locked
Erro ao rodar aplicação mvc no iis 8 RRS feed

  • Dotaz

  • Preciso de ajuda pois está aparecendo o erro abaixo ao tentar rodar uma aplicação C#/ASP.NET MVC4 utilizando o NetFramework 4.5.
    A mesma configuração no IIS 7 em outro servidor funciona normalmente.

    O que pode ser ?

    HTTP Error 403.14 - Forbidden
    The Web server is configured to not list the contents of this directory.
    
    Most likely causes:
    A default document is not configured for the requested URL, and directory browsing is not enabled on the server.
    
    Things you can try:
    If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
    Enable directory browsing using IIS Manager.
    Open IIS Manager.
    In the Features view, double-click Directory Browsing.
    On the Directory Browsing page, in the Actions pane, click Enable.
    Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.
    
    Detailed Error Information:
    Module	   DirectoryListingModule
    Notification	   ExecuteRequestHandler
    Handler	   StaticFile
    Error Code	   0x00000000
    Requested URL	   http://localhost:80/
    Physical Path	   C:\inetpub\wwwroot
    Logon Method	   Anonymous
    Logon User	   Anonymous
    
    More Information:
    This error occurs when a document is not specified in the URL, no default document is specified for the Web site or application, and directory listing is not enabled for the Web site or application. This setting may be disabled on purpose to secure the contents of the server.
    View more information »

    čtvrtek 13. února 2014 16:50

Odpovědi

  • Hi,

    Have you tried the suggestion provided by the message:

    Things you can try:
    If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
    Enable directory browsing using IIS Manager.
    Open IIS Manager.
    In the Features view, double-click Directory Browsing.
    On the Directory Browsing page, in the Actions pane, click Enable.
    Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.

    In addition, I would like to suggest you post in the IIS forum in English:

    http://forums.iis.net/

    Regards,

    Yan Li


    Regards, Yan Li

    • Označen jako odpověď Yan Li_ úterý 25. února 2014 1:47
    pátek 14. února 2014 2:57