none
MDT 2013 - VMware vSphere Hypervizor Critical failed

    Dotaz

  • Zdravím,

    dostal jsem se do poměrně vážných problémů s MDT 2013. V případě nasazení image (jedná se o klasický install.wim) spadne hypervizor ve kterém je uložen server s MDT 2013/WDS do pink screenu (obdoba Microsoft blue screenu). Jedná se o kritickou chybu, ve které je nutné natvrdo otočit hypervizor.

    Scénář:

    Podkladový hypervizor na kterém je uložen deployment server je VMware vSphere ESXi 5.1 U1.

    Nad Hypervizorem je VMware vCenter Server 5.1 U1 (Microsoft Windows platforma)

    Operační systém deployment serveru: Windows 2012 R2 Datacenter

    Služby: Windows ADK for 8.1, Microsoft Deployment Toolkit 2013, Windows Deployment Services.

    DHCP server běží na jiném serveru Windows 2008 R2 Datacenter. DHCP server má namířený TFTP server služby WDS.

    Jsem jediný, koho takhle nový MDT 2013 vypekl? Předpokládám, že na Hyper-V s tímto problém nebude, nicméně VMware je natolik majoritní hypervizor, že si jej nemohu dovolit ignorovat a tento problém bych rád vyřešil. Mohu zkusit jiný podkladový OS (Windows 2008 R2), protože s Windows 2012 jsem měl dost problémů v System Center 2012. 

    Všem díky za pomoc s vyřešením.

    S pozdravem a přáním pěkného dne

    Tomas Herzinger



    22. prosince 2013 13:01

Odpovědi

Všechny reakce

  • Zkusil jsem to rozjet na jiném nodu, který má odlišný hardware, jen má stejnou verzi vSphere 5.1 U1.

    Zkusil jsem MDT 2013 rozjet i na OS Windows 2008 R2 Datacenter.

    Operačním systémem to není, dokonce ani hardwarem to není. Vypadá to, že MDT 2013 má dost závažné problémy a na internetu o tom není ani zmínka :-)

    24. prosince 2013 11:56
  • ahoj Tomáši, pokud ti padá hypervisor VMware, obrať se se svým problémem na společnost VMware, tohle je fórum o produktech Microsoftu ...

    Michal Zobec | IT Consultant, Lightning Group Company | Michal Zobec Blog | Virtuální PC Blog | Můj profil na LinkedIn
    V případě, že se vám zdají moje příspěvky užitečné, označte je prosím.
    Pokud vám moje příspěvky poskytly řešení vašeho problému, označte je jako odpovědi.


    25. prosince 2013 23:59
  • Ahoj Michale,

    Vážně si myslíš, že mě tohle nenapadlo? :-)

    Už se stalo. 

    S pozdravem a přáním pěkného dne

    Tomáš Herzinger

    26. prosince 2013 19:22
  • a jak jsi dopadl?

    Michal Zobec | IT Consultant, Lightning Group Company | Michal Zobec Blog | Virtuální PC Blog | Můj profil na LinkedIn
    V případě, že se vám zdají moje příspěvky užitečné, označte je prosím.
    Pokud vám moje příspěvky poskytly řešení vašeho problému, označte je jako odpovědi.

    26. prosince 2013 19:53
  • vyřešil jsem to.

    27. prosince 2013 11:43
  • ale jak? problém byl tedy na straně VMware vSphere ESXi?

    Michal Zobec | IT Consultant, Lightning Group Company | Michal Zobec Blog | Virtuální PC Blog | Můj profil na LinkedIn
    V případě, že se vám zdají moje příspěvky užitečné, označte je prosím.
    Pokud vám moje příspěvky poskytly řešení vašeho problému, označte je jako odpovědi.


    27. prosince 2013 12:24
  • To se špatně hodnotí.

    Problém je na straně ovládačů síťovek.

    1. WDS v kombinaci s MDT z nějakého podivného důvodu špatně komunikuje s ovládači pro E1000 a E1000E (což je věc Intelu, pokud to chceš brát takhle).

    2. Po aplikaci VMware VMXNET3 hypervizor nespadl, nicméně z vyjádření jsem pochopil, že může být problém i na straně ovládačů řadičů SAS.

    Z mého pohledu je tohle nestandardní chování aplikace, protože Intel E1000 využívají standardní base drivery, které jsou odlazené zvlášť pro operační systémy Windows, byť VMware v dokumentaci doporučuji využívat hlavně VMXNET3 síťové adaptery, protože jsou lepší z hlediska propustnosti.

    Ještě uvádím, že problém byl detekován v případě, že se image nahrával na virtuální instanci VMware. 

    V případě fyzického PC, pro který je MDT ve své podstatě určen, jsem problém nezpozoroval, nicméně sám uznáš, že pokud se MDT odlazuje, tak nejlépe se jeho funkčnost testuje na virtuálních instancích a pád hypervizoru je critical problém. Kdyby se mi to stalo u zákazníka, píšu na support.


    27. prosince 2013 12:44
  • jasně, chápu, mě to třeba ve virtuálu neblbne, ale já testuju desktop OS jen na VMware Workstation na mé pracovní stanici.

    Michal Zobec | IT Consultant, Lightning Group Company | Michal Zobec Blog | Virtuální PC Blog | Můj profil na LinkedIn
    V případě, že se vám zdají moje příspěvky užitečné, označte je prosím.
    Pokud vám moje příspěvky poskytly řešení vašeho problému, označte je jako odpovědi.

    27. prosince 2013 13:39