none
Občasný problém s připojením iSCSI targetu po rebootu serveru

    Dotaz

  • Náš Windows Server 2003, resp. iSCSI initiator 2.08 má nějaké problémy s připojováním iSCSI targetu po rebootu serveru. Často se po restartu serveru objeví v systemovém logu mnohokrát Event ID: 43, Source: iScsiPrt, Description: Target failed to respond in time for login request.

    Nepřipojí se patřičný iSCSI lun a tak nejsou po restartu dostupné žádné oddíly ze zmíněného uložiště!

    Našel jsem na fóru QNAPu následující diskusi, která zmiňuje, že je problém s použitím CHAP autentikace.
    http://forum.qnap.com/viewtopic.php?p=161090

    CHAP my sice využíváme, ale proč by s ním měl být problém u iSCSI jen po restartu serveru? Když pak ručně target normálně připojím, resp. ho v initiatoru odeberu a následní připojím i s použitím CHAP autentikace, tak vše funguje normálně.

    Kde může být problém?


    středa 20. července 2011 10:57

Odpovědi

  • Jasný, ale myslel jsem vytvořit nějaký target přímo na tom serveru. No ale tobě se to podařilo připojit k jinému bez problémů. Takže bych viděl dvě řešení - 

    1. aktualizovat firmware

    2. pokud se to nespraví reklamovat a koupit něco, co bude fungovat

    Když je něco špatně naimplementováno, tak se s tím holt nedá nic jiného dělat.

    úterý 26. července 2011 23:04

Všechny reakce

  • Nemáš možnost si nainstalovat WS2008R2 a do něj si přidat iSCSI Target a pak vyzkoušet, jestli to běhá normálně?

    Je docela dobře možné, že ta implementace v QNAPu je určitým způsobem nedokonalá a tudíž vede ke zmíněným problémům.

    PS: problémy se začaly objevovat až po nějaké době, nebo je to od začátku?

    středa 20. července 2011 13:16
  • Máme to nasazené teprve cca měsíc a na začátku jsem problémy nepozoroval. To jsme ale jeli notnou chvíli bez CHAP ověřování. Jak ale říkám, problémy se objevují jen po restartu. Když target připojím ručně, tak to šlape bez jakýchkoliv problémů i s CHAP autentikací. Určitě to někdy po restartu už ale naběhlo v pořádku, to bych si toho určitě všiml, kdyby ne. Vypínat autentikaci přes CHAP bych však chtěl až jako poslední variantu.

    WS2008R2 si mohu nainstalovat jedině jako trialku. Možná to zkusím.


    středa 20. července 2011 14:05
  • Tak jsem teď vyzkoušet iSCSI target z QNAP TS-259 Pro+, což je menší model od toho co máme v produkčním prostředí, připojit přes iSCSI initiator ve W2K8 R2 a zde mi to funguje s CHAP autentikací i po restartu serveru. Bez problému se to připojuje.
    pátek 22. července 2011 8:37
  • Právě jsem zjistil, že iSCSI target ze zařízení QNAP TS-559 Pro II Turbo NAS, který používáme v produkčním prostředí, se ve W2K8 R2 serveru chová v podstatě úplně stejně, jako je popsáno výše, že se nám stává na produkčním Windows Serveru 2003 s iSCSI initiatorem verze 2.08.

    Po restartu serveru W2K8 R2 je uvedený iSCSI target ve stavu Inactive. Pokud po restartu jdu do v iSCSI Initiator > Properties > Add session > Connect To Target   a zde zadám znovu přihlašovací údaje a to potvrdím, tak se mi target opět bez problému připojí do systému.

    V logu W2K8 R2 se po restartu objeví následující chyby a varování týkající se iSCSI

    --
    Source: iScsiPrt  Event ID: 1  Level: Error
    Initiator failed to connect to the target. Target IP address and TCP Port number are given in dump data.
    --
    Source: MSiSCSI  Event ID: 113  Level: Warning
    iSCSI discovery via SendTargets failed with error code 0xefff0003 to target portal *192.168.70.15 0003260 Root\ISCSIPRT\0000_0 .
    --
    Source: MSiSCSI  Event ID: 121  Level: Warning
    The firewall exception to allow Internet Storage Name Server (iSNS) client functionality is not enabled. iSNS client functionality is not available.
    --
    Source: iScsiPrt  Event ID: 70  Level: Error
    Error occurred when processing iSCSI logon request. The request was not retried. Error status is given in the dump data.
    --
    Source: iScsiPrt  Event ID: 10  Level: Error
    Login request failed. The login response packet is given in the dump data.

    pátek 22. července 2011 10:26
  • Jasný, ale myslel jsem vytvořit nějaký target přímo na tom serveru. No ale tobě se to podařilo připojit k jinému bez problémů. Takže bych viděl dvě řešení - 

    1. aktualizovat firmware

    2. pokud se to nespraví reklamovat a koupit něco, co bude fungovat

    Když je něco špatně naimplementováno, tak se s tím holt nedá nic jiného dělat.

    úterý 26. července 2011 23:04