Failure when expanding disk (Windows Server 2016)


  • We have several Windows 2016 Std with Hyper-V role installed. Standalone server

    Quite often, when we are trying to modify running VM with Expand Dynamic disk operation for guest OS - we have a problem. If we are expanding not a system drive - VMs is "reachable" with ping, it looks working, When we are looking inside guest VM - the volume that was modified - is in "freezed" state. Disk management - hanging, Open via explorer - waiting forever/not responding. A lot of errors related to volume.

    When we are changing system drive (same Expand operation) - VM stop responding at all (ping, RDP, etc).

    When VM is in stopped state - same operation goes without a problem.

    Host 2016 server event logs - doesnt have any useful info/errors, etc.

    We waited up to 20 min, then tried to cancel operation, restart HV VM management service.

    But the only possible way that we found for restoring VM was to RESET HyperV host.

    We were able to reproduce couple of times with VMs based on 2012 R2 and 2016 guest OS. Periodically - it goes well, without problem for same VMs. 

    With 2012R2 - there is no such problem, we made same operation hundreds of times.

    That is crazy solution, for such simple operation when VM is large SQL server (1,5 TB RAM, etc), and should be 99,9% uptime. Please help to find out what can be the reason of that problem.

    čtvrtek 1. března 2018 9:05

Všechny reakce

  • Hi ,

    This is a quick note to let you know that I am currently performing research on this issue and will get back to you as soon as possible. I appreciate your patience.

    If you have any updates during this process, please feel free to let me know.

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    pátek 2. března 2018 9:40
  • Hi Candy,

    We are suffering from the exact same issue. Hyper-V 2016 host, Server 2016 VM.

    VM gets unresponsive during online disk expansion in SCVMM. When restarting VM it gets into an endless stopping state.

    We are unable to kill the VM Process on the host, so the only remaining option is to restart the host. (VM is not able to live migrate to another node anymore) In our case the host is also stuck in shutting down cluster services forever, so a hard reset of the host is the only solution for us.

    Very bad issue!

    středa 28. března 2018 12:38
  • I have exactly the same problem on 2 hyperv Cluster based on Windows 2016 !

    No Problem on 2012 R2 cluster.

    2016 become a real nightmare.

    I have open a case on Microsoft. The case is close because Microsoft Engineer say : It's a know behavior on 2016, so it's normal !!!!!!

    It's and critical problem that crash HyperV HOST !!!!

    What's more it's a regression

    Microsoft Please Wake Up !!! Quickly

    pondělí 16. dubna 2018 10:21
  • Hello,

    We have exact same issue on our WS2016 Hyper-V cluster, SCVMM, Veeam, 3Par storage.

    čtvrtek 7. června 2018 11:55
  • Hi

    We had just this issue a couple of days ago. Do we know if Microsoft is working on this? Until this is solved, or get an explanation. I dont Think we will feel safe to do expansions of disks. We have SCVMM with Fujitsu storage on ISCSI.

    Best regards,


    pátek 8. června 2018 8:38
  • I've experienced a similar issue.

    We're using Windows Server 2016 Datacenter Core installation, running a Hyper-V cluster and using Starwind SDS.  Most of the time we run a disk expansion operation and it works fine.  However, on 3 occasions now this has hung and never seems to recover.  I've let it run 24 hours+ on one occasion and the progress bar never advances to even one bar. 

    As others have reported, I cannot stop the operation, restart/shutdown the VM, and the only fix so far has been to reboot the host. 

    středa 13. června 2018 15:18
  • Hello Candy,

    Any news about topic? I have the same issue with our cluster Hyper-V 2016... ;(

    Hardware: (DELL blades, DELL storage, iSCSI)


    Eduard Marchenko

    středa 11. července 2018 5:39
  • Have had this issue for months. We actually need to stop the VM's affected by this error to expand the disk while the VM is offline. There is no difference if we try to do online disk expansion in VMM or failover cluster manager

    Microsoft support could not solve the case, and suggested we opened a premium support case. Isn't online vmdisk resizing supported anymore? What is going on here?

    • Upravený tony_vage pondělí 27. srpna 2018 12:09
    pondělí 27. srpna 2018 12:09
  • Has anything come of this? We just had a similar issue.
    středa 19. září 2018 19:58