none
Oprávnění v XP..?

    Dotaz

  • Zdravím,

    mám Windows XP Professional a za boha se mi nedaří rozjet účet pod Administrátorem...po instalaci se vytvoří účet uživatele, který by měl mít "rootovská" oprávnění, ale nemá je ...když chci z cmd spustit jednu službu "file.exe -install", napíše "přístup byl odepřen"...našel jsem přímo na podpoře microsoftu, jak se odemyká účet administrátora...v registrech HKLM/......../SpecialAccount jsem přidal hodnotu DWORD "Administrator" a změnil stav z "0" na "1" ...Administrátor se v nabídce objevil - ovšem ten samý problém...opět nemám oprávnění ...

    Když najedu do stavu nouze a dám Administrátor, pak vše funguje jak má ...službu nainstaluji a opravdu se to chová jako admin....ale ve stavu nouze je to nežádoucí....prosím, co mám ještě udělat, abych hned po bootu byl PLNOHODNOTNÝ admin..? Vím, že existuje ještě služba, která je NAD adminem a pomocí PSEXEC se takhle programy spouštět dají, ale takhle to nechci ...chci být po bootu jako admin a všechny programy, které roota vyžadují, aby mi fungovaly...

     

    děkuji

     

    EDIT: Přes ten psexec to samozřejmě funguje ...ale to je hodně NE-user friendly...max vytvořit bat soubor, ale pořád to neřeší problém, proč nejsem admin :)

     



    • Upravený 16. září 2011 14:33
    16. září 2011 13:59

Odpovědi

  • net localgroup adminisrators říká, kdo je členem skupiny Administrators.

     

    K čemu nemáte práva? Jako člen skupiny administrátors máte právo si všechno nastavit, ne že máte právo všechno provést.

     

    Práva jsou nastavovat. Můžete je přidělit nebo odebrat. O jakých právech se tu bavíme? (NTFS soubory, NTFS registry, sdílení, blokování funkcí, ...)

     

    Možná by pomohlo, kdyby jste si nejprve o tom něco přečetl.


    JCH
    17. září 2011 8:56

Všechny reakce

  • DD,

    no něco máte evidentně špatně. Co všechno vám nefunguje? Podívejte se jestli je uživatel členem skupiny administrators.

    Příkaz net localgroup administrators vám vypíše všechny členy skupiny administrators.

     

    Máte alespoň představu jestli to v posledních 3 měsících někdy fungovalo?

    Pokud ano můžete se vrátit obnovou systému do doby, kdy to fungovalo.

    Start -> Nápověda a odborná pomoc -> Vrátit změny nástrojem obnovení systému

     


    JCH
    16. září 2011 16:31
  • Jedná se o naprosto čistou instalaci, tudíž to nefungovalo nikdy ..příkaz: "net localgroup administrators" vypíše:

     

    "Došlo k systémové chybě 1376

    Zadaná místní skupina neexistuje"

    Což by evidentně mělo být špatně ...ale jak říkám, jedná se o naprosto čistou instalaci, kde jako uživatele vyplním nějaké jméno ..Účet Administrator jsem v registrech opět zrušil, pač je to evidentně zbytečné (chová se totiž stejně) ...vzhledem k tomu, že tato skupina neexistuje a nechápu proč, můžu ji nějak vytvořit? Např v nouzovém režimu jako admin?

    Něco jak v linuxu: "sudo groupadd administrators" ...?

    16. září 2011 18:20
  • Problemem bude to "Zadaná místní skupina neexistuje". Kdyz nemate skupinu Administrators, nemuzete mit administratorska prava!

    Bojím se, že nově vytvořená skupina nebude mít správný SID. O název totiz nejde nejde.

    To není na opravu (alespon ja bych nevedel jak na to). Doporucuji jeste jednou udelat cistou instalaci a zkusit hned po instalaci jestli prikaz net localgroup administrators funguje. Mozna je tvoje instalační médium poškozené, zkus jine instalacni CD.


    JCH
    16. září 2011 20:01
  • Bohužel to není poprvé, co se mi tohle stalo ..stává se to teda velmi zřídka, ale stává ..Instalačky samozřejmě originální nemám, ty už jsou někde za zenitem, ale hádám, že je úplně jedno, kde si jakou XP Profi stáhnu (ať už SP2 nebo SP3 - jde nejspíš jen o klíč) ...mám 3 různá média a u SP3 se mi to podařilo rozběhat i bez psexec ...čili na příkaz "net localgroup administrators" opravdu reaguje úspěšně...

    Ale i u toho prvního media to v minulých instalacích fungovalo...a nevím, kde by dotyčný (ten, co tento systém instaloval) mohl v instalaci udělat chybu..to snad ani nejde...kór takovou, aby se nevytvořila skupina Administrators, to opravdu hledím...každopádně na jiný noťas jsem nainstaloval onu zmiňovanou SP3 a vše ok.. i tak mi to ale vrtá hlavou..

    každopádně díky za rady

    16. září 2011 21:01
  • Tak zkusil jsem instalaci dalšího notebooku, net localgroup říká, že oprávnění mám a pro nějaké služby opravdu práva mám, ale pro jiné zase ne ..tohle chování windows byl přesně důvod, proč jsem je zahodil. Zajímalo by mě, kolik možností oprávnění tady vlastně je ...? Není možné, abych pro něco práva admina měl a pro něco zas ne ..někdy zas nemám práva vůbec (viz příspěvky výše), ale někde to zas funguje úplně normálně - tak jak by mělo. Instalaci provádím samozřejmě všude stejně

    Pokud by se našel někdo, kdo toto chování může vysvětlit, byl bych moc rád..

     

    děkuji

    • Upravený 17. září 2011 8:34
    17. září 2011 8:34
  • net localgroup adminisrators říká, kdo je členem skupiny Administrators.

     

    K čemu nemáte práva? Jako člen skupiny administrátors máte právo si všechno nastavit, ne že máte právo všechno provést.

     

    Práva jsou nastavovat. Můžete je přidělit nebo odebrat. O jakých právech se tu bavíme? (NTFS soubory, NTFS registry, sdílení, blokování funkcí, ...)

     

    Možná by pomohlo, kdyby jste si nejprve o tom něco přečetl.


    JCH
    17. září 2011 8:56
  • Asi se na to dívám z jiného úhlu pohledu než Vy, tak zkusím můj dotaz ještě objasnit:

    Podívejte se, jestliže nainstaluji systém, nainstaluji program a ten program funguje, tak to samé očekávám od jakékoliv další instalace ...je jedno o jakou službu jde, o jakých právech se bavíme, to není vůbec podstatné ...jde mi o to, že udělám 5x to samé a pokaždé s jiným výsledkem ...

    Ano, jdou přidělovat práva, jde hodně věcí nastavit..v podstatě nemusím řešit vůbec nic, stáhnu si psexec.exe a nepotřebuju na to ani skupinu "administrators". Vždycky jde všechno nějak obejít a poradím si s tím...já ale chci, aby mi to fungovalo tak, jak by mělo...

    Abych instaloval systém pokaždé jinak, toho bych si za těch 20let všimnul. Nedělám nic jiného, než že vyplním nick, celé jméno uživatele a pole heslo nechávám prázdné. Nic víc, nic míň...ono tam nic jiného taky moc dělat nejde, když nepočítám rozdělení disků...takže chybu v instalaci vylučuji..a podle mě prostě není normální, abych z 5 instalací dostal pokaždé jiný výsledek...Jsem zvyklý z jiných OS, že já kočíruju systém a ne systém mě...to je vše.

    Nemyslím to nijak zle, snad to tak nebude pochopeno...jen mi nejsou jasné rozdílné výsledky při totožných operacích

    17. září 2011 19:20
  • No ale stále jsme se nedozvěděli co je rozdílné.

     

    Mám za sebou stovky instalací Windows a pokud nebylo poškozené instalační médium nesetkal jsem se s problémem. Prostě děláte něco jinak než je obvyklé.

    Bylo těch 5 instalací WinXP třeba ze stejné edice Windows? (Home/Professional/...)


    JCH
    17. září 2011 19:35
  • Jasný ...ne všech 5, ale 3 z nich určitě ...ale všech 5 bylo Professional, jen jedna instalačka byla s SP2 a druhá v sobě měla už SP3..Takže zkusím konkretizovat:

     

    Nainstaluji systém, naprosto čistý, bez čehokoliv jiného..nainstaluji FW a antivir Comodo. To dělám jako první. Poté instaluji služby, které potřebuji pro práci (služby Vám nic nejspíš neřeknou, jsou to víceméně interní záležitosti, čili software ušitý na míru potřebám - je k tomu potřeba terminál Telium 2 a např k tomu program LLT). Tento program LLT vyžaduje konfiguraci COM portu (terminál je USB a automaticky se nainstalují ovladače Sagem Telium), ve správci zařízení pak přibude položka COM4 Sagem Telium....Tento COM port pak musím přidat v tom programu LLT...jenže...políčko "přidat" je zašedlé...nechápal jsem proč...pak mě napadlo, že to může být právami.. Tak jsem to zkusil přes psexec.exe a ejhle, políčko se odbarvilo a mohl jsem přidat tento COM port.

    U jiné instalace toto políčko bylo HNED odbarvené, čili měl jsem práva i bez psexec.exe. A i spolupracovník říkal, že konkrétně on neměl nikdy problém s právama. Ale něco je prostě jinak..nevím, jestli na to nemůže mít vliv třeba i to Comodo, ale to si nemyslím...resp určitě nemůže za to, že se nevytvořila skupina Administrators.

    Nastaly tedy 3 stavy:

    a) nemám vůbec skupinu administrators

    b) mám skupinu administrators, služby, které potřebuji můžu normálně spouštět, ale v programu LLT mám políčko "přidat" zašedlé - nejde kliknout

    c) funguje vše

     

    A ještě mi nastal jeden zajímavý stav, kdy jsem to políčko "přidat" měl zašedlé a na druhý den nebo po restartu nebo nevím po čem se prostě "samo" odbarvilo..Samozřejmě jsem mezitím laboroval, takže to "samo" je zavádějící...mohl jsem udělat něco, co si nevybavuju, že by na to mohlo mít vliv...ale prostě se mi podařilo to nějak odbarvit i bez použití psexec.exe.. A např u Windows 7 když kliknu v tomto LLT zase na definici COM portu, tak tam jen problikne okno (otevře > zavře), tudíž ho nemůžu nastavit ...protože jsem to už ale nastavené měl předtím, tak jsem to neřešil..ale opět divný stav. Kdybych chtěl COM port ale změnit, tak mi to asi nepůjde..nebo bych tomu zase musel nějak pomoct

     

    Díky psexec.exe vždy dosáhnu toho, co potřebuji, ale abych u každého dalšího programu používal tuto utilitu, to je prostě špatně..


    EDIT: takže, možnost b) se mi asi podařilo vyřešit ...antivirový program a Firewall Comodo pouští programy v tzv SandBoxu a spustil přes něj tedy i LLT...jakmile jsem zadal možnost "Nespouštět v SandBoxu", tak se to tlačítko "přidat" odbarvilo ... tato možnost tedy odpadá - vyřešeno. Zbývá tedy už jen vysvětlení absence skupiny "administrators"
    • Upravený 18. září 2011 9:45
    18. září 2011 7:45