none
IE8 vs Adobe reader 9.2 - pdf stahovani

    Dotaz

  • Zdravim, kdyz chci stahnout nejaky pdf soubor z webu (a nemam moznost 'ulozit jako') tak se mi automaticky stahne do Tempu a pak okamzite otevre v adobe readeru (mam zakazane adobe doplnky).

     Co a kde nastavit, aby se mi zobrazoval dotaz, kam ho chci ulozit?

    Nebo je koncepce myslena tak, ze se pdf maj otevirat v IE a pak teprv pres adobe menu soubor ulozit? OS = win7.
    pondělí 7. prosince 2009 9:51

Odpovědi

  • Ono totiž toto provádí ActiveX (AcroIEHelperShim a pdfshell - nenajdete, nezakážete v IE, plus to není skované pod samotnou příponou PDF). Adobe jsou pěkně otravní, viz jejich  profláklá Bonjour Service...

    Mimo postupu pro vypnutí zobrazení v prohlížeči (který u mě na XP funguje) nutno možná ještě otevřít registr a pohrát si s (po záloze a na vlastní nebezpečí)...

    HKEY_CLASSES_ROOT\AcroExch.Document.7 > EditFlags změnit na "00 00 00 00" (bez uvozovek a zavřeným IE a PDF)
    HKEY_CLASSES_ROOT\AcroPDF.PDF.1 > EditFlags na "00 00 00 00" (bez uvozovek a zavřeným IE a PDF)
    • Označen jako odpověď lukval pondělí 7. prosince 2009 13:41
    pondělí 7. prosince 2009 12:32
    Vlastník

Všechny reakce

  • Ahoj,
    asi jsi nastavil ze se .pdf ma automaticky otevirat (neptat se). O jaky OS se jedna?

    MP
    pondělí 7. prosince 2009 10:18
    Moderátor
  • Ahoj, OS = win7 x64 ent.

    No, ja uz si nejsem vedom, ze bych zaskrtnul se neptat. Samotny support od adobe mi poradil nainstalovat Firefox :-))

    Asi zkusim odinst. a nainst.

    L.

    EDIT:
    Odinst. a nainst. nepomohlo.
    Myslim ze to je v zakladni "koncepci", proste bud pdf otevirat primo v IE (a pak ulozit) nebo primo v Adobe (a pak ulozit). Neco jako 'Always ask before opening this type of file' ve win7 pro pdf neni.


    pondělí 7. prosince 2009 10:35
  • Dobrý den,
    Adobe Support je opravdu chytrá horákyně (viz citace z instalační nápovědy Adobe Reader "When you install Acrobat or Adobe Reader on a system that includes a browser, you automatically configure the browser to open PDF files.") :-)

    Mám Windows XP a IE8, musím říci, že jsem instaloval Adobe Reader 9 kompletně i s doplňky pro IE a Firefox (tyto doplňky [ActiveX] umožňují zobrazit PDF v okně prohlížeče), do doby instalace (vyzkoušeno právě na čistém stroji) se IE i Firefox ptají co se souborem PDF udělat, po instalaci Adobe Reader se ani jeden prohlížeč neptá a oba ho automaticky stáhnou (Firefox občas kvůlu tomu otevře novou záložku) a otevřou (v okně prohlížeče nebo spuštěném Adobe Readeru).

    Doporučuji (stejně jako samo Adobe v oné nápovědě) používat volbu pravým tlačítkem nad odkazem na soubor PDF "Uložit cíl jako..." (ve Firefoxu "Uložit odkaz jako...").

    Jinak volba jestli se PDF zobrazí v prohlížeči nebo samostatném Adobe Readeru je schována v menu Úpravy > Předvolby > Internet > Zobrazit PDF v prohlížeči. Pokud tuto volbu odškrtnete a následně vyresetujete ono nastavení pro soubory PDF nikdy se naptat co provést za akci (dost náhodné, někdy je to potřeba, někdy ne > Pokročilé v Typech souborů v Možnostech složky), bude (měl by) se Vás IE opět ptát co se souborem udělat.

    pondělí 7. prosince 2009 11:46
    Vlastník
  • jj, XPesa jsou jasny, me jde o 7cky.
    Nejaky figl v registrech apod.
    pondělí 7. prosince 2009 11:52
  • Koukal jsem do HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046} ... nic :(

    MP
    pondělí 7. prosince 2009 11:55
    Moderátor
  • Mě jsou ty 7 též jasné a myslím, že se onen fígl od XP snad moc nezměnil...

    Tak změnil :-( Lehce ztížil... a i na ty registry tedy přišlo... pardon.
    pondělí 7. prosince 2009 11:56
    Vlastník
  • Zkousel jsem - soubor se otevre mimo IE ale neprisel jsem na to jak vyresetovat to "ptani se" (viz reg vyse) :(

    MP
    pondělí 7. prosince 2009 11:57
    Moderátor
  • Ono totiž toto provádí ActiveX (AcroIEHelperShim a pdfshell - nenajdete, nezakážete v IE, plus to není skované pod samotnou příponou PDF). Adobe jsou pěkně otravní, viz jejich  profláklá Bonjour Service...

    Mimo postupu pro vypnutí zobrazení v prohlížeči (který u mě na XP funguje) nutno možná ještě otevřít registr a pohrát si s (po záloze a na vlastní nebezpečí)...

    HKEY_CLASSES_ROOT\AcroExch.Document.7 > EditFlags změnit na "00 00 00 00" (bez uvozovek a zavřeným IE a PDF)
    HKEY_CLASSES_ROOT\AcroPDF.PDF.1 > EditFlags na "00 00 00 00" (bez uvozovek a zavřeným IE a PDF)
    • Označen jako odpověď lukval pondělí 7. prosince 2009 13:41
    pondělí 7. prosince 2009 12:32
    Vlastník
  • Ve win7 jsem nic podobneho jako resetovat volbu 'nikdy se neptat' nenasel.

    Tak me napadlo, asociovat pdf s jinym programem napr. CoolPDFReader nebo FoxitReader a kdyz bych potreboval silny delo adobe, otevru to v nem manualne :)
    pondělí 7. prosince 2009 12:38
  • http://twitpic.com/sj00z

    Tedy nevím, jak ve Windows 7, ale já mám ve Windows XP vymalováno...
    • Označen jako odpověď lukval pondělí 7. prosince 2009 13:41
    • Zrušeno označení jako odpověď lukval pondělí 7. prosince 2009 13:41
    • Upravený KazzanMVP, Moderator pondělí 7. prosince 2009 13:42 Obrázek
    pondělí 7. prosince 2009 12:47
    Vlastník
  • HKEY_CLASSES_ROOT\AcroExch.Document.7 > EditFlags změnit na "00 00 00 00" (bez uvozovek a zavřeným IE a PDF)
    HKEY_CLASSES_ROOT\AcroPDF.PDF.1 > EditFlags na "00 00 00 00" (bez uvozovek a zavřeným IE a PDF)

    Funguje i ve win7, diky!
    pondělí 7. prosince 2009 13:41
  • Tak trochu dodatek pod čarou - jakákoliv aktualizace Adobe Readeru opět tyto klíče do registru zavede (i kontrola instalace), takže se opět žádný z prohlížečů na stáhnutí/otevření opět ptát nebude (nutné opět změnit tyto klíče nebo zakázat jejich úpravu).

    neděle 17. ledna 2010 23:55
    Vlastník