none
Invisible Annotations in VS2017 Black Theme

    Dotaz

  • I've noticed that annotations don't show up when using the black theme in VS 2017.  For example, the picture below has text written into the box but it is invisible. Does anyone have a solution?

    Thanks,
    Simon

    čtvrtek 1. února 2018 14:09

Odpovědi

  • Hi Simon Nuss,

    Yes, I can reproduce the issue using Visual Studio 2017 dark theme (may be other themes have same issue).

    If you click Options->Fonts and Colors->Show settings for Business Intelligence Designers. You will find the Item foreground and background are set to black, and it does not allow to change. Perhaps this is root cause.

    Unfortunately, currently, there's no workaround available for this issue, I'd suggest you change default theme back so that you can normally use the Annotation in SSIS.

    By the way, you can submit a request to UserVoice which in place of SQL SERVER feedback since January 1,2018.

    Thanks for your understanding and support.

    Regards,

    Pirlo Zhang  


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Označen jako odpověď Simon Nuss pátek 2. února 2018 12:56
    pátek 2. února 2018 6:27

Všechny reakce

  • Hi Simon,

    Right-click choose font and change the font color to something else, but yes using the dark theme in VS2017 (I assume) affects how the annotations are seen.


    Arthur

    MyBlog


    Twitter



    • Upravený ArthurZMVP, Moderator čtvrtek 1. února 2018 14:46
    • Navržen jako odpověď Visakh16MVP čtvrtek 1. února 2018 15:46
    • Označen jako odpověď Simon Nuss čtvrtek 1. února 2018 16:08
    • Zrušeno označení jako odpověď Simon Nuss čtvrtek 1. února 2018 16:10
    čtvrtek 1. února 2018 14:45
    Moderátor
  • You can change annotation font to color of your choice by selecting the Ste Annotation Font property as shown below


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    čtvrtek 1. února 2018 15:49
  • That option doesn't work, unfortunately.  In VS2017, with the black theme selected, the selected & applied font color makes no difference.  I've selected red, white, black etc.. and the font is still invisible:


    • Upravený Simon Nuss čtvrtek 1. února 2018 16:12
    čtvrtek 1. února 2018 16:12
  • Hi Simon Nuss,

    Yes, I can reproduce the issue using Visual Studio 2017 dark theme (may be other themes have same issue).

    If you click Options->Fonts and Colors->Show settings for Business Intelligence Designers. You will find the Item foreground and background are set to black, and it does not allow to change. Perhaps this is root cause.

    Unfortunately, currently, there's no workaround available for this issue, I'd suggest you change default theme back so that you can normally use the Annotation in SSIS.

    By the way, you can submit a request to UserVoice which in place of SQL SERVER feedback since January 1,2018.

    Thanks for your understanding and support.

    Regards,

    Pirlo Zhang  


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Označen jako odpověď Simon Nuss pátek 2. února 2018 12:56
    pátek 2. února 2018 6:27
  • Windows 10 Enterprise, VS 2017 (15.7.1): Had same issue in Blue theme, but didn't have to change the font. It was enough to right-click > Set Text Annotation Font... In dialogue box, made no changes - just clicked OK to reapply the existing settings. Could also multi-select to apply to all. Hope those shortcuts help until a permanent fix is made available.
    středa 16. května 2018 21:26