none
IE sa nedokaze pripojit na vonkajsiu IP

    Dotaz

  • Zdravim vas.

    Neprisiel som na problem preco sa mi nedokaze pripojit IE na rekorder umiestneni na lokalnej sieti zadanim verejnej vonkasej IP adresy.

    Situacia:

    Som v lokalnej sieti kde je aj rekorder. Na jeho lokalnu IP sa v pohode konektnem ale ked zadam verejnu IP tak to bud trva strasne dlho alebo sa nepripoji vobec. FireFox a Opera idu v pohode ale tam nieje podpora kodekov. Verejnu IP pingam v pohode z lokalnej siete.

    Ked som mimo lokalnej siete tak to ide v pohode. Co tam vadi exploreru ?

    Dakujem za rady.

    PZ

    sobota 2. května 2015 18:11

Odpovědi

  • Osobne bych "problem" resil pouzitim lokalni IP adresy, pokud by slo jen o konektivitu.

    Doporucuji davat podobne problemy do fora answers.microsoft.com

    M.


    neděle 3. května 2015 6:41
    Moderátor
  • Ahoj.

    Je to bezpečnostní záležitost a je to takhle udělané schválně. Lepší je tohle řešit přes DNS. Pokud bys ale trval na přístupu přes IP, uprav si firewall na zařízení vykonávají NAT. Na Mikrotiku například se to jmenuje Hairpin NAT a řešení by mohlo být nějaké takové

    /ip firewall nat
    add chain=srcnat action=masquerade protocol=tcp src-address="vnitrni rozsah" 
     dst-address="ip nasu" out-interface="inerface lokalni site" dst-port="port"
    
    

    neděle 3. května 2015 15:27
  • Stahni a nainstaluj si Fiddler a podivej se, co se deje.

    MP

    pondělí 4. května 2015 8:13
    Moderátor

Všechny reakce

  • Proč se proboha snažíš z vnitřní sítě dostat na prostředek ve stejné vnitřní síti přes veřejnoyu IP adresu routeru?

    Nebo jsem to pochopil špatně?


    JCH

    sobota 2. května 2015 20:15
  • Osobne bych "problem" resil pouzitim lokalni IP adresy, pokud by slo jen o konektivitu.

    Doporucuji davat podobne problemy do fora answers.microsoft.com

    M.


    neděle 3. května 2015 6:41
    Moderátor
  • Ahoj.

    Je to bezpečnostní záležitost a je to takhle udělané schválně. Lepší je tohle řešit přes DNS. Pokud bys ale trval na přístupu přes IP, uprav si firewall na zařízení vykonávají NAT. Na Mikrotiku například se to jmenuje Hairpin NAT a řešení by mohlo být nějaké takové

    /ip firewall nat
    add chain=srcnat action=masquerade protocol=tcp src-address="vnitrni rozsah" 
     dst-address="ip nasu" out-interface="inerface lokalni site" dst-port="port"
    
    

    neděle 3. května 2015 15:27
  • Pochopil si to spravne a zial aj ja to vnimam ako ty ale zakaznik mi stale trva na svojom ze to chce proste takto ze ked to nacita opera a chrome tak to ma ist aj v Exploreri :-) Preto som sa chcel spytat ze ci je to mozne nastavit a ked nie tak ho proste dotlacim k tomu ze to jednoducho v IE nejde a hotovo.

    PZ

    pondělí 4. května 2015 5:55
  • Ahoj, NAT je okej cez ine prehlaidace to funguje iba IE s tym ma problem a je jedno aka verzia cize predpokladam ze to bude v IE ako bezpecnost by default.

    PZ

    pondělí 4. května 2015 5:56
  • Stahni a nainstaluj si Fiddler a podivej se, co se deje.

    MP

    pondělí 4. května 2015 8:13
    Moderátor