none
windows 7 professional - one or more audio services are not running

    Dotaz

  • I have a windows 7 professional laptop. The audio stopped working suddenly. When i click on the audio icon (with a red x on it) the system tried to troubleshoot the problem. This is the error i see in the troubleshooter.

    One or more audio services isn't is running

    I tried to start the windows audio, windows audio endpoint builder. Neither of them started but gave some error.

    When i tried to restore to a previous version i got an error message that there are some bad sectors on the C drive but could not run the checkdsk on that drive. Instead windows offered me to run it at next reboot. I did multiple reboots but the chkdsk never ran.

    I am don't have a windows reinstall disk. Can somebody point me where i can get the windows OS to reinstall it?

    neděle 21. července 2013 1:19

Odpovědi

Všechny reakce

  • RC

    That largely depends on what version of win 7 you have and if it is retail, or came pre-installed (OEM) on your system.  You can read about the variables here


    Wanikiya & Dyami--Team Zigzag

    neděle 21. července 2013 2:19
    Moderátor
  • >> I tried to start the windows audio, windows audio endpoint builder. Neither of them started but gave some error.

    What would be the exact error message/error code



    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience

    neděle 21. července 2013 8:13
    Přispěvatel
  • Thanks for your response. Here are the error messages i got.

    Service Name: Windows Audio service start
    path to executable: C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted

    Error 1068: The dependency service or group failed to start

    ------
    Service Name: Windows Audio Endpoint Builder
    path to executable: C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted

    Windows could not start the Windows Audio Endpoint Builder service on Local Computer
    Error 193: 0xc1

    neděle 21. července 2013 14:06
  • Yes, the OS came pre-installed with the laptop. Unfortunately there is no backup image on the laptop.

    I have Windows 7 professional with Service pack1 64bit OS

    neděle 21. července 2013 14:08
  • Hi,

    You can contact the Original Equipment Manufacturer (OEM) of your computer for obtaining replacement disks and manuals.

    For computer manufacturer contact information, visit the following Microsoft Web site:

    http://support.microsoft.com/default.aspx?pr=oemphone

    More information about How to replace Microsoft software or hardware, order service packs, and replace product manuals, please see the following KB article:

    http://support.microsoft.com/default.aspx?kbid=326246

    Hope it helps.


    Tracy Cai
    TechNet Community Support

    pondělí 22. července 2013 2:27
    Moderátor
  • Thanks for your response. Here are the error messages i got.

    ------
    Service Name: Windows Audio Endpoint Builder
    path to executable: C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted

    Windows could not start the Windows Audio Endpoint Builder service on Local Computer
    Error 193: 0xc1

    Press WinKey+R to bring up the Run dialog.

    Type the following and press ENTER:

    cmd /k REG QUERY "HKLM\SYSTEM\CurrentControlSet\services\AudioEndpointBuilder" /S

    Copy the output and include with your reply.


    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience

    čtvrtek 25. července 2013 4:38
    Přispěvatel
  • Thanks for your response. I found the ISO and re-installed the OS.

    I know that anything related to MicroSoft OS is a big mess. 

    čtvrtek 25. července 2013 17:41

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\AudioEndpointBuilder
        Start    REG_DWORD    0x2
        DisplayName    REG_SZ    @%SystemRoot%\system32\audiosrv.dll,-204
        Group    REG_SZ    AudioGroup
        ImagePath    REG_EXPAND_SZ    %SystemRoot%\System32\svchost.exe -k LocalSyst
    emNetworkRestricted
        Description    REG_SZ    @%SystemRoot%\System32\audiosrv.dll,-205
        ObjectName    REG_SZ    LocalSystem
        ErrorControl    REG_DWORD    0x1
        Type    REG_DWORD    0x20
        DependOnService    REG_MULTI_SZ    PlugPlay
        ServiceSidType    REG_DWORD    0x1
        RequiredPrivileges    REG_MULTI_SZ    SeChangeNotifyPrivilege
        FailureActions    REG_BINARY    80510100000000000000000003000000140000000100
    000060EA000001000000C0D401000000000000000000

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\AudioEndpointBuilder\Parame
    ters
        ServiceDll    REG_EXPAND_SZ    %SystemRoot%\System32\Audiosrv.dll
        ServiceDllUnloadOnStop    REG_DWORD    0x1


    C:\Windows\system32>
    pátek 27. června 2014 18:11
  • I got exactly the same problem...

    did you fix it?

    how?

    help me !!!

    úterý 17. dubna 2018 2:11