none
WHS 2011 nefunkční IIS7

    Dotaz

  • Dobrý den, mám takový problém. Tady je report:


    Chyba konfigurace
    Popis: Při zpracování konfiguračního souboru, který je vyžadován pro obsloužení tohoto požadavku, došlo k chybě. Prohlédněte si níže uvedené podrobné informace o chybě a příslušným způsobem upravte konfigurační soubor.

    Chybová zpráva analýzy: Nelze načíst soubor nebo sestavení Wssg.RootSite nebo jeden z jejich závislých prvků. Toto sestavení je vytvořeno modulem runtime, který je novější než aktuálně zavedený modul runtime, a nelze je zavést.

    Zdrojová chyba:

    Řádek 57: <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    Řádek 58: <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    Řádek 59: <add assembly="*"/>
    Řádek 60: <add assembly="System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>
    Řádek 61: <add assembly="System.IdentityModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>


    Zdrojový soubor: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config Řádek: 59

    Trasování načtení sestavení: Následující informace mohou pomoci při zjišťování, proč sestavení Wssg.RootSite nebylo načteno.

    WRN: Protokolování vazeb sestavení je VYPNUTO.
    Chcete-li povolit protokolování chyb vazeb sestavení, nastavte hodnotu registru [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) na hodnotu 1.
    Poznámka: Protokolování chyb vazeb sestavení ovlivňuje výkon systému.
    Chcete-li tuto funkci vypnout, odeberte z registru hodnotu [HKLM\Software\Microsoft\Fusion!EnableLog].

     

    ještě výpis z prohlížeče údálostí:

     

    Event code: 3008
    Event message: Došlo k chybě konfigurace.
    Event time: 17.10.2011 12:43:59
    Event time (UTC): 17.10.2011 10:43:59
    Event ID: 9cab6c28daed414498c09b66d6e70de3
    Event sequence: 1
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/ROOT/Connect-1-129633218390199719
        Trust level: Full
        Application Virtual Path: /Connect
        Application Path: C:\Program Files\Windows Server\Bin\WebApps\Client\
        Machine name: WHS
     
    Process information:
        Process ID: 7332
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: HttpException
        Exception message: Nelze načíst soubor nebo sestavení ClientSetupWebsite nebo jeden z jejich závislých prvků. Toto sestavení je vytvořeno modulem runtime, který je novější než aktuálně zavedený modul runtime, a nelze je zavést.
     
    Request information:
        Request URL: https://WHS:65515/connect/default.aspx?get=VersionInfo.xml&LanguageId=1029&64bit=0
        Request path: /connect/default.aspx
        User host address: 192.168.0.7
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 5
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:    v System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
       v System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
       v System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
     
     
    Custom event details:


    Jestli s tím má někdo zkušenosti prosím poraďte.

    pondělí 17. října 2011 11:35

Odpovědi

  • Ahoj,

    nefunguje webový přístup? Instalovaly se nějaké aktualizace? Zkoušel jsi vypnout a zapnout Webový přístup?

    Podívej se na toto fórum:

    http://homeservershow.com/forums/index.php?/topic/2830-remote-web-access-failure-runtime-error/

    nejspíše jsi nainstalval aktualizace .NET Frameworku 4. Je potřeba zkontrolovat ve správci IIS přiřazení .NET Frameworku k jednotlivým poolum.

    Start - Nástroj pro správu - Správce Internetové informační služby - rozklikni název počítače - klikni na Fondy aplikací a napiš, u čeho máš verzi rozhranní v2.0. Hlavně u RootApp by mělo být v4.0.

    Tak to zkontroluj - jestli to tam nebude, tak to nastav správně:

    Citace z webu..

    Ok. So on my working server RootApp is set to v4.0 and Integrated with Identity of ApplicationPoolIdentity. I think if you change that one it should work. I think you can recycle just the application pool but if that doesnt work then recycle IIS. One of those two *Should* do it. Please advise if that works. I'm almost at the point of being able to apply the updates and that will give some peace of mind. 

    pondělí 17. října 2011 11:48

Všechny reakce

  • Ahoj,

    nefunguje webový přístup? Instalovaly se nějaké aktualizace? Zkoušel jsi vypnout a zapnout Webový přístup?

    Podívej se na toto fórum:

    http://homeservershow.com/forums/index.php?/topic/2830-remote-web-access-failure-runtime-error/

    nejspíše jsi nainstalval aktualizace .NET Frameworku 4. Je potřeba zkontrolovat ve správci IIS přiřazení .NET Frameworku k jednotlivým poolum.

    Start - Nástroj pro správu - Správce Internetové informační služby - rozklikni název počítače - klikni na Fondy aplikací a napiš, u čeho máš verzi rozhranní v2.0. Hlavně u RootApp by mělo být v4.0.

    Tak to zkontroluj - jestli to tam nebude, tak to nastav správně:

    Citace z webu..

    Ok. So on my working server RootApp is set to v4.0 and Integrated with Identity of ApplicationPoolIdentity. I think if you change that one it should work. I think you can recycle just the application pool but if that doesnt work then recycle IIS. One of those two *Should* do it. Please advise if that works. I'm almost at the point of being able to apply the updates and that will give some peace of mind. 

    pondělí 17. října 2011 11:48
  • Velice děkuji za odpověď. Nemohl jsem najít kde by mohl být problém. Nenapadlo mě kontrolovat fondy aplikací.

    Vše již funguje v pořádku.

    pondělí 17. října 2011 12:12
  • Tak to je super:)
    pondělí 17. října 2011 12:15