none
SQL Server nutzt mehr RAM als vorgegeben. AWE aktiviert. RRS feed

  • Frage

  • Hallo zusammen,

    ich habe folgende Problem.

    Auf SQL Server 2005 x64 habe ich AWE aktiviert.

    Hier sind die Enstelllungen:

    awe enabled 0 1 1 1

    max server memory (MB) 16 2147483647 10240 10240

    min server memory (MB) 0 2147483647 1024 1024

    Lock Page Memory ist für SQLServer - Account aktiviert.

    Wie man sieht ist Max auf 10240 MB(10GB) eingestellt. Leider laut Task-Manger hat SQLServer Prozess 10.827.568 Kb genommen, dass ist über 10GB

    Ist das OK, oder rechne ich falsch.

    Ich habe noch 10 DB-Instanzen, da wird max server memory 10-20% überschritten.

    DANKE.

     

     

     

     

    Freitag, 6. August 2010 08:28

Alle Antworten

  • Hallo andrej75,

    AWE spielt bei dir sowieso keine Rolle da dies nur für 32-Bit Systeme gilt. Warum er allerdings bei dir mehr Speicher nimmt, kann ich dir auch nicht sagen. Bei mir funktionierte dies bisher immer hervorragend. Vielleicht gibt es da ja ein Problem mit der AWE-Option. Entefrne diese einmal und schaue dann, ob es besser läuft.

     

    Dienstag, 10. August 2010 06:26
  • Hi,

    danke für die Antwort. Ich werde versuchen jetzt AWE abzuschalten. Du meinst, dass man nur max und min einstellt, dann reicht es ?

    Dienstag, 10. August 2010 07:59
  • Hallo andrej75,

    ja das sollte ausreichen. Wie gesagt AWE ist nur für 32-bit Systeme da diese nur 2 hoch 32 bit (4 GB) an Arbeitsspeicher direkt lokalisieren können und daher diese Erweiterung brauchen. 64-bit Systeme können jedoch 2 hoch 64 bit an Arbeitspeicher direkt lokalisieren und soviel Speicher hast du mit Sicherheit nicht in deiner Mschine ;-).

     

     

    Mittwoch, 11. August 2010 06:50
  • Hallo Korodamos,

    es hat nicht geholfen. Der SQL Server hat wieder 10821216 K(laut Taskmanager) belegt. 

    Laut Powershell: 

    PS C:\Documents and Settings\o9001159> Get-Process sqlservr

    Handles  NPM(K)    PM(K)      WS(K) VM(M)   CPU(s)     Id ProcessName
    -------  ------    -----      ----- -----   ------     -- -----------
        722     157 -1678168   -1761696   349 ...26,39  89812 sqlservr

    Freitag, 20. August 2010 08:38