none
Terminalserver wird langsam nach ca. 2 Wochen RRS feed

  • Frage

  • Hallo zusammen,

    ich habe ein kleines Problem und hoffentlich hat jemand einen Tipp.

    Ich habe eine TS-Farm aus 3 Terminalservern (Lastenausgleich) auf denen diverse Programm installiert sind.

    Nach einem Neustart läuft das System sehr flüssig und es gibt keine Problem.

    Nach ca. 2-3 Wochen wird das System dann aber "langweilig"!

    Es macht sich sehr stark bemerkbar im Bereich Office und unserer Kassensoftware (FoxPro).

    Die Anwendungen öffnen sich dann sehr langsam und es wird eine "Diashow"....

    Wenn ich die Server durchstarte, dann ist alles wieder normal und läuft.

    Zu meiner Landschaft:

    Die Terminalserver, Anwendungsserver und der DC sind alles 2012 R2 und laufen als VM (VMware)

    Das SQL-Cluster sind zwei Server 2008

    Der DC ist auch Printserver und wir haben nur Kyocera Drucker im Einsatz....ich verwende fast nur den KX Treiber

    Die User greifen mit ThinClients (Igel) per RDP auf die Server zu

    Die Hardwarebeschleunigung in Word 2010 habe ich auch schon deaktiviert

    Bin für jeden Tipp zu haben....

    Danke

    Mittwoch, 17. Juni 2015 10:22

Antworten

  • Danke für die Antworten....

    Ich werde die Tipps dann halt "durchführen"...

    Ich habe sonst die Server auch einfach neu gestartet und wollte nur mal in die Runde fragen :)

    Dann kann man(n) aber sicher sein......es läuft alles richtig und nicht irgendwo Mist in der Konfiguration oder so.

    Danke an euch

    Donnerstag, 18. Juni 2015 11:47

Alle Antworten

  • Hallo Torben,

    ich hatte ein ähnliches Problem mit den Terminalservern. Bei mir lag es an einer JAVA Anwendung welche den Arbeitsspeicher voll geschrieben hat.

    Da das Problem nicht von uns lösbar (Software von Extern) war haben wir die TS jeweils einmal pro Woche an unterschiedlichen Tagen neustarten lassen

    Gruß Benjamin


    Benjamin Hoch
    MCSA: Microsoft Certified Solutions Associate - SQL Server 2012,
    MCSA: Microsoft Certified Solutions Associate - Windows Server 2012,

    Mittwoch, 17. Juni 2015 10:39
  • Am 17.06.2015 12:22, schrieb Torben_Rö:
    > Nach ca. 2-3 Wochen wird das System dann aber "langweilig"!
     
    Viel mehr Speicher in den TS stecken, dann passiert das erst nach 4
    Wochen oder regelmässig, vor dem merkbaren Verlangsamen, rebooten.
     
    Der Speicher fragmentiert sich durch Benutzung, dadurch wirds langsamer
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Mittwoch, 17. Juni 2015 10:40
  • Danke erstmal an euch zwei...

    Den Speicher habe ich auch schon kontrolliert und es ist eigentlich noch genügend frei.

    Was aber ist, es ist immer viel im "Standby" Speicher.....

    Ich habe den TS jeweils 36 GB an Arbeitsspeicher zugewiesen und davon sind immer ca. 20-25 im Standby.

    Den Speicher habe ich auch schon geleert, aber hat auch nicht den erhofften Erfolg gebracht!?

    Mittwoch, 17. Juni 2015 11:25
  • Speicher hin oder her, du musst einfach akzeptieren das, um das Problem zu umgehen, du die Terminalserver turnusmäßig neustarten musst. Das ist bei Windows seit eh und je Gesetz - und viele Mythen lösen sich erst bei einem Neustart.

    Man muss das ja nicht mal selbst tun, ein geplanter Task und alles ist gut. Im Citrix gibt's dafür sogar eine integrierte Option die das übernimmt - und das sagt viel aus, wo doch XenApp so "ausgezeichnet" funktioniert.

    Wir z.B. (RDS Farm, 6+2 Knoten, je 32 GB RAM ~40 User pro Knoten) starten die RDS Server um 1 Uhr nachts neu, die User wissen das, akzeptieren das, und du hast Ruhe, zumal da auch jede Menge Zaubersoftware drauf ist.


    freundliche Grüße Thomas


    Mittwoch, 17. Juni 2015 11:52
  • Hi,
     
    Am 17.06.2015 13:25, schrieb Torben_Rö:
    > Den Speicher habe ich auch schon kontrolliert und es ist eigentlich noch
    > genügend frei.
     
    Nein, ist es nicht. Am Ende ist es wesentlich komplexer, wie MS den
    Speicher handelt und es ist nicht allein die Fragmentierung, aber es ist
    der einfachste Weg es zu erklären.
     
    Der freie Speicher liegt nicht "am Stück" frei vor, sondern nur mal hier
    ein paar MB, da mal ein Gig und dort auch noch ein paar Schnipsel. Nur
    in Summe ist "viel frei".
     
    Nimm eine Tüte Chips und stell sie ins Wohnzimmer in eine Ecke, du wirst
    barfuss ohne Probleme rein uns rausgehen. (das ist der Rebootzustand,
    wenn du aufgeräumt hast) Jetzt nimm die Tüte, öffne sie, gib sie einem
    2-Jährigem, gib ihm 10 Minuten Zeit und geh dann barfuss ins Wohnzimmer
    ...  Die Menge "Raum" sollte reichen, um sauber rein und rauszukommen
    ... tut sie aber nicht. :-)
     
    Genau das passiert deinem Speicher. Der ist wild verteilt und das
    System, die Prozesse müssen sich den freien Platz suchen und
    organisieren. Das kostet Zeit und je mehr, je mehr Organisation es braucht.
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Mittwoch, 17. Juni 2015 12:31
  • Hallo Torben

    Ihr Problem liegt vielleicht an einen pool memory leak . Die Lösung von Benjamin ist am einfachsten.

    http://blogs.technet.com/b/askpfeplat/archive/2013/12/30/troubleshooting-adventure-a-real-life-memory-pool-leak.aspx

    Wie ist der ausgelagerte und nicht ausgelagerte Pool ? Steigen sie ständig mit der Zeit ?

    Task-Manager → Leistung → Arbeitsspeicher

    viele Grüße

    Nathan


    • Bearbeitet TadNa Donnerstag, 18. Juni 2015 08:01
    Donnerstag, 18. Juni 2015 08:01
  • Danke für die Antworten....

    Ich werde die Tipps dann halt "durchführen"...

    Ich habe sonst die Server auch einfach neu gestartet und wollte nur mal in die Runde fragen :)

    Dann kann man(n) aber sicher sein......es läuft alles richtig und nicht irgendwo Mist in der Konfiguration oder so.

    Danke an euch

    Donnerstag, 18. Juni 2015 11:47
  • Hi,
     
    Am 18.06.2015 13:47, schrieb Torben_Rö:
    > Dann kann man(n) aber sicher sein......es läuft alles richtig
     
    Ja, das ist zwar doof, aber korrekt. Regelmässiger Reboot ist die
    einzige Lösung, die "immer" funktioniert. Deswegen hat sie sich wohl
    etabliert.
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Donnerstag, 18. Juni 2015 11:54