none
Ex2010: Plain SMTP-Mails gehen durch, Outlook Mails bleiben in der Queue RRS feed

  • Allgemeine Diskussion

  • Hi,

    ich habe derzeit das Problem, dass per plain SMTP (telnet hostname 25) versendete Mails an einen bestimmten Empfänger zugestellt werden, Mails an denselben Empfänger dagegen, die per Outlook (oder anderem Client) eingeliefert werden, in der Queue hängen bleiben und schließlich mit einem "400 4.4.7 Message expired" zurückgehen. Mails an eine beliebige (ganz sicher nicht existierende) Mailadresse in der Empfängerdomäne bleiben ebenfalls in der Queue. Der Queue Viewer wirft für die Domäne ein "451 4.4.0 DNS query failed" aus.

    Soweit ich sehe, wurden Anfang vergangener Woche Mails an diese Empfängerdomäne noch ausgeliefert. Ich habe keine Konfigurationsänderungen vorgenommen, ein nslookup auf den MX-Record der Empfängerdomäne funktioniert, mein Exchange sendet helo mit rückwärts auflösbarem FQDN.

    Was kann das Problem sein?

    Viele Grüße, Georg.

    • Typ geändert Alex Pitulice Montag, 19. März 2012 07:47 Warten auf Feedback
    Montag, 12. März 2012 12:34

Alle Antworten

  • Hi Georg,

    welche Version setzt du genau ein - SP2RU1? Was sagt das ausgehende SMTP-Log dazu? Erhöh auch mal das SMTP-Logging?

    Kannst du den AV schon ausschließen?


    Viele Grüße
    Christian

    Montag, 12. März 2012 14:54
    Moderator
  • Hi Christian,

    nein, ich bin noch auf SP1RU6. AV läuft nicht auf dem Exchange (sondern auf dem Eingangs-Gateway). Das Event Log sagt: "
    Send connector 45fb...: A DNS failure occurred with the following diagnostic information The DNS query for 'DnsConnectorDelivery':'irs.uni-stuttgart.de':'45fb...' failed with error : ErrorRetry."

    Witzigerweise (?) wurden plötzlich, kurz nachdem ich gepostet hatte, die Mails zugestellt, aber jetzt hängen sie wieder... Ich habe nichts geändert und kann damit nichts anfangen.

    Viele Grüße, Georg.

    Montag, 12. März 2012 15:47
  • Hi Georg,

    sendet ihr nicht über die Gateway? Bis dahin sollte es es doch schaffen...

    Bitte poste einmal die genauen Fehlermeldung inkl. EventID und ohne Pünktchen. Was gibt es noch im SMTP-Send-Log und im ConnectivityLog?
    C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Logs\Connectivity


    Viele Grüße
    Christian

    Montag, 12. März 2012 17:02
    Moderator
  • Hallo Georg,

    welche DNS Server nutzt Dein Exchange, intern oder extern? Welches OS hast Du, 2008 R2? Schau mal hier (ist zwar 2007, könnte aber trotzdem zutreffen): http://social.technet.microsoft.com/Forums/en-US/exchangesvrtransport/thread/5ac614ee-e4fb-41d9-88f0-363f912634b1

    VG, Timo

    Montag, 12. März 2012 21:47
    Moderator
  • Nein, wir empfangen über das Gateway, senden aber direkt. Der genaue Fehler ist:

    Log Name:      Application
    Source:        MSExchangeTransport
    Date:          2012-03-13 11:05:11
    Event ID:      2000
    Task Category: SmtpSend
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      ...
    Description:
    Send connector 45fb5915-23cf-4bc5-b0a7-0151a60e37f9: A DNS failure occurred with the following diagnostic information The DNS query for 'DnsConnectorDelivery':'irs.uni-stuttgart.de':'45fb5915-23cf-4bc5-b0a7-0151a60e37f9' failed with error : ErrorRetry.

    Das SmtpSend-Log sagt dazu gar nichts. Wenn ich durch das Connectivity-Log gehe, dann finde ich in den letzten 30 Tagen ähnliche Einträge für insgesamt 13 Domänen, die meisten für comcast.net. Verwirrend finde ich, dass zumindest manche der Mails offenbar schließlich doch gesendet werden, vermutlich sogar die meisten, sonst hätte ich sicherlich mehr Benutzerklagen.

    SmtpDiag wirft keine Fehler aus...

    Der DNS ist intern, W2K8 R2.

    Im Augenblick scheint mir, dass die Mails rausgehen, sobald ich in der hosts-Datei die IP-Adresse des Mail-Gateways der Gegenseite eintrage... aber warum? Die wird auch per nslookup aufgelöst.

    Viele Grüße, Georg.


    Dienstag, 13. März 2012 13:35
  • Hallo,

    der Fehler steht da im Klartext: "A DNS failure occurred with the following diagnostic information The DNS query for 'DnsConnectorDelivery':'irs.uni-stuttgart.de"

    Aus irgendeinem Grund kann der Exchange den DNS-Namen im Internet nicht auflösen.

    Poste mal Get-SendConnector | fl

    Stelle sicher, das der im Exchange eingetragene DNS (Netzkarte oder SendConnector) den Namen im Internet auflösen kann.

    Wie viele Exchange sind beteiligt, DC´s, GC?

    Was sagt der BPA?

    ;)


    Gruß Norbert

    Dienstag, 13. März 2012 20:19
    Moderator
  • Hallo Georg,

    hast Du Dir den anderen Thread angesehen? Hier noch einer: http://social.technet.microsoft.com/Forums/en-US/exchangesvrtransport/thread/a9b1a718-7b22-4678-aa91-c8ecebb4c6fa Da schreibt jemand:

    "I found that the Exchange server make a request to query MX record, the first response is successful. Then do the request of AAAA type, this is failed"

    Schmeiss doch mal Netmon an und schau was Dein Server da so treibt.

    VG, Timo


    Dienstag, 13. März 2012 20:32
    Moderator
  • Hi,

    bist du hier schon weitergekommen?


    Viele Grüße
    Christian

    Mittwoch, 14. März 2012 19:02
    Moderator
  • Danke allen für die Vorschläge... momentan habe ich leider nicht die Zeit, mich intensiver damit zu befassen udd die Geschütze aufzufahren, so dass es möglicherweise etwas länger dauert,  bis ich mich wieder melden kann.

    Stand der Dinge ist: Für eine Anzahl von Domänen bekomme ich einen "451 4.4.0 DNS query failed". Einige der betroffenen Gateways habe ich probehalber in die hosts eingetragen, Mails an diese Domänen gehen jetzt raus. Bei einigen anderen wird die Mail einige Zeit später doch abgeliefert (und dann anscheinend alle zur selben Zeit). Wieder andere laufen in ein Timeout (die werde ich einstweilen auch in die hosts eintragen). nslookup zeigt keine Auffälligkeiten, soweit ich erkennen kann.

    Ich stehe auch mit unserem DNS-Forwarder in Verbindung, der die Vermutung geäußert hat, dass es mit DNSSEC zusammenhängen könnte...

    Ich melde mich wieder.

    Georg.

    Mittwoch, 14. März 2012 19:33
  • Hi, da bin ich wieder...

    ExBPA weist auf keine DNS-Probleme hin. Inzwischen habe ich ein Update auf Ex2010 SP2 gefahren. Der Server ist (was ich wohl vergessen habe zu erwähnen) ein W2K8 R2.

    Ich habe dann mal den Wireshark angeworfen - und ich bekomme den Fehler schon auf ein "Standard query MX comcast.net".

    Dummerweise ist das Problem nicht einmal reproduzierbar - ich habe auch schon NDRs von comcast.net bekommen, wenn ich testhalber an eine Zufallsadresse dort schicke. Die Ausgabe von nslookup sieht m.E. vernünftig aus:

    > set type=mx
    > comcast.net
    Server:  dc5....
    Address:  ...

    Non-authoritative answer:
    comcast.net     MX preference = 5, mail exchanger = mx2.comcast.net
    comcast.net     MX preference = 5, mail exchanger = mx1.comcast.net

    mx2.comcast.net internet address = 76.96.30.116
    mx1.comcast.net internet address = 76.96.62.116

    Viele Grüße, Georg.

    Dienstag, 20. März 2012 09:39
  • Hallo,

    der BPA kann ds ggf. gar nicht lokalisieren.

    Wer macht denn die DNS-Auflösung für den Exchange, hast dort nur die DC/GC drin oder im SendConnector externe DNS eingetragen?

    Die Ausgabe oben ist vom Exchange mit dem HUB/Transport?

    Hast du zwischen dem Exchange und der Welt eine Firewall / TMG, wenn ja, was?
    Cisco, Astaro usw. spucken da gerne mal dazwischen - SMTP Filtering.

    ;)


    Gruß Norbert


    Dienstag, 20. März 2012 12:14
    Moderator
  • Hi,

    es spielt keine Geige, ob der DC die DNS-Auflösung für den Exchange betreibt oder ein externer DNS (der dann auf dem DC als Forwarder eingetragen ist) - habe beides ausprobiert.

    Ja, die nslookup-Ausgabe ist vom HT. Firewall: Incoming auf den Exchange nur von intern und OWA/OA, kein SMTP-Filtering, Outgoing ist alles erlaubt.

    Was mich am meisten irritiert, ist die mangelnde Reproduzierbarkeit. Heute um 10 Uhr (wieder einmal) Mails an zufällige Adressen in 6 problematischen Domänen herausgeschickt. Von zweien kam sofort ein NDR. Von den anderen vieren kam der NDR um zwei Stunden später, nachdem zuvor wieder DNS-Fehler ausgeworfen worden sind.

    Viele Grüße, Georg.

    Dienstag, 20. März 2012 12:28
  • Hallo,

    mal ´ne ganz dumme Frage - wer ist der ISP für den Internetzugang, hinter dem dem Exchange steht?

    Ich hatte da mal ganz lustige Sachen mit einem T-DSL Biz....

    ;)


    Gruß Norbert

    Dienstag, 20. März 2012 14:17
    Moderator
  • DFN - Deutsches Forschungsnetz...
    Dienstag, 20. März 2012 14:51