none
Win7 mit Autounattend.xml (läuft nicht) RRS feed

  • Frage

  • Ich habe mit dem WAIK eine AutoUnattend.xml erstellt und geprüft.
    Gemäss Dokumentation habe ich diese auf einem Stick am USB-Port und starte die Installation (auf hp2710p) ab DVD. Die DVD habe ich selber gebrannt, mit einer Source von MSDNAA (unsere Schule ist da Bezugsberechtigt). Den Lizenzschlüssel habe ich ordentlich über unseren OEM-Lieferanten erhalten.

    Wenn ich nun den Vorgang starte, wird der Stick wohl angesprochen (blinkende LED) aber ich werde nach dem Ländercode (Deutsch Deutschland usw.) gefragt (= nicht unattended?) und auch nach der Partition, auf welche ich installieren möchte (noch Vista auf Rechner  mit C: und D: Laufwerk). Danach habe ich dann selber abgebrochen.

    Ziel ist es eine C: und D: Partition zu haben und die Benutzerdaten auf D: anzulegen. Hier die XML-Datei.


    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>de-CH</UILanguage>
                </SetupUILanguage>
                <InputLocale>de-CH</InputLocale>
                <SystemLocale>de-CH</SystemLocale>
                <UILanguage>de-CH</UILanguage>
                <UserLocale>de-CH</UserLocale>
                <UILanguageFallback>en-US</UILanguageFallback>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <UserData>
                    <ProductKey>
                        <Key>..............</Key>
                        <WillShowUI>OnError</WillShowUI>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                    <FullName>probst</FullName>
                    <Organization>bzz</Organization>
                </UserData>
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>1</PartitionID>
                        </InstallTo>
                        <InstallToAvailablePartition>false</InstallToAvailablePartition>
                        <WillShowUI>OnError</WillShowUI>
                    </OSImage>
                </ImageInstall>
                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Size>44000</Size>
                                <Type>Primary</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Extend>true</Extend>
                                <Order>2</Order>
                                <Type>Extended</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Extend>true</Extend>
                                <Order>3</Order>
                                <Type>Logical</Type>
                            </CreatePartition>
                        </CreatePartitions>
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Active>true</Active>
                                <Extend>false</Extend>
                                <Format>NTFS</Format>
                                <Label>Win7-OS</Label>
                                <Letter>C</Letter>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <TypeID>0x7</TypeID>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Active>false</Active>
                                <Extend>false</Extend>
                                <Format>NTFS</Format>
                                <Label>Data</Label>
                                <Letter>D</Letter>
                                <Order>2</Order>
                                <PartitionID>2</PartitionID>
                                <TypeID>0x7</TypeID>
                            </ModifyPartition>
                        </ModifyPartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                    </Disk>
                    <WillShowUI>OnError</WillShowUI>
                </DiskConfiguration>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                </OOBE>
                <AutoLogon>
                    <Password>
                        <Value>*******************</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Enabled>true</Enabled>
                    <LogonCount>4</LogonCount>
                    <Username>Administrator</Username>
                </AutoLogon>
                <TimeZone>W. Europe Standard Time</TimeZone>
                <FolderLocations>
                    <ProfilesDirectory>D:\Benutzer</ProfilesDirectory>
                </FolderLocations>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>********************</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Name>test</Name>
                            <Description>Testbenutzer für erstes Login</Description>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
            </component>
            <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Reseal>
                    <ForceShutdownNow>true</ForceShutdownNow>
                </Reseal>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>mmbabzz30005</ComputerName>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>de-CH</InputLocale>
                <SystemLocale>de-CH</SystemLocale>
                <UILanguage>de-CH</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>de-CH</UserLocale>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:e:/win7/setup-dvd/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    Worauf muss ich noch achten, damit die Datei vom Stick gelesen wird und die Installation unattended abläuft?
    (habe das übrigens zuvor noch nie gemacht, ist für mich also Neuland)

    Danke für Hilfe.

    P.S: hab's auch in einem andern Forum probiert, dort aber keine oder zumindest keine hilfreichen Rückmeldungen bekommen.
    Mittwoch, 30. September 2009 12:12

Alle Antworten

  • Hallo Rene,

    > (noch Vista auf Rechner  mit C: und D: Laufwerk).
    mit autounattend.xml wirst Du kein zusätzliches BS zu einem bestehendem BS installieren können.
    sondern man erwartet eine jungfräuliche HDD.
    Kurz überfolgen, ist oben auch keine Angaben zur 2.Partitiongröße angegeben,
    ein falscher String in der Auswahl kann auch Dein Vorhaben zunichte machen.

    Dein Fehler muß IMHO bereits am Anfang liegen, da Windows Setup die xml ignoriert.
    Und lass ersteinmal das mit dem Benutzer weg, wenn dann ok, kannst Du die xml
    feinschleifen.

    Bleibt nur Lesen, Üben und Ausprobieren. Habe leider bis nächste Woche nicht die Möglichkeit
    es nachzustellen (Kurzurlaub), aber vielleicht kann jemand anders Dir hier weiterhelfen.

    Gruß Ralph Andreas Altermann
    Mittwoch, 30. September 2009 21:29
  • Hallo Ralph,
    eigentlich sollte Vista "weg", d.h. dass bei der Installation die Platte formatiert und dann neu partitioniert werden muss.
    Wenn ich im WAIK die Schalter richtig verstanden habe, sollte das so sein:
    - WillWipeDisk = true; müsste nach Beschreibung den Disk löschen
    - Size = leer; müsste dazu führen, dass der Rest der HD für die 2. Partition benutzt wird

    Ich versuche es mal mit einer unattend im sources-Verzeichnis der DVD. Mal schauen was dabei raus kommt.

    Gruss René
    Donnerstag, 1. Oktober 2009 05:54
  • Hallo Rene,
    Ich will dieselbe Sache wie du machen und bis jetzt habe ich nicht geschafft. Hast du geschafft? Falls ja, kannst du mich deine Autounattend.xml senden?

    Gruss
    Oscar (Bern)

    Freitag, 6. August 2010 11:49
  • Also um ehrlich zu sein, bevor Ihr viel Aufwand reinsteckt um das selbst zum laufen bekommen, probiert mal das Microsoft Deployment Toolkit 2010(http://www.microsoft.com/downloads/details.aspx?FamilyId=3BD8561F-77AC-4400-A0C1-FE871C461A89&displaylang=en) aus. Das ist ein kostenloser Solution Accelerator von Microsoft. In der Dokumentation gibt es eine wirklich hilfreiche Schritt-für-Schritt Anleitung die einen innerhalb von 1-3 Stunden zum ersten erfolgreich verteilten computer führt. Dabei ist das ganze modular aufgebaut, sprich ich kann es erst mal grob zum laufen bekommen und dann weiter ausbauen. Zusätzliche Treiber für weitere Modelle importieren, Anwendungen importieren die während des Deployments installiert werden sollen, das ganze per WDS und/oder CD verteilen. Dabei wird die gleiche so genannten Task Sequenz für Deployments auf neue computer (bare-Bone) existierende Computer (Refresh/Reimage) oder auch beim austausch bestehender computer genutzt. Beim Re-image werden automatisch die Nutzerdaten gesichert und wieder eingespielt usw.

    Grob gesagt ist es GUI für alle anderen Deployment tools aus dem WAIK wie imagex, dism, etc. Und es erleichtert einen viele Aufgaben da man doch immer wieder auf ähnliche Probleme stösst, die dort bereits behoben sind. Ein schöner Spruch hierbei stammt vom Entwickler des MDT "Es löst Probleme von denen man nicht mal wusste das man sie hat." ;-). Z.B. kann ich die Partitionskonfiguration direkt in der TaskSequenz konfigurieren und die unattend.xml wird erst zur Laufzeit damit aktualisiert.

    Unter http://deploymentcd.com/ gibt es eine kostenlose CD mit weiteren Schritt-für-Schritt Anleitungen und Videos. Zwar auf englisch, sollte aber kein Problem sein :-)

    Ansonsten bei Problemen einfach fragen.

    viele Grüße

    Maik


    http://myitforum.com/cs2/blogs/maikkoster/

    Freitag, 13. August 2010 10:01
  • Hey Rene,

    geht es bei dir um 32bit oder 64bit Win7?

     

    Dienstag, 31. August 2010 07:34
  • Kurze Frage. Handelt es sich um einen MAK oder KMS key ?

    Bei einem MAK musst du den Key in Pass 4 (Specialize) packen. Desweiteren von dem was ich so sehe grade koennte es dran liegen das du Ihm erst sagst wo er hininstallieren soll und dann die Partitionen erstellst.

    Mittwoch, 13. April 2011 14:58