none
Verweis (Referenz) auf öffentlichen Ordner nach Migration von 2007 auf 2010 komplett entfernen !? RRS feed

  • Frage

  • Hallo zusammen,

    Ich habe vor einiger Zeit unseren Exchange Server 2007 nach Exchange Server 2010 migriert. Hat soweit auch alles gut geklappt bis auf eine kleine Sache ;)

    Nachdem ich nun testweise einmal den alten Exchangeserver ausgeschaltet habe, hatte sich der Start von Outlook zunächst etwas verzögert und nach erfolgreicher Verbindung auch ein wenig Zeit benötigt, um die Ordner auch wriklich zu aktualisieren.
    Nun habe ich mir beim Start von Outlook einmal mit STRG+Rechtsklick auf das Outlook Systray Icon die Verbindungseigenschaften angeguckt und gesehen das dort noch versucht wird eine Verbindung zu einem öffentlichen Ordner auf dem alten ExchangeServer aufzubauen.

    Ich habe eine Replikation dieser Ordner auf den neuen Exchangeserver veranlasst über die Toolbox - doch scheinbar war das falsch - da weiterhin versucht wird auf den alten Server zuzugreifen !?

    Ich möchte diese öffentlichen Ordner eigentlich komplett aus dem System haben (sind eh leer) - wie gehe ich am besten vor um alle Verweise darauf aus der Exchange Umgebung zu entfernen ? VOm alten sowie vom neuen Server ?

    Anschliessend kann ich dann endlich den alten Exchangeserver (hoffentlich) komplett deinstallieren.

    Florian
    • Typ geändert Alex Pitulice Dienstag, 6. September 2011 07:08 Warten auf Feedback
    • Typ geändert Florian S. _ Freitag, 13. Januar 2012 15:32 Um Antwort zu markieren
    Donnerstag, 1. September 2011 12:50

Antworten

  • Hallo,

    hast du auf dem neuen Server auch wieder eine Public Folder DB?

    Diese den Datenbanken auf dem alten und neuen Server als PF DB zugewiesen?

    Ich hatte unlängs einen ähnlichen Fall, da alle Daten auf dem neuen Server waren, die DB kurzerhand mittels ADSI Edit gelöscht.

    Vielleicht nicht ganz sauber, aber effektiv.

     


    Gruß Norbert
    Freitag, 2. September 2011 07:59
    Moderator
  • Hi Florian,

    bist du hier schon weitergekommen? Bisher sind die PF auch noch den DBs zugerodnet - vielleicht entfernst du die, bevor du den PF-Store löschst...


    Viele Grüße
    Christian

    Samstag, 3. September 2011 07:15
    Moderator
  • Da der Thread noch offen ist : 

    Ich habe das Problem über die Verwaltungskonsole lösen können - hier hat ein Rechtsklick auf  die MailDatenbank im Reiter "Clienteinstellungen" gezeigt das hier noch der alte Server bzw die alte PF Datenbank angegeben war. Ein Wechsel auf die Neue und es läuft !'

     

     

    • Als Antwort markiert Florian S. _ Freitag, 13. Januar 2012 15:32
    Freitag, 13. Januar 2012 15:31

Alle Antworten

  • Hallo,

    schau mal nach, ob die richtige Öffentliche-Ordner-Datenbank bei den Postfachdatenbanken eingetragen ist. Eventuell verweisen die noch auf die Öffentliche-Ordner-Datenbanken auf dem 2007er.

    Grüße,

    Toni

    Donnerstag, 1. September 2011 13:05
  • Hi Florian,

    poste mal: get-mailboxDatabase | fl Iden*,publicfolder*,offlinead*"
    und get-offlineAddressBook | fl

    Es sollten keine alten Outlook 2003 Clients mehr im Einsatz sein, denn diese benötige ÖO für free/busy und OAB - als OAB-Verteilung anpassen:
    http://blog.ronnypot.nl/?p=212


    Viele Grüße
    Christian

    Donnerstag, 1. September 2011 13:40
    Moderator
  • Hallo,

    [PS] C:\Windows\system32>get-mailboxDatabase | fl Iden*,publicfolder*,offlinead*
    
    
    Identity       : CompanyName
    PublicFolderDatabase : EXCHANGE_alt\Second Storage Group\Public Folder Database
    OfflineAddressBook  :
    
    Identity       : Externe Nutzer
    PublicFolderDatabase : CompanyName Public
    OfflineAddressBook  :

    Offline Adressbuch habe ich gelöscht - also kein Eintrag vorhanden (wurde auch nie genutzt - werde ich wenn wieder neu anlegen)


    Donnerstag, 1. September 2011 13:57
  • Hi Florian,

    Offline Adressbuch habe ich gelöscht - also kein Eintrag vorhanden (wurde auch nie genutzt - werde ich wenn wieder neu anlegen)

    Eigentlich sollte deinen Cached-Clients auch ein OAB zur Verfügung gestellt werden, damit sie auch ein OAB bei Bedarf haben...

    Was für Clients setzt du denn ein?
    http://www.andreas-exner.eu/index.php/2010/03/16/how-to-remove-the-last-public-folder-database-during-migration-from-exchange-2007-to-exchange-2010/


    Viele Grüße
    Christian

    Donnerstag, 1. September 2011 14:10
    Moderator
  • Outlook 2007 / 2010 und Outlook for MAC und MacMail ist im Einsatz - kein 2003 mehr

    LInk schaue ich mir mal an - vielen Dank soweit
    Donnerstag, 1. September 2011 14:15
  • Get-PublicFolder "\NON_IPM_SUBTREE" -recurse

    Ich habe nur einen IPM_SUBTREE


    [PS] C:\Windows\system32>Get-PublicFolder
    
    Name                  Parent Path
    ----                  -----------
    IPM_SUBTREE


    Donnerstag, 1. September 2011 14:18
  • Hallo,

    IPM_SUBTREE ist der ganz oben gelegene Public Folder der Hierarchie, darunter beginnen die restlichen Nicht-System-PFs.

    NON_IPM_SUBTREE ist für System-PublicFolder der ganz oben gelegene Public Folder der Hierarchie. Bei Get-PublicFolder wird dieser ausgeblendet. Also müssten mit dem oben stehenden Befehl "Get-PublicFolder "\NON_IPM_SUBTREE" -Recurse" alle System-PublicFolders angezeigt werden.

    Grüße,

    Toni

    Donnerstag, 1. September 2011 14:40
  • OK - Ich hatte wohl den Backslash vergessen - ich komme wie in dem Artikel beschrieben aber nur bis zu

    http://www.andreas-exner.eu/wp-content/uploads/2010/03/pf3.jpg

    Diese Ordner bekomme ich nicht entfernt mit folgender Fehlermeldung :
    Remove-PublicFolder : Das Objekt '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=CompanyName/ou=Exchange Administrative Grou
    p (FYDIBOHF23SPDLT)' kann nicht gelöscht werden. Stellen Sie sicher, dass Sie die richtige Identität angegeben haben un
    d über die richtigen Berechtigungen zum Löschen verfügen.
    Bei Zeile:1 Zeichen:65
    + Get-PublicFolder "\NON_IPM_SUBTREE" -recurse|remove-publicfolder <<<<
        + CategoryInfo          : NotSpecified: (7:Int32) [Remove-PublicFolder], MapiPartialCompletionException
        + FullyQualifiedErrorId : C2C6E62E,Microsoft.Exchange.Management.MapiTasks.RemovePublicFolder

    Im Artikel wird darauf verwiesen den Befehl dann noch einige male durchlaufen zu lassen - ändert aber nichts.

    Wenn ich in diesem Zusatnd die Datenbank löschen will :




    emove-PublicFolderDatabase : Die Öffentliche Ordner-Datenbank 'EXCHANGE_alt\Second Storage Group\Public Folder Database' i
    st die Standarddatenbank für Öffentliche Ordner für die folgende(n) Postfachdatenbank(en):
    EXCHANGE_alt\First Storage Group\Mailbox Database
    CompanyName
    . Weisen Sie der/den Postfachdatenbank(en) vor dem Löschen der Öffentlichen Ordner-Datenbank eine neue Öffentliche Ordn
    er-Datenbank zu.
    Bei Zeile:1 Zeichen:53
    + Get-PublicFolderDatabase|remove-publicfolderdatabase <<<<
        + CategoryInfo          : InvalidOperation: (EXCHANGE_alt\Second...Folder Database:ADObjectId) [Remove-PublicFolderDat
       abase], InvalidOperationException
        + FullyQualifiedErrorId : 76C6CDDB,Microsoft.Exchange.Management.SystemConfigurationTasks.RemovePublicFolderDataba
       se



    • Bearbeitet Florian S. _ Freitag, 2. September 2011 07:50 Link geändert
    Freitag, 2. September 2011 07:48
  • Hallo,

    hast du auf dem neuen Server auch wieder eine Public Folder DB?

    Diese den Datenbanken auf dem alten und neuen Server als PF DB zugewiesen?

    Ich hatte unlängs einen ähnlichen Fall, da alle Daten auf dem neuen Server waren, die DB kurzerhand mittels ADSI Edit gelöscht.

    Vielleicht nicht ganz sauber, aber effektiv.

     


    Gruß Norbert
    Freitag, 2. September 2011 07:59
    Moderator
  • Hi Florian,

    bist du hier schon weitergekommen? Bisher sind die PF auch noch den DBs zugerodnet - vielleicht entfernst du die, bevor du den PF-Store löschst...


    Viele Grüße
    Christian

    Samstag, 3. September 2011 07:15
    Moderator
  • Ich war einige Zeit nicht im Büro und kann mich jetzt wieder darum kümmern.
     We genau weise ich es denn um, bzw wo lösche ich den Eintrag mit ADSIEDIT ? Wie bereits erwähnt, bruche ich keine der öffenltichen Ordner und ein reines Löschen wäre vollkommen OK.

    Florian
    Donnerstag, 6. Oktober 2011 08:56
  • Da der Thread noch offen ist : 

    Ich habe das Problem über die Verwaltungskonsole lösen können - hier hat ein Rechtsklick auf  die MailDatenbank im Reiter "Clienteinstellungen" gezeigt das hier noch der alte Server bzw die alte PF Datenbank angegeben war. Ein Wechsel auf die Neue und es läuft !'

     

     

    • Als Antwort markiert Florian S. _ Freitag, 13. Januar 2012 15:32
    Freitag, 13. Januar 2012 15:31