none
Advanced Resource Leveling

    Frage

  • I would like if someone can confirm if the following is a leveling issue in the Microsoft Project Pro 2016 client.

    I have a project plan with "a single task", i.e., with a 1-day Duration task, with one resource assigned to it at 16 hours (of type work).  I have purposely over allocated this resource to work a 16-hour day (i.e., Resource's Max Units = 100% [8-hours /day], assignment units = 200% [16-hours/1-day]).

    Upon running the leveling operation, Microsoft Project changes the assignment work form 16 hours/ 1-day, to 8-hours over 2 working days. Is this normal?  From what I know of leveling, Microsoft Project is not supposed to change the assignment units during a leveling operation!!!

    However, we see here that it does in this extremely simple scenario (a plan with only a single task and a single resource).  Also, given that I am forcing an over allocation situation rather than using overtime-work to ‘ok’ the over allocation situation (i.e., 8 hours regular work + 8 hours overtime work), I am expecting the following warning/ error message--"This overallocation can not be resolved... / SKIP/SKIP ALL/ STOP", but instead it changes the assignment.

    Note, this scenario is applies to Fixed Units, or Fixed Work task types.  The Leveling option settings are default, i.e., Look for overallocations on a: Day-by-Day basis; Leveling Order : Standard; Leveling can adjust assignments = On, and Leveling can split = On.

    Is this a bug, or a change in the design of how MSP levels?

    Thanks in advance,


    \Spiro Theopoulos, Montreal, QC (Canada)

    Samstag, 12. Mai 2018 06:48

Antworten

  • All --

    I can confirm what Spiro is seeing.  I set up the exact same situation as he has, and Microsoft Project 2016 DID change the Duration to 2 days with the resource assigned at 8 hours/day.  This is definitely new leveling behavior in the tool that I have never seen before.  I will need to remember this when we start updating our books for Project Server 2019.


    Dale A. Howard [MVP]

    Sonntag, 13. Mai 2018 20:52
    Moderator
  • I am not sure whether this is an improvement or a big mistake. It contradicts decades of advice about how leveling works. If it is by design, and if it is really an improvement, then there should at least be another check box in the leveling options. What does the leveling delay field say?
    Sonntag, 13. Mai 2018 23:35

Alle Antworten

  • Well, I checked what you did, assigned the one resource at 200% to a 1 day duration task, and leveled with the leveling options you describe, with MSP2010 and ...no such thing as you describe happens. I will be very surprised if anyone with MSP2016 tries it and gets what you got.

    Can you post screenshots of before and after leveling?

    Are you up to date with current version and any fixes/patches?

    Sonntag, 13. Mai 2018 13:59
  • Firstly, "Thank you" Trevor for getting back to me on this.  What you describe in 2010 is what I would expect.

    Yes, my 2016 subscription of Microsoft Project Online is up to date.  It is set to Automatic Updates and double checked that it is up to date by clicking "update now".

    Below. is the Before Leveling, After Leveling, and Leveling options screenshots:

    Before:

    After:

    Leveling Options used:

    Let me know if you have any other thoughts on this.

    Kind regards,


    \Spiro Theopoulos, Montreal, QC (Canada)



    • Bearbeitet Spiro Theopoulos Sonntag, 13. Mai 2018 14:43 Typo - inserted incorrect image
    Sonntag, 13. Mai 2018 14:41
  • All --

    I can confirm what Spiro is seeing.  I set up the exact same situation as he has, and Microsoft Project 2016 DID change the Duration to 2 days with the resource assigned at 8 hours/day.  This is definitely new leveling behavior in the tool that I have never seen before.  I will need to remember this when we start updating our books for Project Server 2019.


    Dale A. Howard [MVP]

    Sonntag, 13. Mai 2018 20:52
    Moderator
  • You think it is by design?! I would assume it is a bug.  I have come across and identified quite a few of theses leveling related bugs over the last few years and have worked with MS support to get them fixed.  Yet, I have not seen anything announcing this particular change in functionality to make me think it non other than a bug. In fact, I have put this to them a few days ago to see what they come back to me with.  Will let you know what they tell me.

    \Spiro Theopoulos, Montreal, QC (Canada)

    Sonntag, 13. Mai 2018 21:06
  • I am not sure whether this is an improvement or a big mistake. It contradicts decades of advice about how leveling works. If it is by design, and if it is really an improvement, then there should at least be another check box in the leveling options. What does the leveling delay field say?
    Sonntag, 13. Mai 2018 23:35
  • Seems like a bug given what I see in the Start/ Finish times (i.e., 1pm versus 8am)... Below is the before and after leveling delay:

    After Leveling:


    \Spiro Theopoulos, Montreal, QC (Canada)


    Montag, 14. Mai 2018 01:20
  • Um..., gee, that's a bit strange. I am having a bit of difficulty reading the tiny fuzzy numbers in your screenshots, but is it really moving the task start from 08:00 to 13:00 on the first day (Friday), and finish to 12:00 on the second day (Monday)? How is that resolving the resource over-allocation? Am glad I stopped upgrading at MSP2010.

    Montag, 14. Mai 2018 03:22
  • Dale,

    Please confirm that MSP 2016 DID CHANGE the Duration from 1d to 2d on executing the leveler.  I agree that that would be a MAJOR change from all previous leveling behavior.

    Spiro's screenshots imply something not so nefarious.  I can duplicate his results (in MSP 2010) by manually imposing a Leveling Delay of 4ehrs.  That makes the little red man go away because the over-allocation checker  (on Day-by-Day setting) sees 8 hours on Friday and 8 hours on Monday - i.e. no over-allocation - notwithstanding the fact that the work is constrained to occur during a 4-hour period on each day.  Changing the setting to Hour-by-Hour brings the red man back as expected.  The real over-allocation is NOT fixed, but the checker has been fooled.  I would consider this a bug.

    Project's leveling behavior can be more complex than expected.  Here's what happens when I set the test project to start on the last day of the month and level Month-by-Month.  (A 5ehr leveling delay is imposed, and the 1-day task is split between two days/months.)  This is in MSP 2010. 


    Montag, 14. Mai 2018 20:35