none
Excell 2010 Probleme mit Autofilter "Fixierte Objekte werden verschoben" RRS feed

  • Frage

  • Hallo Forengemeinde,

    der HWH2011 hat mal wieder ein dickes Problem und weis nicht wie er es angehen könnte.

    Gegeben:

    • Excell 2010
    • Tabelle im Format XLS (wahrscheinlich 2003)
    • ca. 5500 Zeilen und ca. 400 Spalten
    • Tabelle enthält augenscheinlich in manchen Spalten verbundene Zellen, die ich nicht trennen darf!
    • Weitere Objekte habe ich nicht gefunden, weil ich nicht weis wie ( bin halt nicht der Profi ).
    • Setzen des Autfilters funktioniert
    • Nach dem Zurücksetzen der Filterauswahl erscheint die Meldung: "Fixierte Objekte werden verschoben" "OK". Diese Meldung läßt sich weder durch Betätigung des OK - Buttons noch durch den Fensterschließen "X" Button beseitigen. Der entsprechende Sound wird ausgegeben, Excel läßt sich nicht mehr bedienen, auch nicht schließen.
    • Abhilfe schaft nur das "Abschießen" von Excel über den Taskmanager.
    • Sowohl im Originalformat wie auch im konvertierten XLSX Format besteht das Problem

    Die Gegenprobe mit der gleichen Datei bei einem Bekannten unter Excel 2003 löst keinerlei Fehler bei der Arbeit mit dem Autofilters aus!

    Ich bin quasi am verzeifeln. Ich muß aus dieser Datei Auswertungen erstellen, mir steht aber nur Excel 2010 zu Verfügung.

    Ich finde die entsprechende "Stellschraube" im Excel 2010 nicht um das Problem umgehen zu können. Hoffentlich ist dies  kein Bug im Excel 2010.

    Hat irgendjemand eine Idee wo ich den Hebel ansetzen könnte?

    Gruß   Helmut


    mit freundlichen Grüssen HWH2011 wären doch da nicht immer diese excelPROBLEME!
    Samstag, 15. Oktober 2011 11:00

Antworten

  • Hallo Helmut...

    Du könntest probieren, eine Option in Excel 2010 abzuschalten, die Du unter Datei -> Optionen -> Erweitert, Rubrik 'Ausschneiden, Kopieren und Einfügen' auf der rechten Seite -> Haken bei 'Eingefügte Objekte mit übergeordneten Zellen auchschneiden, kopieren und sortieren'. Auch könntest Du prüfen, ob Kommentare möglicherweise die Ursache dafür sind. Quellen, Englisch: VBA Express Forum, Mr. Excel

    Gruß


    MVP Office System · Excel Formula Translator · www.excel-translator.de
    • Bearbeitet Mourad LouhaMVP Sonntag, 16. Oktober 2011 08:18
    • Als Antwort markiert HWH2011 Sonntag, 16. Oktober 2011 13:20
    • Tag als Antwort aufgehoben HWH2011 Sonntag, 16. Oktober 2011 13:20
    • Als Antwort markiert Alex Pitulice Donnerstag, 20. Oktober 2011 14:29
    Sonntag, 16. Oktober 2011 08:18
  • Hallo Helmut...

    Du könntest probieren, eine Option in Excel 2010 abzuschalten, die Du unter Datei -> Optionen -> Erweitert, Rubrik 'Ausschneiden, Kopieren und Einfügen' auf der rechten Seite -> Haken bei 'Eingefügte Objekte mit übergeordneten Zellen auchschneiden, kopieren und sortieren'. Auch könntest Du prüfen, ob Kommentare möglicherweise die Ursache dafür sind. Quellen, Englisch: VBA Express Forum, Mr. Excel

    Gruß


    MVP Office System · Excel Formula Translator · www.excel-translator.de
     

    Hallo Mourad Louha,

    ich habe nun deinen Vorschlag verifiziert:

    Das ist die Lösung! 

    Trotz mehrfachem durchgehen der Optionen bin ich nicht auf diese Einstellung gekommen.

    Wie bereits von mir geschrieben war es tatsäch ein verschobener Kommentar.

    Der Fehler/Hinweis beim Lösen des Autofilters tritt dann nicht mehr auf. Dies hat den großen Vorteil, dass die Tabelle nicht geändert werden muß.

    Dafür auf jeden Fall vielen Dank!

    Mit welchen, vielleicht auch unliebsame Nebenwirkungen, ist bei der Änderung dieser Einstellung zu rechnen? Sie ja schließlich nicht ohne Grund als Standard gesetzt.

    Gruß  HWH


    mit freundlichen Grüssen HWH2011 wären doch da nicht immer diese excelPROBLEME!
    • Als Antwort markiert Alex Pitulice Donnerstag, 20. Oktober 2011 14:28
    Sonntag, 16. Oktober 2011 13:20

Alle Antworten

  • Hallo Helmut...

    Du könntest probieren, eine Option in Excel 2010 abzuschalten, die Du unter Datei -> Optionen -> Erweitert, Rubrik 'Ausschneiden, Kopieren und Einfügen' auf der rechten Seite -> Haken bei 'Eingefügte Objekte mit übergeordneten Zellen auchschneiden, kopieren und sortieren'. Auch könntest Du prüfen, ob Kommentare möglicherweise die Ursache dafür sind. Quellen, Englisch: VBA Express Forum, Mr. Excel

    Gruß


    MVP Office System · Excel Formula Translator · www.excel-translator.de
    • Bearbeitet Mourad LouhaMVP Sonntag, 16. Oktober 2011 08:18
    • Als Antwort markiert HWH2011 Sonntag, 16. Oktober 2011 13:20
    • Tag als Antwort aufgehoben HWH2011 Sonntag, 16. Oktober 2011 13:20
    • Als Antwort markiert Alex Pitulice Donnerstag, 20. Oktober 2011 14:29
    Sonntag, 16. Oktober 2011 08:18
  • Hallo Mourad Louha,

    Danke für deine Antwort.

    Ich habe das Problem letzte Nacht gefunden und zum Glück auch gelöst.

    Die Ursache war ein verschobener Kommentar!

    Ich hatte nie einen Gedanken daran verschwendet, dass Kommentare einen solchen Ärger verursachen könnten.

    Ich vermute, das der Kollege diesen im gefilterten Zustand der Liste eingefügt und aus Versehen in die Nachbarzelle verschoben hat.

    Sichtbar an: Kommentar in Zelle FP2843 im Modus Kommentar bearbeiten stand er über FP2890!

    Händelt Excel 2010 verschobene Kommentare anders als Excel 2003? 

     

    Gruß

    HWH


    mit freundlichen Grüssen HWH2011 wären doch da nicht immer diese excelPROBLEME!
    Sonntag, 16. Oktober 2011 10:27
  • Hallo Helmut...

    Du könntest probieren, eine Option in Excel 2010 abzuschalten, die Du unter Datei -> Optionen -> Erweitert, Rubrik 'Ausschneiden, Kopieren und Einfügen' auf der rechten Seite -> Haken bei 'Eingefügte Objekte mit übergeordneten Zellen auchschneiden, kopieren und sortieren'. Auch könntest Du prüfen, ob Kommentare möglicherweise die Ursache dafür sind. Quellen, Englisch: VBA Express Forum, Mr. Excel

    Gruß


    MVP Office System · Excel Formula Translator · www.excel-translator.de
     

    Hallo Mourad Louha,

    ich habe nun deinen Vorschlag verifiziert:

    Das ist die Lösung! 

    Trotz mehrfachem durchgehen der Optionen bin ich nicht auf diese Einstellung gekommen.

    Wie bereits von mir geschrieben war es tatsäch ein verschobener Kommentar.

    Der Fehler/Hinweis beim Lösen des Autofilters tritt dann nicht mehr auf. Dies hat den großen Vorteil, dass die Tabelle nicht geändert werden muß.

    Dafür auf jeden Fall vielen Dank!

    Mit welchen, vielleicht auch unliebsame Nebenwirkungen, ist bei der Änderung dieser Einstellung zu rechnen? Sie ja schließlich nicht ohne Grund als Standard gesetzt.

    Gruß  HWH


    mit freundlichen Grüssen HWH2011 wären doch da nicht immer diese excelPROBLEME!
    • Als Antwort markiert Alex Pitulice Donnerstag, 20. Oktober 2011 14:28
    Sonntag, 16. Oktober 2011 13:20
  • Auch könntest Du prüfen, ob Kommentare möglicherweise die Ursache dafür sind."

    Hallo Murad Louha,

    ist zwar schon ein paar Jahre her, aber bei MS hat man es leider bislang nicht für nötig befunden, das Problem zu beheben.

    Ich arbeite mit enorm großen xlb-Dateien und habe darin Daten, die ich z. T. mittels Kommentarfeld erläutert hatte.

    Deshalb kam rd. 1000x die Fehlermeldung, die man dann wegklicken musste.

    Untragbar. 

    Schweren Herzens habe ich die Notizen (nach einer Datensicherung) dann alle gelöscht. Et voilà: nun gibt es das Problem nicht mehr.

    Somit sind Kommentare (neu in Excel 365: "Notizen") nicht wirklich kompatibel mit dem Filtern. Ein bug der dringend gefixt gehört.

    Genau die Kommentar-Funktion ist z. B. ein großer Vorteil ggü. Datenbanksystemen.

    Vielen Dank für den Hinweis.

    Dienstag, 14. Januar 2020 22:27