none
Remotedesktop Web Access von extern erreichen RRS feed

  • Frage

  • Hallo,

    ich habe einen Terminalserver und dort das Remotedesktop WebAccess installiert. Intern funktioniert dies wunderbar. Jetzt möchte ich dieses von extern ermöglichen. Deswegen habe ich den Port 443 auf den Terminalserver gelenkt! Ich kann von extern leider kein Remote APP starten oder mich zum Terminal verbinden!

    Das Zertifikat ist auf name.DOMAIN.de ausgestellt. Subdomain mit Host A Eintrag gesetzt. Ich komme auf die RPWEB Seite.

    Fehler: Es konnte keine Verbindung hergestellt werden! Oder er ist aus oder nicht erreichbar!

    Bei google finde ich immer Lösungen mit dem Remote Desktop Gateway als Lösung. Muss man diesen unbedingt haben?

    Gruß Patrick

    Dienstag, 8. Mai 2012 13:51

Alle Antworten

  • Dienstag, 8. Mai 2012 14:01
  • Danke für den Link.

    Ich erhalte keine Zertifikatsfehlermeldung!

    Mir stellt sich die Frage! Benötige ich das Remotedesktop Gateway?

    Meine Vermutung liegt daran, das von extern Versucht wird per 3389 eine Verbindung zum Remote APP aufzubauen. Das geht natürlich nicht, weil dieser nicht geöffnet ist am Router. Das kann ich für einen kurzen Test morgen einmal prüfen. Wenn ich den 3389 aufmache, dann könnte ich auch direkt MSTSC und die Verbindung zum Server aufbauen. Stellt sich hier die Frage der Sicherheit! Müssen 443 + 3389 Terminalserver zeigen.

    Sicherer ist bestimmt das Remote Desktop Gateway. Dort verbinde ich mich über https und das Gateway kennt den Weg zum Terminalserver!

    Danke

    Patrick

    • Bearbeitet PatrickMs Dienstag, 8. Mai 2012 17:57
    Dienstag, 8. Mai 2012 14:44
  • Hallo Patrick,

    Mir stellt sich die Frage! Benötige ich das Remotedesktop Gateway?

    Meine Vermutung liegt daran, das von extern Versucht wird per 3389 eine Verbindung zum Remote APP aufzubauen. Das geht natürlich nicht, weil dieser nicht geöffnet ist am Router. Das kann ich für einen kurzen Test morgen einmal prüfen. Wenn ich den 3389 aufmache, dann könnte ich auch direkt MSTSC und die Verbindung zum Server aufbauen. Stellt sich hier die Frage der Sicherheit! Müssen 443 + 3389 Terminalserver zeigen.

    Sicherer ist bestimmt das Remote Desktop Gateway. Dort verbinde ich mich über https und das Gateway kennt den Weg zum Terminalserver!

    Du hast den springenden Punkt genau erkannt. Du willst ja nunmal das RDP Protokoll durch SSL tunneln. Deshalb muss Du das RDG installieren, damit Du Dich auch über den Port 443 mit dem TS Verbinden kannst. Um es kurz zu machen: Ja, Du benötigst ein Remote Desktop Gateway.

    Viele Grüße

    Frank


    -- Frank Röder http://blog.iteach-online.de --

    Dienstag, 8. Mai 2012 18:37
  • Okay. Wenn ich den Port aufmache würde das gehen!

    Kurze Frage zum TS Gateway! Ich installiere den auf einen separaten Server und installiere nur die Gateway Komponente. Dort leite ich den 443 um! Geht durch ein TS Gateway auch Remote APP?

    Wenn ich einen extra Server installieren muss, überlege ich schon einen UAG 2010 Server aufzusetzen! Dann könnte ich eine Portalseite mit OWA, Sharepoint, Terminalserver machen! 

    Danke

    Dienstag, 8. Mai 2012 18:41
  • Hallo Patrick,

    Du kannst das TSGateway auch auf der gleichen Maschine aufsetzen. Dann geht auch Remotapp wenn es richtig konfiguriert ist. Das mit dem UAG ist eine prima Idee. Allerdings ist das Ding nicht so einfach zu administrieren. Das macht man nicht so nebenbei.

    Viele Grüße

    Frank


    -- Frank Röder http://blog.iteach-online.de --

    Dienstag, 8. Mai 2012 19:52
  • Zeit habe ich nicht viel, da ich als IT Techniker bei den Kunden sein soll. Ich bin gerade dabei unsere IT auf einen neuen Hyper V Server aufzustellen.

    Ich werde morgen das Gateway auf dem terminal server installieren. Das Zertifikat habe ich ja schon passend ausgestellt bekommen. Das gebe ich beim TS Gateway mit an! Das müsste doch so gehen, wenn es auf der gleichen Server ist! Oder?

    Was meinst du mit "Dann geht auch Remotapp wenn es richtig konfiguriert ist" Gibt es besonderheiten? How To?

    Danke!!!

    Dienstag, 8. Mai 2012 20:20
  • Hallo Frank,

    es läuft! Ich komme über das TS Gateway auf den Terminalserver. APPs kann ich leider nicht direkt starten. Wenn ich mir die Remote APPS am Server exportiere kann ich diese aus der Ferne starten und im Word z.b Arbeiten.

    Das geht wohl nicht anders?

    Patrick

    Mittwoch, 9. Mai 2012 12:25
  • Hallo Patrick,

    das ist ein Konfigurationsfehler. Die Remote-Apps müssen sich auch aus der Ferne starten lassen. Öffne mal den RemoteApp Manager und klicke unter "Aktionen" auf den Link "Remotedesktop-Gatewayeinstellungen". Dort musst Du den externen FQDN des Gateways einstellen. Danach sollte bzw. muss es klappen.

    Viele Grüße

    Frank


    -- Frank Röder http://blog.iteach-online.de --

    Mittwoch, 9. Mai 2012 17:46
  • Hi,

    da steht meiner Meinung genau das Richtige drin. server.firma.de

    Hier mein Setup:

    1. Interne AD Domain: firma.de

    2. FQDN vom Terminalserver inkl. RS Gateway: server.firma.de

    3. Externe Subdomain beim Webprovider: server.firma.de / Host A Eintrag ist auf die Feste IP vom Router gesetzt

    4. Port Forwarding: Nur der Port 443 auf die IP von server.firma.de

    5. https://server.firma.de/rdweb ist erreichbar / Keiner Zertifikatsmeldung (ausgestellt auf server.firma.de)

    Kann es daran liegen, dass meine Interne Domain gleich der externen ist? Wobei das keinen Sinn macht, dass die APPs für mich die gleichen Einstellungen bzgl. TS Gatway anzeigen wenn man drauf klickt!

    Ich komme ohne Probleme per MSTSC auf den Server inkl. Angabe vom TS Gateway.

    Ich komme auf https://server.firma.de/rdweb. Dort sehe ich die APPs. Auf Remotedesktop kann ich eine Verbindung zum Server aufbauen. Mir werden auch die Information angezeigt was die APP für Einstellungen hat. Sprich server.firma.de

    Klicke ich auf ein APP sehe ich genau die gleichen Informationen. Keine Verbindung möglich. Exportiere ich eine APP im App Manager und bringe Sie auf meinen PC, kann ich mich verbinden und das Programm wird in der TS Session geladen!

    Gruß

    Patrick

    Mittwoch, 9. Mai 2012 18:31
  • Ich glaube ich habe den Fehler gefunden! Es liegt wohl am IE. Mit dem habe ich immer zwischen Test User und Administrator getestet. Ich habe es daheim vom Notebook getestet und wunderte mich das es geht. Dann habe ich es daheim am PC gemacht. Ging nicht. Den einmal auf Werkeinstellungen. Siehe da es geht!
    • Bearbeitet PatrickMs Mittwoch, 9. Mai 2012 19:56
    Mittwoch, 9. Mai 2012 19:54
  • Nicht ganz den Fehler gefunden! Es liegt an der Authentifizierung. Klicke auf den Remoteserver kommt immer eine Benutzerauthentifizierung. Dort gebe ich immer die Benutzerdaten ein. Bei den APPs kommt diese nicht. Bei Windows erscheint ein Fenster bei der Uhr wo die Remote Verbindung angezeigt wird. Trenne ich dort die Verbindung erscheit wenn ich auf eine APP klicke auch die Authentifizierung. Tippe ich die Daten ein startet meine APP

    Wie löse ich dieses? Bei XP habe ich dieses Problem nicht!

    Mittwoch, 9. Mai 2012 20:15
  • Hallo Patrick,

    also wenn ich gut verstanden habe, hast Du dieses Problem nur wenn Du im RDWeb - Remote Apps bist und von dort aus auf eine App gehen willst.

    Es scheint dass es durch RD Gateway funktioniert und anders nicht.

    1. Überprüfe mal folgenden Artikel um zu sehen ob alles ok konfiguriert wurde:

    Schrittweise Anleitung zu RemoteApp für Terminaldienste

    2. Welche sind die Unterschiede zwischen Dein Laptop und Dein PC und was meinst Du genau mit Werkeinstellungen funktioniert es auf dem PC auch?

    3. Bezüglich Dein letzter Beitrag, passiert alles auf RDWeb und geht es um Windows 7 Clients?

    Gruss,
    Raul


    Raul Talmaciu, MICROSOFT 
    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Dienstag, 15. Mai 2012 09:46
  • Also bei XP: Ich erreiche die RDWEB und klicke auf eine APP. Erneute Benutzer Authentifizierung erfolgt. Zugriff möglich.

    Bei Windows 7 erreiche die RDWEB-Seite. Klicke auf das APP und es kommt zu keiner Authentifizierung. Windows 7 hat eine Remote APP Verwaltung in der Systemsteuerung. Die habe ich eingebunden und getestet! Läuft. Diese Einrichtung würde ich bei meinem Heimarbeitsplatz machen.

    Es gibt auch Umgebungen wo ich einfach die RDWEB erreichen möchte und eine APP starte! Ist dies ein Windows 7 Rechner zeigt er unten diese Remote APP Icon. Dort muss ich die Verbindung erst trennen, dann klicke ich auf das APP und dann kommt die Authentifizierung und das Remote App startet!

    Patrick

    Dienstag, 15. Mai 2012 11:19