none
Excel Mittelwert Funktion liefert unerwartete Ergebnisse RRS feed

  • Allgemeine Diskussion

  • Hi Community,

    Excel 2011 (Mac) liefert bei mir unerwartete Ergebnisse, solange nicht alle Felder, welche in die Mittelwert Funktion involviert sind, mit Werten belegt sind. In diesem Screenshot sieht man ein Beispiel der Problematik:

    http://media.prontosystems.org/v/bk/excel_mittelwert.png.html

    Die angezeigte Feldfunktion kommt aus Zelle S191. Die Zellen E191, K191 und Q191 wiederum sollen den Mittelwert der vorausgegangenen Zellen ermitteln. zB: E191 = Mittelwert(B191:D191). Der einzig reele Wert, welcher mittlerweile eingetragen wurde ist der Wert 9 in Zelle C191 und ich würde somit auch diesen Wert als Mittelwert erwarten. Warum wird mir aber der Mittelwert 3 der Zellen  (B191:D191) und der Mittelwert der Zellen (E191;K191;Q191) sogar nur 1 angezeigt?

    Für Aufklärung dankend & Bye Tom

    Dienstag, 19. Juni 2012 07:36

Alle Antworten

  • Update:

    Ich habe jetzt eine Teillösung für das Problem gefunden. Den korrekten Mittelwert der Zellen (B191:D191) erhalte ich mit einem Matrixcode.

    Syntax: {=MITTELWERT(WENN(B191:D191;B191:D191))}

    Wobei ich zugeben muss, dass ich das jetzt nicht verstanden habe, warum das so ist. Jetzt habe ich auch noch das Problem, dass der Mittelwert in Zelle S191 sich nicht wie im og Fall aus einem Zellenbereich wie zB (B191:D191) sondern aus einzelnen durch Semikolon getrennten Werten/Zellen -> (E191;K191;Q191). Jetzt ist aber in der Matrixfunktion der erste Wertebereich ebenfalls durch ein Semikolon mit dem zweiten Wertebereich getrennt. Mein naiver Gedanke die beiden Wertbereiche in Klammern zu setzen scheitert allerdings mit einem Fehler im Wert:

    {=MITTELWERT(WENN((E191;K191;Q191);(E191;K191;Q191)))}

    Ich bekomme #WERT! in Zelle S191 angezeigt. Wie komme ich in diesem Fall zu einem korrekten Matrixcode?

    Thx & Bye Tom

    Dienstag, 19. Juni 2012 08:38
  • Hallo Thomas,

    [Excel 2011 (Mac); http://media.prontosystems.org/v/bk/excel_mittelwert.png.html] Der einzig reele Wert, welcher mittlerweile eingetragen wurde ist der Wert 9 in Zelle C191...

    Ist 0 (Null) kein reeller Wert? Warum lässt du die Zellen dann nicht einfach leer?
    Mir steht kein Excel für Mac zur Verfügung. Aber schau doch mal, ob es nicht auch dort die Funktion Mittelwertwenn() gibt. Dann kannst du Nullwerte bei der Berechnung des Mittelwertes ausschließen. Allerdings stößt du dann beispielsweise in K191 auf das Problem, dass Excel nichts zu summieren hat und dieses Nichts dann durch Null dividieren soll (#DIV/0!).


    Viele Grüße
    Lisa [MS MVP Word]

    Mittwoch, 20. Juni 2012 09:50
  • Servus,

    > Aber schau doch mal, ob es nicht auch dort die Funktion Mittelwertwenn() gibt.

    Ja gibt es, hab ich ja auch schon im ersten Posting verwendet.

    > Dann kannst du Nullwerte bei der Berechnung des Mittelwertes ausschließen. Allerdings stößt du dann beispielsweise in K191 auf das Problem, dass Excel nichts zu summieren hat und dieses Nichts dann durch Null dividieren soll (#DIV/0!).

    Und gäbe es da eine brauchbare Lösung dafür?

    Thx & Bye Tom

    Montag, 9. Juli 2012 11:33
  • Hallo Tom,

    in deinen Beiträgen hast du die Funktion Mittelwert() erwähnt. Ich dagegen sprach von der Funktion Mittelwertwenn().

    Viele Grüße

    Lisa

    Freitag, 27. Juli 2012 16:38