none
Updateverteilung funktioniert nicht mehr. RRS feed

  • Frage

  • Hallo Community, 

    Unsere Updateverteilung über SCCM 2012 R2 SP1 funktioniert nicht mehr. Wir mussten den SCCM Server, nach Problemen mit dem OS neu installieren, die Datenbank konnten wir sichern und damit haben wir auf einem neuen Server eine Restore Installation gemacht. Es läuft alles, alle Komponenten und Systeme sind grün. Pakete können verteilt werden usw. WSUS_SYNC funktioniert auch und ich habe ein neues Updatepaket mit den Juli Updates erstellt. Dieses kommt aber auf den Clients nicht an. Alles ist augenscheinlich so wie vor der Neuinstallation. 

    Merkwürdig wird es beim prüfen der Compliance für bestimmte Collections und Updategruppen. Wir machen jeden Monat eine Gruppe und verteilen diese an mehrere Collections. Schaue ich mir die Reports dazu an, stehen die meisten Systeme in Status "Unbekannter Kompatibilitätszustand" 

    Nun habe ich zum Testen eine Tasksequenz erstellt, die alle Updates installieren soll und vorher einen Updatescan triggert. Die logfiles unten verraten mir nicht die Ursache, nur das der Installationsschritt auf einen Timeout läuft. 

    Hat irgendjemand eine Idee wo ich noch schauen kann um die Ursache zu finden? 

    Oder habe ich in den Logs den entscheidenden Hinweis übersehen?

    Die SMSTS.og sagt mir das die Schritte erfolgreich gestartet werden und dann: 

    …..<![LOG[Policy evaluation initiated]LOG]!><time="11:31:38.237-120" date="07-14-2016" component="InstallSWUpdate" context="" type="1" thread="3772" file="utils.cpp:4437"> 
    <![LOG[GetIPriviledgedInstallInterface successful]LOG]!><time="11:31:38.247-120" date="07-14-2016" component="InstallSWUpdate" context="" type="0" thread="3772" file="installswupdate.cpp:47"> 
    <![LOG[Refreshing Updates]LOG]!><time="11:31:38.247-120" date="07-14-2016" component="InstallSWUpdate" context="" type="0" thread="3772" file="installswupdate.cpp:473"> 
    <![LOG[Successfully initiated RefreshUpdates operation ]LOG]!><time="11:31:38.921-120" date="07-14-2016" component="InstallSWUpdate" context="" type="1" thread="3772" file="installswupdate.cpp:483"> 
    <![LOG[Waiting for RefreshUpdates complete notification from Updates Deployment Agent]LOG]!><time="11:31:39.040-120" date="07-14-2016" component="InstallSWUpdate" context="" type="1" thread="3772" file="installswupdate.cpp:1251"> 
    <![LOG[FALSE, HRESULT=800705b4 (e:\nts_sccm_release\sms\client\osdeployment\installswupdate\installswupdate.cpp,1273)]LOG]!><time="12:01:39.060-120" date="07-14-2016" component="InstallSWUpdate" context="" type="0" thread="3772" file="installswupdate.cpp:1273"> 
    <![LOG[Timedout waiting for updates refresh complete notification]LOG]!><time="12:01:39.060-120" date="07-14-2016" component="InstallSWUpdate" context="" type="3" thread="3772" file="installswupdate.cpp:1273"> 

    Die UpdatesDeployment.log sagt: 

    <![LOG[Detection job ({14B42D4B-D944-4494-8188-7C75BCBD0DF8}) started for assignment ({93EDC372-FAE4-4417-9676-54A5977A6E90})]LOG]!><time="11:31:38.823-120" date="07-14-2016" component="UpdatesDeploymentAgent" context="" type="1" thread="3420" file="updatesassignment.cpp:1196"> 
    <![LOG[Redetecting Assignment ({424B0E2C-D1A8-44DF-A52C-69128521275A})]LOG]!><time="11:31:38.827-120" date="07-14-2016" component="UpdatesDeploymentAgent" context="" type="1" thread="3420" file="updatesassignment.cpp:861"> 
    <![LOG[Cancelling active CI Agent job - {E7C13B86-9BA5-4C90-B60E-24EE28035402} for assignment ({424B0E2C-D1A8-44DF-A52C-69128521275A})]LOG]!><time="11:31:38.827-120" date="07-14-2016" component="UpdatesDeploymentAgent" context="" type="1" thread="3420" file="updatesassignment.cpp:3107"> 
    <![LOG[Detection job ({9416AB5C-09C0-4E2D-8978-DF01CE1F3243}) started for assignment ({424B0E2C-D1A8-44DF-A52C-69128521275A})]LOG]!><time="11:31:38.906-120" date="07-14-2016" component="UpdatesDeploymentAgent" context="" type="1" thread="3420" file="updatesassignment.cpp:1196"> 
     

    Und dann nix mehr. 


    Der letzte Eintrag in UpdatesHandler.og ist: 

    <![LOG[Successfully initiated scan.]LOG]!><time="11:31:40.634-120" date="07-14-2016" component="UpdatesHandler" context="" type="1" thread="3932" file="capplicabilityhandler.cpp:515"> 

    Ansonsten auch nichts was auf einen Fehler hindeutet 

    Und in der UpdatesStore stehen am Ende viele Einträge der Art: 

    <![LOG[Queried Update (f782b6c4-2b86-4eb7-9708-5531bc6c1a8f): Status=Missing, Title=Sicherheitsupdate für Microsoft .NET Framework 3.5 unter Windows 8.1 und Windows Server 2012 R2 für x64-basierte Systeme (KB2972103), BulletinID=MS14-057, QNumbers=2972103, LocaleID=, ProductID=0fa1201d-4330-4fa8-8ae9-b877473b6441, UpdateClassification = 0fa1201d-4330-4fa8-8ae9-b877473b6441, ExcludeForStateReporting=FALSE.]LOG]!><time="11:31:39.685-120" date="07-14-2016" component="UpdatesStore" context="" type="1" thread="3900" file="cupdatesstore.cpp:1313"> 
    <![LOG[Queried Update (f7c02df0-0cb8-4a56-b367-7efd5c9bc9ac): Status=Installed, Title=Sicherheitsupdate für Windows Server 2012 R2 (KB3071756), BulletinID=MS15-085, QNumbers=3071756, LocaleID=, ProductID=0fa1201d-4330-4fa8-8ae9-b877473b6441, UpdateClassification = 0fa1201d-4330-4fa8-8ae9-b877473b6441, ExcludeForStateReporting=FALSE.]LOG]!><time="11:31:39.685-120" date="07-14-2016" component="UpdatesStore" context="" type="1" thread="3900" file="cupdatesstore.cpp:1313"> 
    <![LOG[Queried Update (fa8b1451-89ad-44ea-ad22-d14ac8106ad3): Status=Installed, Title=Sicherheitsupdate für Microsoft .NET Framework 4.5.1 und 4.5.2 für Windows 8.1 für x64-basierte Systeme (KB3097997), BulletinID=MS15-118, QNumbers=3097997, LocaleID=, ProductID=0fa1201d-4330-4fa8-8ae9-b877473b6441, UpdateClassification = 0fa1201d-4330-4fa8-8ae9-b877473b6441, ExcludeForStateReporting=FALSE.]LOG]!><time="11:31:39.685-120" date="07-14-2016" component="UpdatesStore" context="" type="1" thread="3900" file="cupdatesstore.cpp:1313"> 
    <![LOG[Queried Update (fb95c1c8-de23-4089-ae29-fd3351d55421): Status=Installed, Title=Sicherheitsupdate für Windows Server 2012 R2 (KB3004365), BulletinID=MS15-006, QNumbers=3004365, LocaleID=, ProductID=0fa1201d-4330-4fa8-8ae9-b877473b6441, UpdateClassification = 0fa1201d-4330-4fa8-8ae9-b877473b6441, ExcludeForStateReporting=FALSE.]LOG]!><time="11:31:39.685-120" date="07-14-2016" component="UpdatesStore" context="" type="1" thread="3900" file="cupdatesstore.cpp:1313"> 
    <![LOG[Querying update status completed successfully.]LOG]!><time="11:31:39.685-120" date="07-14-2016" component="UpdatesStore" context="" type="1" thread="3900" file="cupdatesstore.cpp:1287"> 

    • Bearbeitet Holger_dV Donnerstag, 14. Juli 2016 12:08 ergänzt
    Donnerstag, 14. Juli 2016 12:07

Antworten

  • Moin,

    Inzwischen sind alle Einstellungen wieder hergestellt und die Verteilung von Updates läuft wieder.

    In diesem Fall hat also die vollständige Deinstallation aller beteiligten Komponenten und das anschließende neu installieren geholfen.

    Vielen Dank, vor allem an Torsten, für die vielen Tipps!

    Gruß Holger


    Thankful for any Suggestion Holger

    Montag, 8. August 2016 09:01

Alle Antworten

  • Passt nicht alles in den Beitrag oben....

    Die Windows Update.log sieht in dem Zeitraum so aus: 

    2016-07-14 11:31:04:180  812 e6c Agent   * Added update {BA0F75FF-19C3-4CBD-A3F3-EF5B5C0F88BF}.202 to search result 
    2016-07-14 11:31:04:181  812 e6c Agent   * Found 300 updates and 77 categories in search; evaluated appl. rules of 838 out of 1897 deployed entities 
    2016-07-14 11:31:04:183  812 e6c Agent Reporting status event with 219 installable, 153 installed,  0 installed pending, 0 failed and 0 downloaded updates 
    2016-07-14 11:31:04:183  812 588 Report REPORT EVENT: {B5C0AA10-0499-49BA-9C99-48E19B68E723} 2016-07-14 11:31:04:183+0200 1 147 [AGENT_DETECTION_FINISHED] 101 {00000000-0000-0000-0000-000000000000} 0 0 CcmExec Success Software Synchronization Windows Update Client successfully detected 300 updates. 
    2016-07-14 11:31:04:183  812 588 Report REPORT EVENT: {14331252-9794-41DF-B368-329BD9654A70} 2016-07-14 11:31:04:183+0200 1 156 [AGENT_STATUS_30] 101 {00000000-0000-0000-0000-000000000000} 0 0 CcmExec Success Pre-Deployment Check Reporting client status. 
    2016-07-14 11:31:04:184  812 588 Report CWERReporter finished handling 10 events. (00000000) 
    2016-07-14 11:31:04:184  812 588 Report CWERReporter finished handling 10 events. (00000000) 

    (Wiederholungen entfernt)

    2016-07-14 11:31:04:188  812 e6c Agent ********* 
    2016-07-14 11:31:04:188  812 e6c Agent **  END  **  Agent: Finding updates [CallerId = CcmExec  Id = 3] 
    2016-07-14 11:31:04:188  812 e6c Agent ************* 
    2016-07-14 11:31:04:188  812 588 Report CWERReporter finished handling 10 events. (00000000) 
    2016-07-14 11:31:04:188  812 588 Report CWERReporter finished handling 10 events. (00000000) 
    2016-07-14 11:31:04:188  812 588 Report CWERReporter finished handling 10 events. (00000000) 
    2016-07-14 11:31:04:188  812 588 Report CWERReporter finished handling 10 events. (00000000) 
    2016-07-14 11:31:04:188  812 e6c IdleTmr WU operation (CSearchCall::Init ID 3, operation # 42) stopped; does use network; is not at background priority 
    2016-07-14 11:31:04:188  812 e6c IdleTmr Decremented idle timer priority operation counter to 0 
    2016-07-14 11:31:04:191 2408 810 COMAPI >>--  RESUMED  -- COMAPI: Search [ClientId = CcmExec] 
    2016-07-14 11:31:04:857 2408 810 COMAPI   - Updates found = 300 
    2016-07-14 11:31:04:857 2408 810 COMAPI --------- 
    2016-07-14 11:31:04:857 2408 810 COMAPI --  END  --  COMAPI: Search [ClientId = CcmExec] 
    2016-07-14 11:31:04:857 2408 810 COMAPI ------------- 
    2016-07-14 11:31:09:188  812 588 Report CWERReporter finished handling 2 events. (00000000) 
    2016-07-14 11:41:08:388  812 5b8 AU Earliest future timer found:  
    2016-07-14 11:41:08:388  812 5b8 AU     Timer: CF1ABEC6-7887-4964-BB93-B2E21B31CEC1, Expires 2016-07-14 09:45:08, not idle-only, not network-only 
    2016-07-14 11:45:08:390  812 924 AU Adding timer:  
    2016-07-14 11:45:08:390  812 924 AU     Timer: CF1ABEC6-7887-4964-BB93-B2E21B31CEC1, Expires 2016-07-15 09:45:08, not idle-only, not network-only 
    2016-07-14 11:45:08:431  812 924 AU Adding timer:  
    2016-07-14 11:45:08:431  812 924 AU     Timer: 29A863E7-8609-4D1E-B7CD-5668F857F1DB, Expires 2016-07-15 09:45:08, not idle-only, not network-only 
    2016-07-14 11:51:08:397  812 448 AU Earliest future timer found:  
    2016-07-14 11:51:08:397  812 448 AU     Timer: 31DA7559-FE27-4810-8FF6-987195B1FD98, Expires 2016-07-15 03:59:28, not idle-only, not network-only 
    2016-07-14 11:51:09:398  812 924 AU ###########  AU: Uninitializing Automatic Updates  ########### 
    2016-07-14 11:51:09:424  812 924 WuTask Uninit WU Task Manager 
    2016-07-14 11:51:09:454  812 924 AU Earliest future timer found:  
    2016-07-14 11:51:09:454  812 924 AU     Timer: 31DA7559-FE27-4810-8FF6-987195B1FD98, Expires 2016-07-15 03:59:28, not idle-only, not network-only 
    2016-07-14 11:51:09:479  812 924 AU Earliest future timer found:  
    2016-07-14 11:51:09:479  812 924 AU     Timer: 31DA7559-FE27-4810-8FF6-987195B1FD98, Expires 2016-07-15 03:59:28, not idle-only, not network-only 
    2016-07-14 11:51:09:528  812 924 Service ********* 
    2016-07-14 11:51:09:528  812 924 Service **  END  **  Service: Service exit [Exit code = 0x240001] 
    2016-07-14 11:51:09:528  812 924 Service *************



    Thankful for any Suggestion Holger

    Donnerstag, 14. Juli 2016 12:11
  • LocationServices.log sollte anzeigen, welche Katalog-Version der Client anfordert. Vergleiche dies mal mit der Version unter \Monitoring\Overview\Software Update Point Synchronization Status.

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 14. Juli 2016 12:24
    Beantworter
  • Hallo Torsten,

    danke für den schnellen Hinweis!

    Catalog Version auf dem SCCM = 7

    Ich vermute die Version die angefordert wird steht hier:

    <![LOG[Calling back with the following WSUS locations]LOG]!><time="11:30:54.711-120" date="07-14-2016" component="LocationServices" context="" type="1" thread="2064" file="lsutils.cpp:2967">
    <![LOG[WSUS Path='http://MYSCCM-FQDN:8530', Server='MYSCCM-FQDN', Version='7']LOG]!><time="11:30:54.711-120" date="07-14-2016" component="LocationServices" context="" type="1" thread="2064" file="lsutils.cpp:2987">
    <![LOG[Machine is not in quarantine. No need to add WSUS locations.]LOG]!><time="11:30:54.711-120" date="07-14-2016" component="LocationServices" context="" type="0" thread="2064" file="ccmnappkglocationfilter.cpp:2136">

    Deckt sich also :-(


    Thankful for any Suggestion Holger

    Donnerstag, 14. Juli 2016 13:22
  • Das passt das schonmal zusammen.
    Kannst Du Updates*.log, ScanAgent.log, WUAHandler.log und WindowsUpdate.log bereitstellen?

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 14. Juli 2016 13:27
    Beantworter
  • Klar kann ich machen. Wo denn?

    Thankful for any Suggestion Holger

    Donnerstag, 14. Juli 2016 13:31
  • OneDrive, DropBox etc

    Torsten Meringer | http://www.mssccmfaq.de

    Donnerstag, 14. Juli 2016 13:51
    Beantworter
  • :-)

    https://1drv.ms/f/s!Ag0tf3-uBgozmJNd2IzaxyF1kd7yPg


    Thankful for any Suggestion Holger

    Donnerstag, 14. Juli 2016 13:53
  • Spontan ist kein Fehler zu sehen. Was zeigt denn die Monitoring Node zu dem Deployment an?

    Torsten Meringer | http://www.mssccmfaq.de

    Freitag, 15. Juli 2016 07:12
    Beantworter
  • Das ist etwas merkwürdig. Die neuen Deployments sind alle bei 0% Compliance. Aber nicht wegen Fehler sollen im Deployment Status unknown.

    Schaue ich in den Status rein, stehen alle Systeme auf "Client check passed/Active"

    Also scheinen ja die Informationen der Clients nicht mehr beim SCCM Server anzukommen...


    Thankful for any Suggestion Holger

    Freitag, 15. Juli 2016 07:48
  • Leider keine Änderung.

    Wir haben im Moment auch noch diesen lästigen Konsolenbug aus dem SP1 für R2. Die Konsole reagiert jedes Mal nicht mehr wenn ich mir die Deployments anzeigen lassen will.

    Nun gehe ich erst mal in den Urlaub, danach werden die Kollegen den SP1 Client auf allen Systemen installiert haben und dann installieren wir das CU3.

    Wenn es dann immer noch nicht funktioniert, werde ich mal alle Deployments für Updates löschen, die Updatepakete entfernen und den SUP runter schmeißen.


    Thankful for any Suggestion Holger

    Freitag, 15. Juli 2016 11:37
  • Ich glaube nicht, dass SUP entfernen und neu hinzufügen helfen wird. Problem ist, dass das recht komplex ist und per Forum immer nur "Snapshots" (per Log) auf einen kurzen Zeitpunkt sind. Vielleicht hilft ja auch SP/CU - was ich aber auch nicht wirklich glaube. Schönen Urlaub erstmal! ;-)

    Torsten Meringer | http://www.mssccmfaq.de

    Freitag, 15. Juli 2016 11:44
    Beantworter
  • Melde mich zurück und bin schon mit dem selben Fleiße wieder an der gleichen...  :-)

    Ich hatte auf die Selbstheilungskräfte des SCCM gehoft, war aber nix :-( Einzig das der SCCM nun keine Clients mehr mit unbekanntem Kompatibilitätsstatus in Bezug auf die Updates in den Reports hatte, hat sich geändert. Der Status "Nicht kompatibel" stimmte aber definitiv bei den meisten nicht.

    Die Installation des CU3 (Für R2 SP1) hat wie erwartet keine Änderung gebracht. Ich habe heute noch diverse Dinge versucht und mich weiter durch die Logs gewühlt, ohne neue Erkenntnisse.

    Jetzt habe ich:

    1. alle Updategruppen und Pakete gelöscht, incl. aller Paketverzeichnisse.
    2. den SUP deinstalliert
    3. den WSUS incl. DB deinstalliert
    4. das WSUS Content Verzeichnis gelöscht
    5. die Client Policy angepasst und die Updateeinstellungen entfernt
    6. ja... 6. ???

    Was sollte ich noch tun, um Altlasten loszuwerden? Gibt es einen Script um die Datenbank von SUP Altlasten zu befreien?

    Habt Ihr da noch Tipps für mich?


    Thankful for any Suggestion Holger

    Mittwoch, 27. Juli 2016 13:17
  • Moin,

    Inzwischen sind alle Einstellungen wieder hergestellt und die Verteilung von Updates läuft wieder.

    In diesem Fall hat also die vollständige Deinstallation aller beteiligten Komponenten und das anschließende neu installieren geholfen.

    Vielen Dank, vor allem an Torsten, für die vielen Tipps!

    Gruß Holger


    Thankful for any Suggestion Holger

    Montag, 8. August 2016 09:01