none
Problem bei Printserverkonfiguration: Hinzufügen von x86-Treibern unter Server 2008 R2 RRS feed

  • Frage

  • Hi,

    ich habe einen Printserver unter Win 2008 R2 aufgesetzt, der jetzt sowohl 32, als auch 64-bit-Treiber zur Verfügung stellen soll.

    Wenn ich jedoch einen 32-bit-Treiber in den Freigabeoptionen eines Druckers hinzufügen möchte, erhalte ich folgende Meldung:

    "Der ausgewählte Treiber muss remote von einem x86-Computer unter Verwendung von Treibern des Typs 3 (Benutzermodus) installiert werden."

    Was genau muss ich da wie von einem Rechner mit 32-bit-Windows installieren? Ich mache das zum ersten Mal und stehe daher etwas auf dem Schlauch.

    Vielen Dank für Hilfe :)

    Freitag, 4. Februar 2011 10:04

Antworten

  • Es hat nun endlich geklappt. Das Problem war, dass beim Anschliessen des Druckers an den Server automatisch die Druckertreiber des HP Laserjet 1300 installiert wurden. Ich habe zwar dann im Nachhinein den Universal PCL6 Treiber installiert, aber der kam sich dann irgendwie mit dem Originaltreiber ins Gehege.Nachdem ich den Originaltreiber gelöscht hatte konnte ich endlich den X86 Treiber installieren. Winfried, vielen Dank für Deine Hilfe, die Vorgehensweise gem. dem Link im 2ten. Beitrag führt zum Erfolg.Konnte damit Problemlos noch ein Kyocera Drucker einbinden.

     

    Zum Schluss noch eine Frage. Mir bleibt jetzt noch ein OKI ML 590 Nadeldrucker übrig, der hat kein USB Anschluss, sondern ein Parallelport. Habe mir eine PCI Express Card besorgt, und diese auch installiert. Nur ist leider der Treiber nicht signiert. Ich möchte nicht jedesmal den Server mit gedrückter F8 Taste hochfahren um die Zwangsüberprüfung der Signatur zu unterbinden. Was für Möglichkeiten bleiben mir da noch ? Der Tip mit den Gruppenrichtlinien funktioniert leiner nur bis Windows Server 2003. Gibts da noch ne andere Möglichkeit?

     

    Gruss

    Frank

    Montag, 7. Februar 2011 23:00

Alle Antworten

  • Am 04.02.2011 schrieb EvilEcki:

    ich habe einen Printserver unter Win 2008 R2 aufgesetzt, der jetzt sowohl 32, als auch 64-bit-Treiber zur Verfügung stellen soll.

    Wenn ich jedoch einen 32-bit-Treiber in den Freigabeoptionen eines Druckers hinzufügen möchte, erhalte ich folgende Meldung:

    "Der ausgewählte Treiber muss remote von einem x86-Computer unter Verwendung von Treibern des Typs 3 (Benutzermodus) installiert werden."

    Dieser Artikel sollte Licht ins Dunkel bringen:
    http://www.faq-o-matic.net/2010/01/06/windows-druckserver-treiber-fr-32-und-64-bit-clients/
    Und diesen Artikel nimmst Du auch gleich mit:
    http://www.faq-o-matic.net/2009/10/08/drucken-unter-windows-7-in-der-domne/

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Freitag, 4. Februar 2011 10:30
  • Hi,

    ich hab die in den Artikeln beschriebenen Schritte durchgeführt, allerdings erhalte ich beim Hinzufügen des Treibers über meine 32-bit Windows 7-VM immer noch dieselbe Fehlermeldung.

    Montag, 7. Februar 2011 06:50
  • Wir haben die Erfahrung gemacht, dass dieser Fehler auftritt, wenn der Name des Druckers (innerhalb der INF-Datei)

    zwischen dem x64 und x86 Treiber unterschiedlich ist.

    Also am besten den aktuellen x64 von der Herstellerseite laden und auch gleich den dazugehörigen x86 Treiber.

    Montag, 7. Februar 2011 08:01
  • Wir haben die Erfahrung gemacht, dass dieser Fehler auftritt, wenn der Name des Druckers (innerhalb der INF-Datei)

    zwischen dem x64 und x86 Treiber unterschiedlich ist.

    Also am besten den aktuellen x64 von der Herstellerseite laden und auch gleich den dazugehörigen x86 Treiber.


    Das habe ich natürlich gemacht, die Treiber haben die gleiche Version, enthalten die gleichen Druckernamen und haben das gleiche Datum.

    Leider funktioniert die Installation immer noch nicht.

    Montag, 7. Februar 2011 09:31
  • Am 07.02.2011 schrieb EvilEcki:

    Das habe ich natürlich gemacht, die Treiber haben die gleiche Version, enthalten die gleichen Druckernamen und haben das gleiche Datum.

    Leider funktioniert die Installation immer noch nicht.

    Du verbindest dich von einem 32Bit Client aus via
    \\Printserver\Drucker zu dem Drucker?

    Wenn Du wirklich Schritt für Schritt genauso wie im Artikel gemacht
    hast, ist IMHO jetzt der Zeitpunkt gekommen, den Hersteller der
    Druckertreiber zu kontaktieren.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 7. Februar 2011 09:44
  • Ja, die Verbindung baue ich genauso auf.

    Der Drucker/Treiberhersteller ist Konica Minolta. Eigentlich dachte ich, dass die vernünftige Treiber anbieten. :/

    Montag, 7. Februar 2011 10:31
  • Am 07.02.2011 schrieb EvilEcki:

    Ja, die Verbindung baue ich genauso auf.

    OK.

    Der Drucker/Treiberhersteller ist Konica Minolta. Eigentlich dachte ich, dass die vernünftige Treiber anbieten. :/

    Naja, früher war ein Name Programm, heute ist nichts mehr sicher. ;)
    Was sagt der Support?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 7. Februar 2011 11:12
  • Jetzt hänge ich mich auch an den thread, da auch ich es nicht schaffe dem Windows 2008 R2 Server die 32bit Druckertreiber unterzujubeln. In meinem Fall ist es ein HP Laserjet 1300. Ich habe mit den Universal PCL5/PCL6 Treibern probiert. Die Treiber sind von Februar 2011. Die Installation startet, bricht dann aber mit folgender Fehlermeldung ab:

    Ein Treiber HP Universal Printing PCL6 X86, Typ 3 - Benutzermodus konnte nicht installiert werden. Der Vorgang konnte nicht abgeschlossen werden. (Fehler 0x0000007c)

     

    Was nun ?

     

    Gruss

    Frank

    Montag, 7. Februar 2011 17:43
  • Am 07.02.2011 schrieb areito2:

    Jetzt hänge ich mich auch an den thread, da auch ich es nicht schaffe dem Windows 2008 R2 Server die 32bit Druckertreiber unterzujubeln. In meinem Fall ist es ein HP Laserjet 1300. Ich habe mit den Universal PCL5/PCL6 Treibern probiert. Die Treiber sind von Februar 2011. Die Installation startet, bricht dann aber mit folgender Fehlermeldung ab:

    Du probierst das von einem 32Bit Client aus? Bist Du als Admin
    angemeldet?

    Ein Treiber HP Universal Printing PCL6 X86, Typ 3 - Benutzermodus konnte nicht installiert werden. Der Vorgang konnte nicht abgeschlossen werden. (Fehler 0x0000007c)

    Hier
    http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?lang=en&cc=us&prodNameId=238322&prodSeriesId=238320&prodTypeId=18972&taskId=135&swLang=18
    gibts 64Bit und 32bit Treiber. Bist Du exakt wie in dem von mir
    geposteten Artikel vorgegangen?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 7. Februar 2011 17:53
  • Handelt es sich dabei um signierte Treiber?

    Schau dir bitte auch mal diesen Lösungsweg an:

    http://blogs.technet.com/b/sieben/archive/2009/12/03/drucker-auf-windows-7-x64-64-bit-im-netzwerk-freigeben.aspx

    Montag, 7. Februar 2011 18:02
  • Es hat nun endlich geklappt. Das Problem war, dass beim Anschliessen des Druckers an den Server automatisch die Druckertreiber des HP Laserjet 1300 installiert wurden. Ich habe zwar dann im Nachhinein den Universal PCL6 Treiber installiert, aber der kam sich dann irgendwie mit dem Originaltreiber ins Gehege.Nachdem ich den Originaltreiber gelöscht hatte konnte ich endlich den X86 Treiber installieren. Winfried, vielen Dank für Deine Hilfe, die Vorgehensweise gem. dem Link im 2ten. Beitrag führt zum Erfolg.Konnte damit Problemlos noch ein Kyocera Drucker einbinden.

     

    Zum Schluss noch eine Frage. Mir bleibt jetzt noch ein OKI ML 590 Nadeldrucker übrig, der hat kein USB Anschluss, sondern ein Parallelport. Habe mir eine PCI Express Card besorgt, und diese auch installiert. Nur ist leider der Treiber nicht signiert. Ich möchte nicht jedesmal den Server mit gedrückter F8 Taste hochfahren um die Zwangsüberprüfung der Signatur zu unterbinden. Was für Möglichkeiten bleiben mir da noch ? Der Tip mit den Gruppenrichtlinien funktioniert leiner nur bis Windows Server 2003. Gibts da noch ne andere Möglichkeit?

     

    Gruss

    Frank

    Montag, 7. Februar 2011 23:00
  • Am 08.02.2011 schrieb areito2:

    Es hat nun endlich geklappt. Das Problem war, dass beim Anschliessen des Druckers an den Server automatisch die Druckertreiber des HP Laserjet 1300 installiert wurden. Ich habe zwar dann im Nachhinein den Universal PCL6 Treiber installiert, aber der kam sich dann irgendwie mit dem Originaltreiber ins Gehege.Nachdem ich den Originaltreiber gelöscht hatte konnte ich endlich den X86 Treiber installieren. Winfried, vielen Dank für Deine Hilfe, die Vorgehensweise gem. dem Link im 2ten. Beitrag führt zum Erfolg.Konnte damit Problemlos noch ein Kyocera Drucker einbinden.

    Wunderbar, freut mich für Dich und Danke für die Rückmeldung. ;)

    Zum Schluss noch eine Frage. Mir bleibt jetzt noch ein OKI ML 590 Nadeldrucker übrig, der hat kein USB Anschluss, sondern ein Parallelport. Habe mir eine PCI Express Card besorgt, und diese auch installiert. Nur ist leider der Treiber nicht signiert. Ich möchte nicht jedesmal den Server mit gedrückter F8 Taste hochfahren um die Zwangsüberprüfung der Signatur zu unterbinden. Was für Möglichkeiten bleiben mir da noch ? Der Tip mit den Gruppenrichtlinien funktioniert leiner nur bis Windows Server 2003. Gibts da noch ne andere Möglichkeit?

    Welche Gruppenrichtlinien meinst Du? Hier findest Du alle Richtlinien,
    evtl. ist ja die richtige dabei.
    http://www.gruppenrichtlinien.de/RiLi/Uebersicht_Richtlinien_2008R2.htm

    Ich hätte den Drucker an einen kleinen Printserver angeschlossen, der
    PS dann via LAN an den 2008R2. IMHO bist Du dann auch flexibler.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Dienstag, 8. Februar 2011 09:17
  • Möchte den thread noch einmal ausgraben. Der Drucker funktioniert einwandfrei mit der PCIe Lösung. Da Server und die 5 Clients im gleichen Raum sind, möchte ich mit so wenig wie möglich Gerätschaften auskommen, daher möchte ich nicht unbedingt auf den Printserver zurückgreifen. Nur ist es nervig den Server mit gedrückter F8 Taste hochzufahren.

    Ich hatte gpedit.msc geöffnet und dort unter Administrative Vorlagen/System/Treiberinstallation/Codesignatur für Gerätetreiber/Eigenschaften das Häkchen auf aktiviert gesetzt und dann "Beim Ermitteln einer Treiberdatei ohne Digitalsignatur" auf Ignorieren geklickt.

    Aber das funktioniert scheinbar nur bis zu einem Windows 2003 Server.

    Ich weiss nicht, ob der folgende Link eine Lösung wäre: http://www.ngohq.com/home.php?page=dseo

    Bin im allgemeinen kein Freund mir solche Dinge aufzuhalsen. Gibt es vielleicht nicht doch noch eine andere Lösung ?

    Gruss

    Frank

    Mittwoch, 16. Februar 2011 08:30
  • Am 16.02.2011 schrieb areito2:

    Möchte den thread noch einmal ausgraben. Der Drucker funktioniert einwandfrei mit der PCIe Lösung. Da Server und die 5 Clients im gleichen Raum sind, möchte ich mit so wenig wie möglich Gerätschaften auskommen, daher möchte ich nicht unbedingt auf den Printserver zurückgreifen. Nur ist es nervig den Server mit gedrückter F8 Taste hochzufahren.

    Wie oft startest Du den Server?

    Ich weiss nicht, ob der folgende Link eine Lösung wäre: http://www.ngohq.com/home.php?page=dseo

    Ich würde es zuerst auf einem Testsystem ausprobieren.

    Bin im allgemeinen kein Freund mir solche Dinge aufzuhalsen. Gibt es vielleicht nicht doch noch eine andere Lösung ?

    Ich weiß nichts anderes, muß aber nichts bedeuten. Bekommst Du von OKI
    keinen signierten Treiber?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Mittwoch, 16. Februar 2011 09:59
  • Winfried,

    vielen Dank für Deinen Rat und die Geduld mit mir. Das Problem ist nicht der OKI Drucker, dort sind die Treiber signiert, sondert die Parallelport PCIe Karte die ich verbaut habe. Dort finde ich leider nur einen nicht signierten Vista 64bit Treiber.

     

    Im allgemeinen fahre ich den Server übers Wochenende herunter, hier am Bodensee haben wir im Sommer ordentliche Gewitter da kann es sein, dass ich ihn auch unter der Woche runterfahre. Problematisch kann es werden wenn ich im Urlaub bin.

     

    Hatte den Windows 2003 SBS Server problemlos seit 2004 am laufen und hoffe der 2008 läuft letztendlich auch ohne Probleme.

     

    Gruss

     

    Frank

     

    Mittwoch, 16. Februar 2011 15:04
  • Am 16.02.2011 schrieb areito2:

    vielen Dank für Deinen Rat und die Geduld mit mir. Das Problem ist nicht der OKI Drucker, dort sind die Treiber signiert, sondert die Parallelport PCIe Karte die ich verbaut habe. Dort finde ich leider nur einen nicht signierten Vista 64bit Treiber.

    Deshalb hatte ich dir ja empfohlen, lieber einen kleinen Printserver
    ins Netz zu stellen. Daran schließt Du dann den OKI mit der Parallelen
    Schnittstelle an. Sowas meinte ich:
    http://www.amazon.de/LogiLink-Ethernet-Printserver-Drucker-Parallel/dp/B000R8SUOI/ref=pd_sim_computers_2

    Im allgemeinen fahre ich den Server übers Wochenende herunter, hier am Bodensee haben wir im Sommer ordentliche Gewitter da kann es sein, dass ich ihn auch unter der Woche runterfahre. Problematisch kann es werden wenn ich im Urlaub bin.

    Hast Du keine USV am Server angeschlossen?

    Hatte den Windows 2003 SBS Server problemlos seit 2004 am laufen und hoffe der 2008 läuft letztendlich auch ohne Probleme.

    Laufen wird er bestimmt lange, aber ob die obige Konfiguration so Sinn
    macht sei dahingestellt.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Mittwoch, 16. Februar 2011 15:27
  • Letztendlich wird es wahrscheinlich schon auf den zusätzlichen Printserver hinauslaufen, ich habe noch Zeit bis Ende August, dann fängt die neue Produktionssaison an und der Drucker wird  täglich gebraucht.

    Ich hoffe allerdings, das es bis dorthin vielleicht doch noch einen signierten Treiber gibt.

     

    Spielt es eigentlich eine Rolle ob es  ein Printserver mit Fast Ethernet oder Gigabit ist hinsichtlich der Netzwerkgeschwindigkeit, bzw. kann ein Fast Ethernet Printserver am Switch generell die Geschwindigkeit runterdrücken ? ? Laut den Amazon Bewertungen scheint der Logilink-Ethernet -Printserver auch so nicht gerade eine Rakete zu sein, ich denke da werde ich etws tiefer in die 'Tasche greifen müssen.

     

    Leider habe ich derzeit keine USV, habe allerdings einmal einen direkten Blitzeinschlag miterlebt, da hätte auch keine USV geholfen. Wobei diese natürlich prinzipiell schon Sinn macht.

     

    Gruss

    Frank

     

    Donnerstag, 17. Februar 2011 14:42
  • Am 17.02.2011 schrieb areito2:

    Letztendlich wird es wahrscheinlich schon auf den zusätzlichen Printserver hinauslaufen, ich habe noch Zeit bis Ende August, dann fängt die neue Produktionssaison an und der Drucker wird  täglich gebraucht.

    Ich hoffe allerdings, das es bis dorthin vielleicht doch noch einen signierten Treiber gibt.

    Die Hoffnung stirbt zuletzt.

    Spielt es eigentlich eine Rolle ob es  ein Printserver mit Fast Ethernet oder Gigabit ist hinsichtlich der Netzwerkgeschwindigkeit, bzw. kann ein Fast Ethernet Printserver am Switch generell die Geschwindigkeit runterdrücken ? ? Laut den Amazon Bewertungen scheint der Logilink-Ethernet -Printserver auch so nicht gerade eine Rakete zu sein, ich denke da werde ich etws tiefer in die 'Tasche greifen müssen.

    Das war ja auch nur ein Beispiel. Lass dir bei einem Händler vor Ort
    zwei oder drei solcher Printserver zum testen geben. Dann kannst Du in
    aller Ruhe den für dich am besten geeigneten raussuchen.

    Leider habe ich derzeit keine USV, habe allerdings einmal einen direkten Blitzeinschlag miterlebt, da hätte auch keine USV geholfen. Wobei diese natürlich prinzipiell schon Sinn macht.

    Elektriker sind die Fachleute für sowas. Die sollten in Sachen
    Blitzeinschlag befragt werden.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Donnerstag, 17. Februar 2011 15:00
  • Hallo,

    im Treiberpaket nach der inf-Datei suchen und diese in einem Editor öffnen.

    Dort nach einem Eintrag LayoutFile=xxx suchen und ggf. vor diese Zeile ein Semikolon ; setzen (auskommentieren).

    Die Datei abspeichern und die Installation erneut starten.

    Das Problem an dieser Fehlermeldung ist, dass der Text an sich absoluter Unsinn ist. Denn auf einem Server muss ich immer alles lokal als Administrator installieren. Dabei ist es unerheblich, ob ich direkt an diesem PC/Server sitze oder mich über einen beliebigen Client per RDP als Administrator dort anmelde.

    Das Problem liegt hierbei an alten Einträgen in der Installationsdatei des Treibers, die schnell einmal bei neuen Systemen in Vergessenheit geraten. Microsoft ändert irgend etwas, ohne dies konsequent durchzuführen und zu kommunizieren. Denn der Treiber lässt sich mit dem Eintrag LayoutFile zwar lokal auf einem 64-Bit und auf einem 32-Bit System installieren, aber eben nicht als zusätzlicher Treiber.

    D.h. Schuld haben beide: Microsoft wegen unsinnigen Fehlermeldungen und der Hersteller, weil er einen alten Eintrag übersehen hat.

    ;)


    Klaus W_

    Montag, 3. November 2014 13:08