none
IIS7 URL's nicht decoden RRS feed

Antworten

  • Hi Christian,

    laut dieser Webseite hier scheint das wohl ein beabsichtigtes Verhalten zu sein, da % als nicht sicheres Zeichen eingestuft wird:

    http://serverfault.com/questions/257680/properly-handle-iis-request-with-percent-sign-in-url

    Vielleicht findest Du in einem der Links eine Möglichkeit, das abzuschalten...


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Montag, 8. September 2014 10:06

Alle Antworten

  • Hi Christian,

    ich bin da kein Experte, aber evtl. geht es über Dritthersteller-Tools:

    http://serverfault.com/questions/47537/can-iis-be-configure-to-forward-request-to-another-web-server

    Hier nutzt einer das Tool "ISAPI Rewrite", vielleicht hilft Dir das?


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Montag, 8. September 2014 09:36
  • Hi Ben,

    danke für deine schnelle Antwort.

    Soweit ich das verstanden habe dient dieses ISAPI Rewrite nur zum URL umschreiben, also in etwa das was das URL Rewrite Modul von Microsoft auch macht.

    Allerdings ist hier nichts beschrieben das mein Problem lösen könnte. Mir geht es ja darum zu verhindern das der IIS bei dieser Seite die ge-"redirecteten" URL's encoded, also das %2F erhalten bleibt und nicht in einen / umgewandelt wird.


    Viele Grüße aus Stuttgart
    Christian Holzwarth


    Montag, 8. September 2014 09:46
  • Hi Christian,

    laut dieser Webseite hier scheint das wohl ein beabsichtigtes Verhalten zu sein, da % als nicht sicheres Zeichen eingestuft wird:

    http://serverfault.com/questions/257680/properly-handle-iis-request-with-percent-sign-in-url

    Vielleicht findest Du in einem der Links eine Möglichkeit, das abzuschalten...


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Montag, 8. September 2014 10:06
  • Naja, da meine Jenkins Installation damit nicht klar kommt habe ich nun einen Apache als Reverse Proxy genutzt, mit besagten Attirbuten, dies hat sofort funktioniert :/

    Naja trotzdem danke dir :)


    Viele Grüße aus Stuttgart
    Christian Holzwarth


    Mittwoch, 10. September 2014 12:00
  • Kein Problem, wenigstens hast Du es anderweitig hinbekommen! :-)

    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Mittwoch, 10. September 2014 12:24