none
Windows Server 2012 RDS Problem mit Anwendung RRS feed

  • Frage

  • Hallo zusammen,

    wir betreiben einen Windows Server 2012 mit installierten Remotedesktopdiensten.

    Es werden mehrere Anwendungen bereit gestellt.

    Jetzt ist eine neue Software dazu gekommen.

    Findet der Zugriff auf den RDS-Server aus dem internen Netz statt funktioniert die Anwendung ohne Probleme.

    Findet der Zugriff allerdings von Extern statt funktioniert die Anwendung leider nicht wie gewünscht.

    Standardmäßig findet der Zugriff über das Remotedesktopgateway statt.

    Auch der Zugriff direkt per RDP wurde getestet, allerdings ohne Erfolg.

    Die Anwendung stellt über Port 8080 eine Verbindung zu einem anderen Server her.

    Die Fehlermeldung lautet, das der angegeben Host nicht erreichbar wäre.

    Ein Ping und ein Telnet auf den Port 8080 sind aber erfolgreich.

    Wie gesagt, das Verhalten tritt nur bei externen Zugriffen auf.

    Vorab vielen Dank.

    Donnerstag, 29. Januar 2015 19:01

Antworten

Alle Antworten

  • Moin,

    was sagt der Hersteller der mir unbekannten Software zu dem Verhalten?

    Der MS Netzwerkmonitor auf Client und Server könnte evnetuell Aufschluss über das Kommunikationsverhalten bei LAN und WAN Zugriff geben.


    This posting is provided AS IS with no warranties.

    Donnerstag, 29. Januar 2015 19:59
  • Hallo.

    Wahrscheinlich hast dein Problem mit der Namensauflösung. Wenn du den Gateway nutzt, werden die DNS Namen ja maskiert, bedeutet ein interner Name des RDS Servers wird auf den externen Namen umgewandelt, da du ja vom Internet her keinen internen Namen ansprechen kannst. Deine Applikation ruft nun wahrscheinlich aber einen internen DNS Namen auf und es kommt zum Kommunikations-Problem. Man müsste das im Detail anschauen... aber ich würde mal da ansetzen.

    Sonntag, 1. Februar 2015 10:24
  • Hallo,

    Die Idee mit den DNS-Namen hatte ich auch schon.

    Allerdings tritt das Verhalten selbst beim verwenden der IP-Adresse auf.

    Montag, 2. Februar 2015 08:51
  • Problem wurde mit einem Softwareupdate seitens des Herstellers behoben.
    Donnerstag, 5. Februar 2015 18:23