none
Probleme mit Druckerport LPT1 im Virtual PC RRS feed

  • Frage

  • Hallo!

    Ich habe einen neuen PC mit Windows 7 Professional 64 bit. Alle bisher verwendeten Programme funktionieren, bis auf ein CAD-Programm.

    Also habe ich einen Virtual PC mit Windows XP aufgesetzt und damit habe ich das Programm tatsächlich zum Laufen gebracht. Es bleibt nur ein Problem: Das CAD-Programm verwendet einen Hardware-Dongle - und dieser wird nicht erkannt.

    Der neue PC hat keinen Parallel-Port mehr auf dem Mainboard, also habe ich eine PCI-Karte mit Parallel-Port gekauft (Digitus DS-33010). Bloss auf meinem Virtual PC erscheint gar kein LPT1-Port, somit erkennt das CAD-Programm den Dongle nicht und ich kann es deshalb nicht starten.

    Meine Frage wäre nun, wie ich am Virtual PC den LPT1 hinzufügen bzw. einrichten kann?
    • Verschoben Alex Pitulice Dienstag, 21. August 2012 12:47 Zusammenfuehrung Plan (aus:Windows 7 Installationsprobleme)
    Freitag, 11. März 2011 11:54

Antworten

  • Hallo,

    soweit ich das mitbekommen habe, wurde die Option nur aus der GUI entfernt. Per COM API ist diese weiterhin verfügbar und in der .vmc Datei gibt es auch konfigurierbare Einträge.

    Windows Virtual PC COM API:

    http://msdn.microsoft.com/en-us/library/dd796756(VS.85).aspx

    IVMParallelPort
    Defines a parallel port inside a VM.

    IVMParallelPortCollection
    Defines the collection of parallel ports within the VM.

    Beispielskonfiguration aus der .vmc Datei:

    <parallel_port>
    <port_shared type="boolean">false</port_shared>
    <port_type type="integer">0</port_type>
    </parallel_port>
    <parallel_port id="0">
    <port_name type="string">LPT1 (378h-37Fh)</port_name>
    <port_type type="integer">1</port_type>
    </parallel_port>

    Ich habe es selber nicht ausprobiert. Könnte Dir aber evtl. weiterhelfen.

    Gruß,
    Andrei

    Donnerstag, 24. März 2011 12:23
    Moderator

Alle Antworten

  • Niemand? :-(
    Freitag, 18. März 2011 08:22
  • Der neue PC hat keinen Parallel-Port mehr auf dem Mainboard, also habe ich eine PCI-Karte mit Parallel-Port gekauft (Digitus DS-33010). Bloss auf meinem Virtual PC erscheint gar kein LPT1-Port, somit erkennt das CAD-Programm den Dongle nicht und ich kann es deshalb nicht starten.

    Meine Frage wäre nun, wie ich am Virtual PC den LPT1 hinzufügen bzw. einrichten kann?

    Hast Du im Geräte Manager keinen LPT Port zur Verfügung? Oder unbekannte Geräte? Die Integrationsfeatures hast Du installiert und aktiviert? Kontrollier doch auch das BIOS, evtl. ist dort etwas zu finden.

     

    Servus

    Winfried

    Samstag, 19. März 2011 10:42
  • VirtualPC unterstützt afaik nur COM Ports und keine LPT Ports.

    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Samstag, 19. März 2011 13:06
  •  

    Hallo,

    in einem Fall mit Maschinensteuerungs Software hatte ich ähnliche Probleme.

    Vom Hersteller erhielt ich auf Nachfrage einen USB-Dongle. Dieser behob das Problem mehr schlecht wie recht. Spater dann eine Softwarelösung und bin seither zufrieden. Sollte der Hersteller für das CAD System keine Lösung anbieten, gibt es professionelle Dienste die dies Legal anbieten.

    Grüße
    Helmut

    Sonntag, 20. März 2011 07:25
  • Hallo,

    soweit ich das mitbekommen habe, wurde die Option nur aus der GUI entfernt. Per COM API ist diese weiterhin verfügbar und in der .vmc Datei gibt es auch konfigurierbare Einträge.

    Windows Virtual PC COM API:

    http://msdn.microsoft.com/en-us/library/dd796756(VS.85).aspx

    IVMParallelPort
    Defines a parallel port inside a VM.

    IVMParallelPortCollection
    Defines the collection of parallel ports within the VM.

    Beispielskonfiguration aus der .vmc Datei:

    <parallel_port>
    <port_shared type="boolean">false</port_shared>
    <port_type type="integer">0</port_type>
    </parallel_port>
    <parallel_port id="0">
    <port_name type="string">LPT1 (378h-37Fh)</port_name>
    <port_type type="integer">1</port_type>
    </parallel_port>

    Ich habe es selber nicht ausprobiert. Könnte Dir aber evtl. weiterhelfen.

    Gruß,
    Andrei

    Donnerstag, 24. März 2011 12:23
    Moderator
  • http://msdn.microsoft.com/en-us/library/dd796756(VS.85).aspx

    IVMParallelPort
    Defines a parallel port inside a VM.

    IVMParallelPortCollection
    Defines the collection of parallel ports within the VM.

    Beispielskonfiguration aus der .vmc Datei:

    <parallel_port>
    <port_shared type="boolean">false</port_shared>
    <port_type type="integer">0</port_type>
    </parallel_port>
    <parallel_port id="0">
    <port_name type="string">LPT1 (378h-37Fh)</port_name>
    <port_type type="integer">1</port_type>
    </parallel_port>

    Das ist mir entgangen. Ich hab bloß kein Parallelport auf dem Mainboard mehr, deshalb kann ich das nicht testen.

    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Donnerstag, 24. März 2011 12:48