none
MOSS2013: Berechtigungsstufe "Nur Anzeigen" RRS feed

  • Frage

  • Hallo,

    im SharePoint 2010 stand die Berechtigungsstufe "Nur Anzeigen" zur Verfügung. Damit konnten Benutzer so eingeschränkt werden, dass Dokumente nur im Browser angezeigt werden (WebApp). Das Herunterladen von Dokumenten war nicht möglich (Office Dokumente). Diese Berechtigungsstufe funktioniert auch im SharePoint 2013 mit der 2010er Oberfläche.

    In einer neuen SharePoint 2013 Webanwendung mit 2013er Oberfläche kann ich diese Berechtigungsstufe nun nicht mehr finden und kann diese auch nicht selber erstellen um diese Funktion wieder zu bekommen. Ist dies nicht mehr möglich? Wie kann ich Benutzer wieder so einschränken, dass Dokumente zwar angezeigt werden können (WebApp) aber das Herunterladen nicht möglich ist.

    Danke und Gruß

    Uwe

    • Typ geändert Alex Pitulice Dienstag, 5. November 2013 09:36 Warten auf Feedback
    • Typ geändert Alex Pitulice Dienstag, 12. November 2013 10:58 Noch Aktiv
    Montag, 28. Oktober 2013 09:41

Antworten

  • Hallo Alex,

    so, hat etwas gedauert, aber ich konnte über die PowerShell nun die Berechtigungsstufe "Nur Anzeigen" erzeugen. Ich habe dafür das Beispiel von  (http://gowrisharepoint.blogspot.ro/2013/01/create-custom-permission-levels-and.html) etwas angepasst:

    $siteUrl =  Read-Host "Enter Site Collection URL"
    $siteUrl = $siteUrl.Trim();
    $site=Get-SPSite $siteUrl
    $web=$site.RootWeb;
    write-host "Connected to the site successfully..."
    
    write-host "Creating custom permission level: Nur Anzeigen"
    $plRequestor=New-Object Microsoft.SharePoint.SPRoleDefinition
    $plRequestor.Name="Nur Anzeigen"
    $plRequestor.Description="Seiten, Listenelemente und Dokumente können angezeigt werden. Dokumenttypen mit serverseitigen Dateihandlern können im Browser angezeigt, jedoch nicht heruntergeladen werden."
    $plRequestor.BasePermissions="EmptyMask,
    ViewListItems,
    ViewVersions,
    ViewFormPages,
    Open,
    ViewPages,
    BrowseUserInfo,
    UseClientIntegration,
    UseRemoteAPIs,
    CreateAlerts,
    EditMyUserInfo"
    $web.RoleDefinitions.Add($plRequestor);
    write-host "Done"

    Anschließend habe ich auf der entsprechenden Bibliothek die Berechtigungsvererbung ausgeschaltet und der betroffenen SharePoint Gruppe die neue Berechtigungsstufe zugewiesen.

    Die ersten Tests waren erfolgreich. Die Option "Kopie herunterladen" ist deaktiviert, Dokumente werden nur in den WepApps lesend geöffnet und selbst das Kopieren von Text in den WebApps ist deaktiviert.

    Danke und Gruß

    Uwe

    • Als Antwort markiert Alex Pitulice Dienstag, 12. November 2013 10:58
    Dienstag, 12. November 2013 09:25

Alle Antworten