none
Windows Server 2016 - Get-VMHostSupportedVersion - keine Gast VM Version 8 verfügbar RRS feed

  • Frage

  • Hallo,

    ich habe das Problem, dass ich auf einem Windows Server 2016 Cluster kein "nested virtualization" aktivieren kann, da er bei dem Befehl: "Set-VMProcessor -VMName "VM1" -ExposeVirtualizationExtensions $true" die Meldung bringt; benötigt für die "VM1" Konfigurationsversion 8.0. Ein "Get-VMHostSupportedVersion" Befehl gibt max. Version 7.1 aus.

    ClusterFunctionalLevel ist "9"

    Beide Knoten wurden von Windows Server 2012 R2 auf Windows Server 2016 TP5 aktualisiert. Wochen später wurde die Windows Server 2016 TP5 Version auf die Windows Server 2016 aktualisiert. Aktuelle Version 1607 (Build 14393.729).

    Ausgabe: Get-VMHostSupportedVersion

    Name                                                                                    Version IsDefault
    ----                                                                                       ------- ---------
    Microsoft Windows 8.1/Server 2012 R2                                    5.0     False
    Microsoft Windows 10 1507/Server 2016 Technical Preview 3    6.2     False
    Microsoft Windows 10 1511/Server 2016 Technical Preview 4    7.0     False
    Microsoft Windows Server 2016 Technical Preview 5                 7.1     True
    Vorabversion                                                                         254.0   False
    Experimentell                                                                        255.0   False

    Wie kann ich die Konfigurationsversion 8.0 auf beiden Cluster-Knoten installieren?

    Auf zwei weiteren Cluster-Knoten (nicht derselbe Cluster sondern ein separater mit 2 separaten Knoten) wurde von Windows Server 2012 R2 direkt auf die aktuelle Windows Server 2016 Version aktualisiert.

    Ausgabe: Get-VMHostSupportedVersion -> dort wird die Version 8.0 unter dem Punkt "Microsoft Windows 10 Anniversary Update/Server 2016" aufgeführt.

    Name                                                                                     Version IsDefault
    ----                                                                                        ------- ---------
    Microsoft Windows 8.1/Server 2012 R2                                     5.0     False
    Microsoft Windows 10 1507/Server 2016 Technical Preview 3     6.2     False
    Microsoft Windows 10 1511/Server 2016 Technical Preview 4     7.0     False
    Microsoft Windows Server 2016 Technical Preview 5                  7.1     False
    Microsoft Windows 10 Anniversary Update/Server 2016             8.0     True
    Vorabversion                                                                          254.0   False
    Experimentell                                                                         255.0   False

    Vorab vielen Dank für eure Unterstützung.

    Udo Heuschmann


    Udo Heuschmann

    Donnerstag, 16. Februar 2017 09:28

Antworten

  • Hallo,

    nach genauer Analyse konnte ich feststellen, dass das Update KB4010672 auf beiden Knoten nicht installiert wurde.

    Ich habe das Update KB4010672 auf einem Server noch mal installiert - erfolgreich.. Danach funktioniert alles:

    1.neue VMs werden direkt mit der Konfigurationsversion 8.0 angelegt

    2.alle weiteren VM können wie Carsten vorschlägt mit "Update-VMVersion <vmname>" auf die Version 8.0 aktualisiert werden

    3.Nachdem erneuten einspielen des Updates KB4010672 wird jetzt mit Get-VMHostSupportedVersion auch der Eintrag:

    Name                                                                              Version IsDefault
    ----                                                                                 ------- ---------
    Microsoft Windows 10 Anniversary Update/Server 2016       8.0     True

    angezeigt.

    Das selbe Verhalten konnte ich auf dem 2. Knoten durchführen.

    Vielen Dank an @Alle für eure Unterstützung!

    Gruß Udo


    Udo Heuschmann

    Freitag, 17. Februar 2017 12:15

Alle Antworten

  • Moin,

    was passiert denn, wenn Du gegen den problematischen Cluster

     Update-ClusterFunctionalLevel
    ausführst?


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Donnerstag, 16. Februar 2017 09:35
  • Hallo,

    der Befehl lässt sich ganz normal ausführen. Eine anschließende Abfrage mit Get-VMHostSupportedVersion zeigt jedoch keine Verbesserung.

    Evtl. noch eine weitere Idee?

    Danke und Gruß

    Udo Heuschmann


    Udo Heuschmann

    Donnerstag, 16. Februar 2017 11:30
  • Hallo Udo,

    neben dem Cluster muss die VM an sich auch angehoben werden, ich hätte mal was in die richtung versucht :

    Update-VMVersion <vmname>

    Schau mal ob du die Version damit hoch bekommst.

    Gruß
    Carsten


    http://www.ms-fabric.de/ Wenn Dir eine Forenantwort weiter geholfen hat dann markiere sie doch bitte als Antwort, dies hilft anderen bei der Lösung von Problemen! LG Carsten

    Donnerstag, 16. Februar 2017 13:41
  • Hallo,

    nach genauer Analyse konnte ich feststellen, dass das Update KB4010672 auf beiden Knoten nicht installiert wurde.

    Ich habe das Update KB4010672 auf einem Server noch mal installiert - erfolgreich.. Danach funktioniert alles:

    1.neue VMs werden direkt mit der Konfigurationsversion 8.0 angelegt

    2.alle weiteren VM können wie Carsten vorschlägt mit "Update-VMVersion <vmname>" auf die Version 8.0 aktualisiert werden

    3.Nachdem erneuten einspielen des Updates KB4010672 wird jetzt mit Get-VMHostSupportedVersion auch der Eintrag:

    Name                                                                              Version IsDefault
    ----                                                                                 ------- ---------
    Microsoft Windows 10 Anniversary Update/Server 2016       8.0     True

    angezeigt.

    Das selbe Verhalten konnte ich auf dem 2. Knoten durchführen.

    Vielen Dank an @Alle für eure Unterstützung!

    Gruß Udo


    Udo Heuschmann

    Freitag, 17. Februar 2017 12:15