none
Dokument verschieben über Sitecollection RRS feed

  • Frage

  • Hallo zusammen,
    ich bin dem Wahnsinn nahe.... :-)

    SP2010
    Ich bin auf zwei Sitecollection Siteadmin, aber nicht in der Lage ein Dokument aus einer Bibliothek in eine andere zu verschieben. Ich möchte also ein Dokument von Collection A, Bibliothek A in die Collection B, Bibliothek B verschieben. Wenn ich das mache, dann erhalte ich die Fehlermeldung: "Die Quelldatei oder vom Quelldatenträger kann nicht gelesen werden."
    Vorgehen: Wie von MS empfohlen öffne ich beide Bibliotheken in der Explorer-Ansicht und versuche anschließend das Dokument zu verschieben. Kopieren und löschen ist nicht möglich, weil ich dann eine neue Dokument-ID bekomme und die Links dann wertlos sind! Wenn man jetzt richtig gelesen hat: "Kopieren funktioniert problemlos...!"

    laut Microsoft muss das auch gehen: http://office.microsoft.com/de-de/sharepoint-server-help/kopieren-oder-verschieben-von-bibliotheksdateien-mit-offnen-im-windows-explorer-HA101811182.aspx 

    Danke, Grüße!

    Dienstag, 31. Mai 2011 11:27

Alle Antworten

  • Hallo,

    das Dokument-ID kann beim Kopieren nicht Site Collection übergreifend erhalten bleiben. Siehe Dauerhaftigkeit der Dokument-ID:

    http://msdn.microsoft.com/de-de/library/ee559302.aspx

    Gruß,
    Andrei


    Donnerstag, 2. Juni 2011 09:51
  • Hallo,

    Kopieren ist logisch. Sorry,aber ich will ja verschieben. Der obige Link erklärt es nicht wirklich. Wäre für eine Erläuterung dankbar!
    In diversen Blogs kann gelesen werden, dass diese Document-ID dem Dokument Farmweit eindeutig und Standortunabhängig zugeordnet ist und das Dokument in der Farm verschoben werden kann.

    Gruß,
    Erzengel06


    Freitag, 3. Juni 2011 08:05
  • Hallo,

    jetzt bin ich einen Schritt weiter. Jetzt kann ich verschieben, jedoch wird eine neue Document-ID generiert. Es scheint, als würde SP das Dokument kopieren und anschließend löschen. Hilft also auch nicht, da der Link damit kaputt ist.... Ideen?
    Eine Aussage zB "Auf meinem SP funktioniert das" wäre schon mal ein erster Ansatz.. :-)

    Gruß



    Freitag, 3. Juni 2011 09:32