none
Fehlermeldung: "Ein unbekannter Anmeldefehler ist aufgetreten" RRS feed

  • Frage

  • Hallo,

    viele User hatten Probleme, sich am Terminalserver anzumelden. Sie bekamen die Fehlermeldung "Ein unbekannter Anmeldefehler ist aufgetreten". Ein Neustart des Terminalservers und des Domänencontrollers (Windows Server 2008 R2) hat nichts gebracht. Der Fehler konnte erst behoben werden, als ich den Terminalserver von der Domäne abgemeldet und ihn dann wieder neu in die Domäne eingebunden habe.

    Meine Frage: wie konnte sowas passieren bzw. was könnte die Ursache sein? Wie kann ich das in Zukunft vermeiden?

    Freitag, 26. Oktober 2012 06:40

Antworten

  •  
    > Meine Frage: wie konnte sowas passieren bzw. was könnte die Ursache
    > sein? Wie kann ich das in Zukunft vermeiden?
     
    Hast Du das System- und Security Eventlog des TS und der DCs geprüft?
    "Nicht übereinstimmendes Computerkennwort des TS" würde mir spontan
    einfallen (defekter SChannel), ansonsten ist das mit der Beschreibung
    eher ein "Schuß ins Blaue"...
     
    mfg Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Freitag, 26. Oktober 2012 09:18
  •  
    > Wie kann ich einen defekten SChannel "reparieren"?
     
    Den würdest Du erst mal mit "nltest /sc_verify:<domainname>" überprüfen.
    Und "eigentlich" paßt das auch nicht wirklich zu Deiner Beschreibung, da
    dann eine andere Meldung kommen würde.
     
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Montag, 29. Oktober 2012 11:42
  •  
    > Fehler bei I_NetLogonControl: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN
     
    Daß der Server keine Domäne findet... Ok, bissle mehr Diagnose (alles
    vom TS aus):
     
    nslookup <domain> - liefert das die IP-Adressen aller DCs zurück? Und
    geht ein Ping auf alle (!) diese Adressen? (Um genau zu sein: Geht ein
    Portqry auf alle diese Adressen auf Port 88/UDP+TCP und 389/TCP?)
    netdom query dc - was kommt raus? Sollte die gleiche Liste sein wie beim
    nslookup.
    In einer Admin-Commandline: wmic computersystem get domain,domainrole -
    was kommt da raus? domain sollte natürlich Deine Domäne sein, Domainrole
    wäre 3 (Member Server)...
     
    mfg Martin
     
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Donnerstag, 1. November 2012 08:19
  • nslookup -> zeigt die korrekte IP des DC an
    ping -> funktioniert einwandfrei
    portqry -> listening
    netdom query dc -> zeigt den richtigen DC an (wie nslookup)
    wmic computersystem get domain -> zeigt den richtigen DC an
    wmic computersystem get domainrole -> 3

    Sieht so aus, dass alles einwandfrei funktioniert. Dann hatte der DC wohl anscheinend einen kurzen Aussetzer gehabt.

    ---------------------------------------------

    edit: Ich glaube, wir können den Thread schließen. Der DC hatte wohl einen kurzen Aussetzer gehabt.

    Ich hatte den Befehl "nltest /sc_verify:<domain>" auf dem DC ausgeführt. Das hatte zu dieser Fehlermeldung geführt. Diesmal habe ich diesen Befehl auf dem Terminalserver ausgeführt und da kam folgende Meldung:

    Kennzeichen: b0 HAS_IP  HAS_TIMESERV
    Vertrauenswürdiger Domänencontrollername \\<domain>
    Vertrauenswürdiger Verbindungsstatus für Domänencontroller Status = 0 0x0 NERR_Success
    Überprüfung der Vertrauenswürdigkeit Status = 0 0x0 NERR_Success
    Der Befehl wurde ausgeführt.


    • Bearbeitet -honeybee- Donnerstag, 1. November 2012 13:27
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Donnerstag, 1. November 2012 13:19

Alle Antworten

  •  
    > Meine Frage: wie konnte sowas passieren bzw. was könnte die Ursache
    > sein? Wie kann ich das in Zukunft vermeiden?
     
    Hast Du das System- und Security Eventlog des TS und der DCs geprüft?
    "Nicht übereinstimmendes Computerkennwort des TS" würde mir spontan
    einfallen (defekter SChannel), ansonsten ist das mit der Beschreibung
    eher ein "Schuß ins Blaue"...
     
    mfg Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Freitag, 26. Oktober 2012 09:18
  • Hallo,

    danke für die Antwort.

    Ja, ich habe schon die Ereignisprotokolle geprüft und konnte nichts passendes finden. Da waren nur ein paar Fehlerprotokolle wegen Drucker, aber damit hat es nichts zu tun.

    Wie kann ich einen defekten SChannel "reparieren"?

    Freitag, 26. Oktober 2012 16:38
  •  
    > Wie kann ich einen defekten SChannel "reparieren"?
     
    Den würdest Du erst mal mit "nltest /sc_verify:<domainname>" überprüfen.
    Und "eigentlich" paßt das auch nicht wirklich zu Deiner Beschreibung, da
    dann eine andere Meldung kommen würde.
     
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Montag, 29. Oktober 2012 11:42
  • Okay, werde den Befehl ausführen.
    Montag, 29. Oktober 2012 15:43
  • Habe den Befehl ausgeführt und bekam folgende Fehlermeldung:

    Fehler bei I_NetLogonControl: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN
    Der Domänenname wurde richtig eingegeben. Was besagt die Fehlermeldung?
    Donnerstag, 1. November 2012 07:46
  •  
    > Fehler bei I_NetLogonControl: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN
     
    Daß der Server keine Domäne findet... Ok, bissle mehr Diagnose (alles
    vom TS aus):
     
    nslookup <domain> - liefert das die IP-Adressen aller DCs zurück? Und
    geht ein Ping auf alle (!) diese Adressen? (Um genau zu sein: Geht ein
    Portqry auf alle diese Adressen auf Port 88/UDP+TCP und 389/TCP?)
    netdom query dc - was kommt raus? Sollte die gleiche Liste sein wie beim
    nslookup.
    In einer Admin-Commandline: wmic computersystem get domain,domainrole -
    was kommt da raus? domain sollte natürlich Deine Domäne sein, Domainrole
    wäre 3 (Member Server)...
     
    mfg Martin
     
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Donnerstag, 1. November 2012 08:19
  • nslookup -> zeigt die korrekte IP des DC an
    ping -> funktioniert einwandfrei
    portqry -> listening
    netdom query dc -> zeigt den richtigen DC an (wie nslookup)
    wmic computersystem get domain -> zeigt den richtigen DC an
    wmic computersystem get domainrole -> 3

    Sieht so aus, dass alles einwandfrei funktioniert. Dann hatte der DC wohl anscheinend einen kurzen Aussetzer gehabt.

    ---------------------------------------------

    edit: Ich glaube, wir können den Thread schließen. Der DC hatte wohl einen kurzen Aussetzer gehabt.

    Ich hatte den Befehl "nltest /sc_verify:<domain>" auf dem DC ausgeführt. Das hatte zu dieser Fehlermeldung geführt. Diesmal habe ich diesen Befehl auf dem Terminalserver ausgeführt und da kam folgende Meldung:

    Kennzeichen: b0 HAS_IP  HAS_TIMESERV
    Vertrauenswürdiger Domänencontrollername \\<domain>
    Vertrauenswürdiger Verbindungsstatus für Domänencontroller Status = 0 0x0 NERR_Success
    Überprüfung der Vertrauenswürdigkeit Status = 0 0x0 NERR_Success
    Der Befehl wurde ausgeführt.


    • Bearbeitet -honeybee- Donnerstag, 1. November 2012 13:27
    • Als Antwort markiert -honeybee- Donnerstag, 1. November 2012 13:28
    Donnerstag, 1. November 2012 13:19
  • Sollte das eigentliche Problem erneut auftreten, so erhöhe auf dem betroffenen Rechner das Debuglogging bzgl. "netlogon":

    Enabling debug logging for the Net Logon service
    http://support.microsoft.com/kb/109626

    und erstelle ein Network-Trace, während der Fehler reproduziert wird:

    Information about Network Monitor 3
    http://support.microsoft.com/kb/933741

    Analysiere dann sowohl den Network-Trace als auch das zugehörige "netlogon.log" nach weiteren Hinweisen bzgl. der eigentlichen Ursache und/oder teile uns das Ergebnis der Analyseschritte mit.

    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net

    Donnerstag, 1. November 2012 13:33