none
Physical % Complete not rolling up for Summary Task over Milestones

    Frage

  • I'v searched and this is not something I have seen an answer for. This specifically pertains to summary task over a list of milestones.

    This is MSP2007 Pro with Dec 2011 CU and SP3.

    I have a summary task called Key Milestones. Under it I have several zero duration milestone tasks. The physical % complete for the milestones is 100%. However I can't get the summary line to roll up those values. The summary line is still physical % complete equals 0%

    On tasks with resources and durations, the Physical % complete rolls up fine.

    Is there any way to get the roll-up to occur if the subtasks are zero duration milestones without work assigned?

    MSP2007 provides me with a total physical % complete for the entire project. Is it is accurate if it ignores milestone summaries?

    Dienstag, 18. September 2012 18:41

Antworten

  • Thanks guys, but in MSP2007 it does. Go to Tools > Options > Calculation and click EV Method. Set that to Physical % Complete. Add EV method to a task view and change each task to Phys % Complete.

    Then copy the entire column Physical % Complete and paste it back on itself. Viola.

    I can guess why people miss this, but take a look in your file and you will notice that my original question holds water. Maybe it is a process issue, not sure.


    I should mention, that you need to have a resource loaded schedule, the resources need a cost rate, the tasks must be baselined, and you need to have some Physical % complete values entered on the subtasks. You can't enter anything on the summary tasks manually. But I think you guys know that.

    Dienstag, 18. September 2012 20:46

Alle Antworten

  • Hi,

    I must have missed something,but I have never seen Physical % Complete roll up in any circumstance ???

    Greetings,

    Dienstag, 18. September 2012 20:09
    Moderator
  • Quized Again --
     
    To echo Jan�??s answer, Physical % Complete does not roll up to summary tasks for either regular tasks or milestones in any version of Microsoft Project.  So I cannot imagine how you can get it to roll up on regular tasks but not on milestone tasks.  It simply DOES NOT roll up to summary tasks at all.  Hope this helps.
     

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Dienstag, 18. September 2012 20:29
    Moderator
  • Thanks guys, but in MSP2007 it does. Go to Tools > Options > Calculation and click EV Method. Set that to Physical % Complete. Add EV method to a task view and change each task to Phys % Complete.

    Then copy the entire column Physical % Complete and paste it back on itself. Viola.

    I can guess why people miss this, but take a look in your file and you will notice that my original question holds water. Maybe it is a process issue, not sure.


    I should mention, that you need to have a resource loaded schedule, the resources need a cost rate, the tasks must be baselined, and you need to have some Physical % complete values entered on the subtasks. You can't enter anything on the summary tasks manually. But I think you guys know that.

    Dienstag, 18. September 2012 20:46
  • I determined that the Physical % Complete at the top schedule summary line is being calculated accurately in spite of skipping the summaries above the milestones. Still not sure why it can't roll-up physical percent complete for milestones, but I suspect it is tied to the EV Method; you can't have EV for a task without work and cost.
    Dienstag, 18. September 2012 22:14
  • Quized Again--

    As Jan and Dale has mentioned, I agree that the Physical % Complete does not roll up to summary tasks for either regular tasks or milestones in any version of Microsoft Project. Also if you copy the Physical % complete and paste on itself, it does not rollup the values.

    Try this workaround to see rollup values:

    1. In the Task view, add a column named Number1.

    2. Right-click on the header column Number1. Click on Customize Fields.

    3. Click on Rename button. In Rename field box, type a name say: Physical Percent Complete and click Ok

    3. In Custom fields dialog box, click on Formula button. Type the formula:  [Physical % complete]. Click Ok.

    4. Select Rollup radio button and select Average from the drop-down list. Click Ok.

    You can use the custom fields to see the values of Physical % complete in summary tasks now.

    I hope this workaround helps.


    Thanks and Regards, Roopkumar Kamat (MCITP)

    Montag, 24. September 2012 07:45
  • I'm with Quized.  Besides, if it's on the Internet, it must be true...

    http://azlav.umtblog.com/2011/09/27/rolling-up-physical-percent-complete/


    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky

    Dienstag, 25. September 2012 00:53
    Moderator
  • Sorry - didn't see the original question.  I'm pretty sure milestones won't roll up accurately - have you tried assigning $1 Fixed Cost to the milestone to see if that fixes it?

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky


    Dienstag, 25. September 2012 00:56
    Moderator
  • Haha, I am glad you chimed in because I was about to go find that post of yours and paste it here! Yes, if there is budget it will work. I calculated the % complete in Excel and it is accurate as rolled-up by the program. Thank you Andrew!
    Dienstag, 25. September 2012 23:05
  • There is a way to show this. Give each of your key milestones 1d duration then go into the properties of each and on the advanced tab select 'Mark task as Milestone'. The task will now look like a milestone in the gantt chart but will now roll up in the % complete column. If you want Work % complete to roll up just put 1% of a work type resource on each milestone. Sory doesn't seem to work on Physical % Complete no matter what I try..
    Montag, 12. November 2012 00:34
  • Great tip. That worked just fine. Saved my life.
    Donnerstag, 26. September 2013 22:42
  • I´ve got it working, pal. Maybe you need to first select all taks, open Task Information and select % physical complete. You also might need to go to Options > Advanced and select % physical complete in the EVM box.
    Donnerstag, 26. September 2013 22:45
  • Revive the ancient post to say....

    You can also just hit "Mark on Track" and it will update to the percentage of time that has passed.

    :)

    Donnerstag, 4. August 2016 16:50
  • I stumbled upon this old post, and this works well, the only problem is that [Physical % complete] will not show the "%" sign in the custom column, if it did, it would be absolutely perfect.

    Thank you

    Dienstag, 16. Januar 2018 15:08
  • GUZZLR,

    A number field will only support numerical values, no text. In order to show a % symbol, you need to use a custom text field.

    John

    Dienstag, 16. Januar 2018 18:06
  • Hello,

    This workaround was working well for me, but now has stopped?  I've checked the formula in the Number I used, and all is well. Any ideas?  Macro is enabled.

    Thanks

    Donnerstag, 15. März 2018 19:46
  • GUZZLR,

    There is a lot of content in this old thread. Exactly which "workaround" are you referring to and what do you mean by, "...it stopped"? Perhaps you should start a new thread and give us full details on what you have, (including which version of Project), and what you are trying to do.

    John

    Freitag, 16. März 2018 00:18
  • Thank you, thank you, thank you. I followed the steps and it worked.  Now its physical % of complete is rolling up at summary level.  
    Montag, 21. Mai 2018 15:41
  • Sorry Dale, 

    I had the same feeling at first, but in fact QuizzedAgain was right, Physical % complete DOES roll up to the summary task, if you carefully follow QuizzedAgain instructions. I tried it, and wonderfully discovered that Physical % complete rolled up. in my case Task EV method field was not filled correctly to Physical % complete. 

    Here are the steps :

    Go to Tools > Options > Calculation and click EV Method.

    Set that to Physical % Complete.

    Add EV method to a task view and change each task to Phys % Complete.

    Then enter Physical % Complete : the calculation works when you enter the PC field and not after. if you did it before, re-enter the %, otherwise it will not work.


    Didier Maignan | http://www.e-labor.fr

    Donnerstag, 5. Juli 2018 09:22