none
Search Date Splittint Error RRS feed

  • Frage

  • Hi Everyone,

    i have a weird problem here:

    I have a SharePoint Search Site where i can search and find results nicely. Now when i try to search for Created=<date> the day and month parameter get somehow mixed by the search engine.

    Following example: Browser is German and also the language setting is German (IE8). When i issue a search for Created=21.2.2011 (the german date format is Day.Month.Year) i get nothing returned. When i switch day and month to Created=2.21.2011 then it works. BUT the date is not a valid one in germany. It also doesn't work it the language setting is set to English.

    I tried it with a second client: Browser is Englisch and language setting is als German (IE8). There the date is split correctly and entered. Created=21.2.2011 returns the same result as the invalid date query above.

    In the logs i find some exceptions for the query not returning results.

    Has anybody any idea?

    Thanks,

    Oliver

    Dienstag, 5. April 2011 15:55

Antworten

  • Hallo Oliver,

    ich gehe davon aus, dass wir Deine Frage auch auf Deutsch behandeln können ;)

    SharePoint handelt das Datumsformat für seine Elemente nicht anhand der IE oder Betriebssystemseinstellungen, sondern durch die Regionalen Einstellungen auf WebSite Ebene.

    Site Actions - Site Settings - Regional Settings. Hier wird das Datumsformat festgelegt. Nach ändern des gewünschten Formats und einem Fullcrawl sollte das neue Datumsformat auch in den Suchergebnissen erkennbar sein.

    PS: OOB gibt es keine "Created" Verwaltete Eigenschaft in der Suche. Daher ist diese als dursuchbare Eigenschaft mittels Created="Datum" nicht einsetzbar. Die Ergebnisse die im o.g. Test angezeigt werden, kommen von der VollText Suche.

    Hoffe das hilft.

    Gruß,
    Andrei

    Mittwoch, 6. April 2011 09:50

Alle Antworten

  • Hallo Oliver,

    ich gehe davon aus, dass wir Deine Frage auch auf Deutsch behandeln können ;)

    SharePoint handelt das Datumsformat für seine Elemente nicht anhand der IE oder Betriebssystemseinstellungen, sondern durch die Regionalen Einstellungen auf WebSite Ebene.

    Site Actions - Site Settings - Regional Settings. Hier wird das Datumsformat festgelegt. Nach ändern des gewünschten Formats und einem Fullcrawl sollte das neue Datumsformat auch in den Suchergebnissen erkennbar sein.

    PS: OOB gibt es keine "Created" Verwaltete Eigenschaft in der Suche. Daher ist diese als dursuchbare Eigenschaft mittels Created="Datum" nicht einsetzbar. Die Ergebnisse die im o.g. Test angezeigt werden, kommen von der VollText Suche.

    Hoffe das hilft.

    Gruß,
    Andrei

    Mittwoch, 6. April 2011 09:50
  • Hallo Andrei,

    danke für deine Antwort. Die Regionalen Einstellungen habe ich bereits geprüft:

    Gebietsschema: Deutsch

    Sortierreihenfolge: Allgemein

    Zeitzone: UTC +01:00 Amsterdam....

    Kalender: Gregorianisch

    Arbeitswoche: Erster Tag: Montag, ...

    Zeitformat: 24 Stunden

    Ich wüsste nicht was da falsch sein könne, dass das Datum falsch erkannt wird. Interessanterweise funktioniert es ja auch einem englischen System mit englischem Browser.

    Hast du noch eine Idee?

    Donnerstag, 21. April 2011 06:49