none
Office 2016 Std Deployment RRS feed

  • Frage

  • Hallo,

    ich möchte Office 2016 deployen, wir haben sowohl Prof. Plus Lizenzen im Einsatz, als auch Standard.

    Das Office Deployment Tool kann ich nutzen um eine MSP Datei zu erstellen und das ProfPlus damit ausrollen, das wird aber bei Standard nicht unterstützt.

    Bei dem erstellen eines Config XML-Files tue ich mich schwer, bsp.

    <Configuration>
    <Add SourcePath=f:\ OfficeClientEdition="32" Channel="Deferred" >
        <Product ID=“STANDARD“ PIDKEY=“XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX“>
          <Language ID="de-de" />
        </Product>
          </Add>  
      <Updates Enabled="TRUE" /> 
      <Display Level="Full" AcceptEULA="TRUE" />  
      <Logging Level="Standard" Path="%temp%" /> 
    </Configuration>

    Anforderung ist, Office 2016 soll installiert werden, inkl. EULA akzeptieren, dem richtigen Key fürs Aktivieren (XXXX sind natürlich nur Beispiele für den richtigen Key).

    Display Level ist momentan zur Überprüfung auf "Full"

    Aufruf lautet also: setup.exe /config config.xml

    Das Sahnehäubchen wäre das vorherige Deinstallieren der alten Version. (geht glaube ich mit rem und dann der ProductID der Installation Vorgänger Version, aber ersteinmal wäre der Install schön)

    Fehlermeldung lautet

    Setup can't find or validate an installation file. Please try reinstalling Office from your installation source, or if you installed from a download package, please re-download and reinstall. If you continue to have problems, please contact Microsoft or your system administrator.

    Die Installation manuell mit Durchklicken geht, also sind die Installationfiles nicht korrupt. 

    Kann mir hier jemand weiterhelfen.

    Danke im Voraus.

    Montag, 13. März 2017 07:57

Alle Antworten

  • Hallo,

    liegen direkt unter f:\ die Installationsressourcen?

    Wie es aussehen könnte:

      <Add SourcePath="\\fileserver\install$\Office 2016 Deployment Tool\Office-de" OfficeClientEdition="64" Channel="Current">


    Freundliche Grüße

    Sandro
    MCSA: Windows Server 2012
    Fachinformatiker Fachrichtung Systemintegration (IHK, 07/2013)


    Montag, 13. März 2017 08:16
  • Das Iso ist in Laufwerk F:\ gemountet die Setup.exe liegt also direkt in F:\setup.exe

    mit einem Netzwerkshare habe ich es auch probiert, jedoch ist dies mit der gleichen Meldung fehlgeschlagen. Die Client edition ist zwingend 32Bit, aufgrund von Addins.

    Montag, 13. März 2017 08:23
  • Was passiert wenn Du die Installationsfiles auf das lokale Dateisystem entpackt kopierst?

    Freundliche Grüße

    Sandro
    MCSA: Windows Server 2012
    Fachinformatiker Fachrichtung Systemintegration (IHK, 07/2013)


    Montag, 13. März 2017 08:25
  • Leider das gleiche. Egal ob ich die Daten auf C:\ , einem Netzwerkshare oder als Iso mounte und ausführe. Ergebnis bleibt das gleiche, weshalb ich die XML in Verdacht habe.
    Montag, 13. März 2017 09:31
  • Am 13.03.2017 schrieb S_Vo:

    Bei dem erstellen eines Config XML-Files tue ich mich schwer, bsp.

    <Configuration>
    <Add SourcePath=f:\ OfficeClientEdition="32" Channel="Deferred" >
        <Product ID=“STANDARD“ PIDKEY=“XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX“>
          <Language ID="de-de" />
        </Product>
          </Add>  
      <Updates Enabled="TRUE" /> 
      <Display Level="Full" AcceptEULA="TRUE" />  
      <Logging Level="Standard" Path="%temp%" /> 
    </Configuration>

    Lt. https://technet.microsoft.com/de-de/library/jj219426.aspx fehlen
    die Anführungsstriche beim Pfad.

    Hier übrigens genauso:
    https://technet.microsoft.com/de-de/library/jj219422.aspx

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    • Als Antwort vorgeschlagen SandroReiter Donnerstag, 16. März 2017 12:07
    Montag, 13. März 2017 17:32
  • fehlen die Anführungsstriche beim Pfad.

    Obwohl ich ein korrektes Beispiel gepostet habe, hab ich das gar nicht gesehen :D

    ... so wird's wohl funktionieren.


    Freundliche Grüße

    Sandro
    MCSA: Windows Server 2012
    Fachinformatiker Fachrichtung Systemintegration (IHK, 07/2013)


    Montag, 13. März 2017 17:59
  • Am 13.03.2017 schrieb SandroReiter:

    fehlen die Anführungsstriche beim Pfad.

    Obwohl ich ein korrektes Beispiel gepostet habe, hab ich das gar nicht gesehen :D

    ... so wird's wohl funktionieren.

    Wir werden sehen was vom TO noch kommt. ;)

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    Montag, 13. März 2017 19:21
  • Danke für die Antworten.

    So funktioniert es bei mir. Probleme bereitet mir noch der Key und das aktivieren. (kein KMS)

    <Configuration>

      <Add OfficeClientEdition="32">
        <Product ID="O365ProPlusRetail" PIDKEY="XXXXXXXXXXXXXXXX">
          <Language ID="de-de" />
          <ExcludeApp ID="Access" />
          </Product>
      </Add>

      <Updates Enabled="True" />

      <Display Level="None" AcceptEULA="True" />

      <Property Name="AutoActivate" Value="1" />
      <Property Name="ForceAppShutdown" Value="True" />
      <Property Name="Setup_Reboot" Value="Never" />
      
    </Configuration>

    Dienstag, 21. März 2017 08:35