none
Empfängerconnectors funktionieren Intern auf einmal nicht mehr RRS feed

  • Frage

  • Hi,

    wir nutzen hier ein Exchange 2010 Enterprise mit SP2, seit ein paar Tagen funktionieren die Internen Empfangsconnectoren für ein paar Programme nicht mehr.

    Der Empfangsconnector von der Firewall/Mailforwarder läuft jedoch ohne Probleme, kann das irgendwie mit dem SP2 zusammen hängen?

    Die Connectoren waren immer auf Anonym eingestellt und sind es immernoch, jedoch bekomm ich mit den Programm keine Mails mehr an den Exchange.

    In der Warteschlange steht auch nichts und im Protokoll kann ich auch nichts finden.

    Danke und Gruß

    • Typ geändert Alex Pitulice Dienstag, 24. Januar 2012 08:58 Warten auf Feedback
    • Typ geändert Alex Pitulice Donnerstag, 23. Februar 2012 12:35 Noch aktiv
    Dienstag, 17. Januar 2012 13:45

Antworten

  • Hi,

    ich hab das Problem gefunden....

    Es hat was mit der DNS Einstellung an dem Server zu tun, also der der sich nicht Connecten wollte.

    Nach dem ich im CMD "ipconfig /flushdns" gemacht habe, lief es sofort... da muss wohl irgendwas passiert sein.

    DAAAAANKE EUCH TROTZDEM :)

    • Als Antwort markiert Alex Pitulice Donnerstag, 23. Februar 2012 12:35
    Donnerstag, 23. Februar 2012 07:44

Alle Antworten

  • Hi newcomer_de,

    aktivier das SMTP-Logging am Connector und prüf das Log-File.

    Es muss ja einen Grund geben, weshalb die Mail nicht angenommen werden.


    Viele Grüße
    Christian

    Dienstag, 17. Januar 2012 14:27
    Moderator
  • Hi Christian,

    du meinst sicherlich diese Logs, richtig?

    C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Logs\ProtocolLog\SmtpReceive

    Danke und Gruß

    Dienstag, 17. Januar 2012 14:30
  • Moin,

    und im Protokoll kann ich auch nichts finden.

    das kann ich mir kaum vorstellen, weil es bedeuten würde, dass die Mail gar nicht bei Exchange landet.

    Im SMTP-Receive-Log muss was stehen, wenn es aktiv ist und die Mails da ankommen.

    Ansonsten poste/prüfe mal:

    Get-ReceiveConnector | fl


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Dienstag, 17. Januar 2012 14:34
  • Hi,

    ja, die sind gemeint. Hast du Updates?


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Dienstag, 17. Januar 2012 17:25
    Moderator
  • Hallo newcomer_de,

    Nehme doch mal Testweise eine weitere IP mit in den Empfangsconnector auf und versuche dann von dieser eine E-Mail per Telnet abzusetzen. Dort soltest du ja aufjedenfall einen Fehler bekommen, welcher dir sagt, warum das nicht klappt.

    http://www.msxfaq.de/internet/smtptelnet.htm

    --
    Gruß Malte Schoch
    www.msblog.eu

    Mittwoch, 18. Januar 2012 06:13
  • Das komische ist, ich habe die Programme alle auf einen Server 2008 geschoben und für die dann die Connectoren freigeschaltet und es läuft.

    Packe ich die zurück auf nen Server 2003 bekomme ich die Mail einfach nicht raus!

    Mit telnet komme ich von den 2003er drauf und es klappt!!!

    Mittwoch, 18. Januar 2012 08:14
  • Ich sehe gerade, ich habe immer die Login Daten vom Administrator angegeben und es hat immer funktioniert!!

    Nun nicht mehr!!! Nehme ich meine persönlichen Login-Daten klappt es... WTF??!?!

    Sicherheitsupdate?

    Ich sehe gerade auf einem Server 2003 sagt er mir bei Telnet immer bei "mail from:xxx" "501 5.5.4 Unrecognized Parameter" egal welchen Username ich angebe!

    Mittwoch, 18. Januar 2012 08:25
  • Hallo newcomer_de,

    hast du nicht gesagt, du hast auf dem Connector Anonym freigeschaltet? Warum gibst du dann einen Benutzer an? Probiere es mal ohne.

    Hat der Administrator ein Postfach? Wenn nein, kann es sein, dass nur Exchange  Benutzer freigeschaltet sind?

    Poste bitte mal:

    Get-ReceiveConnector -Identity "Name des Connectors" | fl

    --
    Gruß Malte Schoch
    www.msblog.eu

    Mittwoch, 18. Januar 2012 09:36
  • [PS] C:\Windows\system32>Get-ReceiveConnector -Identity "Habel" | fl


    RunspaceId                                      : 18849f07-bdb8-46a4-a9ef-4487ba7dd4f1
    AuthMechanism                                : Tls, Integrated, BasicAuth, ExchangeServer
    Banner                                             :
    BinaryMimeEnabled                          : True
    Bindings                                           : {192.168.77.4:25}
    ChunkingEnabled                             : True
    DefaultDomain                                 :
    DeliveryStatusNotificationEnabled   : True
    EightBitMimeEnabled                       : True
    BareLinefeedRejectionEnabled        : False
    DomainSecureEnabled                     : False
    EnhancedStatusCodesEnabled       : True
    LongAddressesEnabled                  : False
    OrarEnabled                                   : False
    SuppressXAnonymousTls                : False
    AdvertiseClientSettings                  : False
    Fqdn                                               : EXCHANGE01.XXXX
    Comment                                        :
    Enabled                                          : True
    ConnectionTimeout                        : 00:10:00
    ConnectionInactivityTimeout          : 00:05:00
    MessageRateLimit                          : unlimited
    MessageRateSource                      : IPAddress
    MaxInboundConnection                 : 5000
    MaxInboundConnectionPerSource : 20
    MaxInboundConnectionPercentagePerSource : 2
    MaxHeaderSize                              : 64 KB (65,536 bytes)
    MaxHopCount                                : 60
    MaxLocalHopCount                        : 8
    MaxLogonFailures                          : 3
    MaxMessageSize                           : 10 MB (10,485,760 bytes)
    MaxProtocolErrors                         : 5
    MaxRecipientsPerMessage            : 200
    PermissionGroups                         : AnonymousUsers, ExchangeUsers, ExchangeServers, ExchangeLegacyServers, Partners
    PipeliningEnabled                         : True
    ProtocolLoggingLevel                    : Verbose
    RemoteIPRanges                          : {192.168.77.192, 192.168.77.130, 192.168.77.5}
    RequireEHLODomain                       : False
    RequireTLS                              : False
    EnableAuthGSSAPI                        : False
    ExtendedProtectionPolicy                : None
    LiveCredentialEnabled                   : False
    TlsDomainCapabilities                   : {}
    Server                                          : EXCHANGE01
    SizeEnabled                                 : Enabled
    TarpitInterval                              : 00:00:05
    MaxAcknowledgementDelay         : 00:00:30
    AdminDisplayName                        :
    ExchangeVersion                         : 0.1 (8.0.535.0)
    Name                                    : Habel
    Identity                                : EXCHANGE01\Habel
    Guid                                    : 9e192334-ec17-4806-9994-509f13fb47bc
    ObjectCategory                          : XXXX/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
    ObjectClass                             : {top, msExchSmtpReceiveConnector}
    WhenChanged                             : 18.01.2012 10:55:09
    WhenCreated                             : 16.05.2011 09:41:19
    WhenChangedUTC                          : 18.01.2012 09:55:09
    WhenCreatedUTC                          : 16.05.2011 07:41:19
    OrganizationId                          :
    OriginatingServer                       : dc01.XXXX
    IsValid                                 : True


    @Malte: ja der Admin hat auch ein Account. Ich hab damals nur die Connectoren eingerichtet und meine Kollegen halt die Programme die das benötigen, wie ich sehe is zum Teil der Admin Account verwendet worden und zum Teil halt Anonym... klappte halt beides.

    Nun hat sich die Dame aus der Buchhaltung beschwert, das Dakota (Schnittstelle für Krankenkassen) nicht funktioniert... die Übermittlung per eMail wird abgebrochen. Wie ich sehe hat sie das Anonym gemacht, nun hab ich es mal mit dem Admin porbiert... geht nicht, mit meiner eigenen Kennung aber schon.

    • Bearbeitet newcomer_de Mittwoch, 18. Januar 2012 10:12
    Mittwoch, 18. Januar 2012 10:09
  • Hallo newcomer_de,

    wir haben auch einen Kunden welche "Dakota" einsetzen. Ich habe dort damals auch den Exchange entsprechend konfiguriert und erst als ich den Connector auf Anonym freigeschaltet habe und in dem Programm keine Authentifizierung mitgegeben werden musste hat es geklappt.

    Lege den Connector doch einmal frisch an und schaue was passiert. So sehen die Einstellungen gut aus.

    --
    Gruß Malte Schoch
    www.msblog.eu

    Mittwoch, 18. Januar 2012 10:30
  • Hi newcomer_de,

    bist du hier schon weiter gekommen?


    Viele Grüße
    Christian

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer"; if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Donnerstag, 19. Januar 2012 08:18
    Moderator
  • Hi,

    ich hab das Problem gefunden....

    Es hat was mit der DNS Einstellung an dem Server zu tun, also der der sich nicht Connecten wollte.

    Nach dem ich im CMD "ipconfig /flushdns" gemacht habe, lief es sofort... da muss wohl irgendwas passiert sein.

    DAAAAANKE EUCH TROTZDEM :)

    • Als Antwort markiert Alex Pitulice Donnerstag, 23. Februar 2012 12:35
    Donnerstag, 23. Februar 2012 07:44