none
Outlook 2010 & Exchange 2010 Zertifikat Problem RRS feed

  • Frage

  • Hy,

    ich habe mir ein SSL-zertifakt gekauft für meinen Server.

    nun kann ich ohne zertifikatsmeldungen über meinem OWA auf meine E-Mails zugreifen.

    jedoch intern  nicht mehr... bekomm immer die zertifikats installationsmeldung vom externen zertifikat.

    Was muss ich einstellen, das er intern das interne Zertifikat übernimmt?

     

    danke für eure hilf

    gruß andy

     

    Dienstag, 14. Dezember 2010 17:37

Antworten

  • Hi Andy,

    bitte den Fehler etwas genauer beschreiben! Was genau moniert Outlook an dem Zertifikat? Wahrscheinlich wird es Autodiscover von Outlook sein. Ich tippe einfach mal, dass in den Exchange Komponenten eine andere URL hinterlegt ist, als Outlook erwartet. Arbeite mal diesen Technet Artikel ab: http://support.microsoft.com/kb/940726/de 

    Gruß

    Martin

    Dienstag, 14. Dezember 2010 19:35

Alle Antworten

  • hinzuzufügen habe ich folgendes:

     

    im IIS habe ich bei den Bindungen unter der 443 Bindung als Zertifikat das externe ausgewählt

    sonst wurde nichts verändert.

    Dienstag, 14. Dezember 2010 17:40
  • Hi asetzer,

    sonst wurde nichts verändert.

    vielleicht installierst du das Zertifikat noch im Exchange:
    http://help.godaddy.com/article/5863
    oder
    http://telnet25.wordpress.com/2010/01/07/assigning-ssl-certificate-for-owa-exchange-2010-part-2/

    Wie lautet denn die genaue Meldung und wo hast du das Zertifikat gekauft?
    Eine lokale CA reicht in den meisten Fällen, wenn man mit der OWA-Meldung von
    extern leben kann und die Clients intern eingerichtet werden:
    http://www.msxfaq.de/signcrypt/firmenca.htm

    Viele Grüße
    Christian

    Dienstag, 14. Dezember 2010 19:14
    Moderator
  • Hi Andy,

    bitte den Fehler etwas genauer beschreiben! Was genau moniert Outlook an dem Zertifikat? Wahrscheinlich wird es Autodiscover von Outlook sein. Ich tippe einfach mal, dass in den Exchange Komponenten eine andere URL hinterlegt ist, als Outlook erwartet. Arbeite mal diesen Technet Artikel ab: http://support.microsoft.com/kb/940726/de 

    Gruß

    Martin

    Dienstag, 14. Dezember 2010 19:35
  • ja da ist das zertifikat drin, sonst würde ich ja über den OWA nicht reinkommen ohne zertifikat.

     

    Die Meldung vom Outlook lautet:

    servername.domäne

     

    Informationen die Sie mit dieser Website austauschen, können von anderen nicht angezeigt oder geändert werden.

    Es besteht jedoch ein problem mit dem Sicherheitszertifikat der Website..

    ...

     

    Möchten sie den Vorgang fortsetzen?

    Ja / Nein / Zertifikat anzeigen

     

     

    Wenn ich auf anzeigen klicke, kommt das domain.de Zertifkaten (externes)

    aber er soll ja über das interne kommunizieren... wie stell ich das ein?

     

    Bekomm immer ein Synchronisationsfehler gemeldet, wenn ich eine E-Mail lösche.

    Dienstag, 14. Dezember 2010 19:41
  • Ok, nochmal... ich stelle die Frage zum 2ten Mal. Was genau stimmt an dem Zertifikat nicht bzw. worüber meckert Outlook!? Den Link hast du dir sicher auch noch nicht angeuckt,oder? 

    Was sagt denn: Get-ClientAccessServer -Identitiy <dein CAS> | fl

    DANKE!

    Martin

    Dienstag, 14. Dezember 2010 19:57
  • in deiner Anleitung wird von einer URL für den AutoErmittlungsdienst gesprochen.. wo finde ich diese?

    stellt euch vor mein balkon, es fliegen server...

    Dienstag, 14. Dezember 2010 20:11
  • Exchange Management Shell starten

    Get-ClientAccessServer -Identitiy <dein CAS> | fl (das gibst du hier in der Shell ein)

    DIE AUSGABE HIER POSTEN! Danke!

    Dienstag, 14. Dezember 2010 20:17
  • mein CAS ist ? client access server? wie wird der lauten?

     

    das hinter der Befehlszeile soll "|FL" heißen ?

     

    ps: ich geh jetzt schlafen, ich versuchs morgen früh um 6uhr nochmal -

    hab die letzte nacht nicht geschlafen bezüglich der kiste....

    Dienstag, 14. Dezember 2010 20:36
  • Also Andy... ich will mal hoffen die Fragen waren ernst gemeint...so langsam komme ich mir wirklich verarscht vor ;-)

    mein CAS ist ? client access server? wie wird der lauten?

    Richtig! Frage nicht mich, frag dich das selber. Kleine Hilfe meinerseits. CMD starten und dort folgendes eingeben: hostname (Sofern nur ein Exchange Server in der Orga. vorhanden!)

    das hinter der Befehlszeile soll "|FL" heißen ?

    Richtig! Wobei das "|fl" zum Befehl mitgehört! ist ein Alias für Format-List, um es auch für dich bisschen verständlicher zu umschreiben. Wichtig ist dann letztendlich was hinter : " AutodiscoverServiceInternalUri" als Wert eingetragen ist.

    Du kannst auch direkt den Wert abfragen, falls dir FL zu viel output ist:

    Get-ClientAccessServer -Identity <dein CAS> | ft A utodiscoverServiceInternalUri

    > ps: ich geh jetzt schlafen, ich versuchs morgen früh um 6uhr nochmal - hab die letzte nacht nicht geschlafen bezüglich der kiste....

    Tu das bitte, vielleicht lässt du dir morgen besser helfen ;-). Gute Nacht!

    Dienstag, 14. Dezember 2010 20:55
  • Hi Andy,

    ps: ich geh jetzt schlafen, ich versuchs morgen früh um 6uhr nochmal -

    hab die letzte nacht nicht geschlafen bezüglich der kiste....

    ich hoffe, dass die ganze Diskussion aufgrund von Schlafmangel entstanden ist!
    ;)

    Es ist jetzt 7Uhr - bist du schon weiter und hast du deinen CAS gefunden?
    Wir wissen immer noch nicht:
    - wer der Zertifikatsdienstleister ist,
    - ob das neue Zertifikat hinterlegt ist (nur weil du auf OWA zugreifen kannst,
    heißt das nicht, dass das richtige installiert ist),
    - wie das Ergebnis von "get-ClientAccessServer -Identitiy <dein CAS> | fl"
    ist,
    - wie die genaue Meldung in Outlook zur "Installationsmeldung vom externen
    zertifikat" lautet, denn "servername.domäne" ist wenig aussagekräftig.

    Am besten schaust du dir mal die Seite msxfaq.de an oder nimmst dir ein gutes
    Buch, um die unbekannte Kiste etwas kennenzulernen.

    Einen guten Start in den Tag! ;)

    Christian

    Mittwoch, 15. Dezember 2010 06:15
    Moderator
  • Guten Morgen :( hab verschlafen... einfach zu viel zur Zeit.

    Das Zertifikat ist von Thawte DV und es wurden 3 Zertifikate installiert.
    Hauptzertifkat und 2 Nebenzertifikate.

    Hier die Ausgabe der Shell

    RunspaceId                           : 3d20576a-660c-41fd-adb3-6d230
    Name                                 : ASETZER-SERVER
    Fqdn                                 : asetzer-server.asetzer.local
    OutlookAnywhereEnabled               : True
    AutoDiscoverServiceCN                : asetzer-server
    AutoDiscoverServiceClassName         : ms-Exchange-AutoDiscover-Serv
    AutoDiscoverServiceInternalUri       : https://domain.de/autodiscov
    AutoDiscoverServiceGuid              : 77378f46-2c66-4aa9-a6a6-3e7a4
    AutoDiscoverSiteScope                : {Default-First-Site-Name}
    AlternateServiceAccountConfiguration :
    IsValid                              : True
    ExchangeVersion                      : 0.1 (8.0.535.0)
    DistinguishedName                    : CN=ASETZER-SERVER,CN=Servers,
                                           CN=Administrative Groups,CN=a
                                           ration,DC=asetzer,DC=local
    Identity                             : ASETZER-SERVER
    Guid                                 : eaae75e3-9868-477a-ba06-7e561
    ObjectCategory                       : asetzer.local/Configuration/S
    ObjectClass                          : {top, server, msExchExchangeS
    WhenChanged                          : 14.12.2010 20:37:56
    WhenCreated                          : 09.12.2010 20:40:54
    WhenChangedUTC                       : 14.12.2010 19:37:56
    WhenCreatedUTC                       : 09.12.2010 19:40:54
    OrganizationId                       :
    OriginatingServer                    : asetzer-server.asetzer.local

     

    grüße asetzer

     

    BEMERKUNG: https://DOMAIN.de/autodiscov -Großbuchstaben wurden von mir abgeändert.

    Mittwoch, 15. Dezember 2010 07:06
  • Na endlich. ;-)

    Wurde denn das Exchange Zertifikat auf domain.de ausgestellt? Prüfe mal bitte in der EMC unter Server Konfiguration, ob das richtige Exchange Zertifikat vorhanden ist.

    Beantworte bitte auch die restl. Fragen von Chrisitian. Insbesondere ist es immer noch interessant, was Outlook an den Zert. auszusetzen hat. Eher macht es keinen Sinn weiter zu machen.

    Gruß

    Martin

    Mittwoch, 15. Dezember 2010 08:18
  • ja das Zertifikat wurde auf https://domain.de ausgestellt...

    in der EMC sind 2 Zertifikate vorhanden...  "domain.de" und "Microsoft Exchange"

     

    Ist doch ganz klar was Outlook an dem Zertifikat auszusetzen hat...

    In Meinem Outlook MailPostfach steht als Exchange Server Adresse: asetzer-server.asetzer.local

    Deswegen erwartet Outlook das Zertifakt welches für diese Adresse ausgestellt ist.

    Jedoch bekommt es das Zertifikat von "domain.de" vom Exchange mitgeliefert.

     

    Um das Problem zu lösen muss folgendes Gewährleistet sein:

    Beim Externen Zugriff: CER domain.de

    Beim Internen Zugriff: CER Microsoft Exchange

     

    dann wär das Problem gelöst :) Oder ich würde auf Outlook Anywhere umsteigen. dann wärs auch gelöst.

    Mittwoch, 15. Dezember 2010 08:28
  • Das Rätsels Lösung wird wohl eher sein, das er kein SAN Zertifikat für die unterschiedlichen Namen (sowohl externe als auch interne) gekauft hat, sondern nur ein Zertifikat auf den externen Namen seiner Domain z.B.: mail.domain.tld.

     


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 08:43
  • So hier habe ich mal von 2150 Fehlerlogs die 2 häufigsten rauskopiert..

     

    Protokollname: System
    Quelle:        Microsoft-Windows-Security-Kerberos
    Datum:         15.12.2010 09:43:19
    Ereignis-ID:   3
    Aufgabenkategorie:Keine
    Ebene:         Fehler
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      asetzer-server.asetzer.local
    Beschreibung:
    Eine Kerberos-Fehlermeldung wurde auf
     Anmeldesitzung ASETZER\Administrator empfangen:
     Clientzeit:
     Serverzeit: 8:43:19.0000 12/15/2010 Z
     Fehlercode: 0x19 KDC_ERR_PREAUTH_REQUIRED
     Erweiterter Fehler:
     Clientbereich:
     Clientname:
     Serverbereich: ASETZER
     Servername: krbtgt/ASETZER
     Zielname: krbtgt/ASETZER@ASETZER
     Fehlertext:
     Datei: e
     Zeile: 98a
     Die Fehlerdaten stehen in den Berichtdaten.
    Ereignis-XML:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Security-Kerberos" Guid="{98E6CFCB-EE0A-41E0-A57B-622D4E1B30B1}" EventSourceName="Kerberos" />
        <EventID Qualifiers="32768">3</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-12-15T08:43:19.000Z" />
        <EventRecordID>101334</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>System</Channel>
        <Computer>asetzer-server.asetzer.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="LogonSession">ASETZER\Administrator</Data>
        <Data Name="ClientTime">
        </Data>
        <Data Name="ServerTime">8:43:19.0000 12/15/2010 Z</Data>
        <Data Name="ErrorCode">0x19</Data>
        <Data Name="ErrorMessage">KDC_ERR_PREAUTH_REQUIRED</Data>
        <Data Name="ExtendedError">
        </Data>
        <Data Name="ClientRealm">
        </Data>
        <Data Name="ClientName">
        </Data>
        <Data Name="ServerRealm">ASETZER</Data>
        <Data Name="ServerName">krbtgt/ASETZER</Data>
        <Data Name="TargetName">krbtgt/ASETZER@ASETZER</Data>
        <Data Name="ErrorText">
        </Data>
        <Data Name="File">e</Data>
        <Data Name="Line">98a</Data>
        <Binary>3081A5308181A103020113A27A047830763023A003020112A11C1B1A415345545A45522E4C4F43414C41646D696E6973747261746F723005A0030201173023A003020103A11C1B1A415345545A45522E4C4F43414C41646D696E6973747261746F723023A003020101A11C1B1A415345545A45522E4C4F43414C41646D696E6973747261746F723009A103020102A20204003009A103020110A20204003009A10302010FA2020400</Binary>
      </EventData>
    </Event>

     

     

     

     

     

    Protokollname: Application
    Quelle:        MSExchange RPC Over HTTP Autoconfig
    Datum:         15.12.2010 09:40:20
    Ereignis-ID:   2003
    Aufgabenkategorie:Allgemein
    Ebene:         Fehler
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      asetzer-server.asetzer.local
    Beschreibung:
    Die RPC-über-HTTP-Proxykomponente ist nicht installiert oder nicht ordnungsgemäß konfiguriert. Fügen Sie die RPC-über-HTTP-Proxykomponente den Netzwerkdiensten mithilfe des Assistenten für Windows-Komponenten hinzu.
    Ereignis-XML:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange RPC Over HTTP Autoconfig" />
        <EventID Qualifiers="49152">2003</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-12-15T08:40:20.000Z" />
        <EventRecordID>4159</EventRecordID>
        <Channel>Application</Channel>
        <Computer>asetzer-server.asetzer.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>
        </Data>
      </EventData>
    </Event>

    Mittwoch, 15. Dezember 2010 08:58
  • "ja das Zertifikat wurde auf https://domain.de ausgestellt...
    in der EMC sind 2 Zertifikate vorhanden...  "domain.de" und "Microsoft Exchange"

    Ist doch ganz klar was Outlook an dem Zertifikat auszusetzen hat...
    In Meinem Outlook MailPostfach steht als Exchange Server Adresse: asetzer-server.asetzer.local
    Deswegen erwartet Outlook das Zertifakt welches für diese Adresse ausgestellt ist.
    Jedoch bekommt es das Zertifikat von "domain.de" vom Exchange mitgeliefert."

    Und? War das jetzt so schwer rauszufinden? Gib dann bei Exchange Server die: domain.de Adresse ein. Wenn du DNS richtig konfiguriert hast, dann sollte es auch so funktionieren.

    "Um das Problem zu lösen muss folgendes Gewährleistet sein:
    Beim Externen Zugriff: CER domain.de
    Beim Internen Zugriff: CER Microsoft Exchange"

    Geht nicht!

    "dann wär das Problem gelöst :) Oder ich würde auf Outlook Anywhere umsteigen. dann wärs auch gelöst."

    Dann mach das doch!

     

    Mittwoch, 15. Dezember 2010 09:01
  • Prima,

     

    hast du denn eigentlich schon mal mit https://www.testexchangeconnectivity.com/

    deinen Server getestet? OWA ist ja das eine aber da gibt es ein klein wenig mehr. z.B.: Outlook Anywhere und ActiveSync...

    Kannst ja mal die verschiedenen Test durchlaufen lassen. Meist bekommst du dann eine ziemlich genaue Analyse was das Problem bei den einzelnen Tests ist.


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 09:04
  • okay, dann steig ich um auf outlook anywhere. https://www.testexchangeconnectivity.com/ findet beim Outllok Anywhere Test keinen Fehler.

    Das heißt Server seitig stimmt alles um Outllok Anyhwere zu nutzen,oder?

     

    Wenn ich im Outlook das Postfach bearbeiten möche, kann ich aber die Exchange Adresse asetzer-server.asetzer.local nicht mehr ändern.

    Postfach löschen und neues erstellen?

    Mittwoch, 15. Dezember 2010 09:26
  • Wenn du das bereits eingerichtet hast solltest du unter den Kontoinformationen die Möglichkeit haben weitere Konteneinstellungen zu setzen.

    Auf dem Reiter "Verbindung" sollte glaub ich in jeder Outlook Version so heißen, gibt es die Möglichkeit Exchange Proxy Einstellungen zu setzen. Das solltest du aktivieren und wenn du generell nur über Https darauf zugreifen möchtest solltest du sowohl für langsame als auch schnelle Netzwerke die Option setzen.

     

    edit: Wie sieht das denn mit deinem Zertifikat aus? Hast du nur eines für "mail.domain.tld" gekauft oder auch eines was autodiscover.domain.tld und auch sämtliche interne Namen abdeckt?


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 09:34
  • das Zertifikat deckt ab: https://domain.de/

     

    im MSXFAQ.de habe ich nachgelesen bezüglich der Konfiguration von Outlook. und in den Proxyeinstellungen sollte ich

    eintragen: https://rpcprox.DOMAIN.de - wenn ich diese adresse in der adressleiste eingebe, kommt die seite kann nicht angezeigt werden... schlecht oder?

     

    http://technet.microsoft.com/de-de/library/cc179036.aspx  muss ich diese Schritte abarbeiten, wenn ich möchte

    das jeder neue Client beim erst Start von Outlook automatisch die Outlook Anywhere Einstellungen übernimmt?

    Wenn ja, ...

     

    So konfigurieren Sie Outlook Anywhere mithilfe des OAT

    Navigieren Sie im OAT in der Strukturansicht zu Outlook , und klicken Sie dann auf Konten hinzufügen .

     

    Wo finde ich den OAT?

     

    Mittwoch, 15. Dezember 2010 09:48
  • hier: http://technet.microsoft.com/de-de/library/cc178992.aspx

    So, ich sehe Marcel kümmert sich weiter um dich. Dann mal frohes Schaffen...

    Mittwoch, 15. Dezember 2010 10:07
  • Die Dateien müssen also auf den Clients ersetzt werden? Habe ich das Richtig verstanden?

    Diese müsste ich dann über die GPO's verteilen,oder?

     

    Und ist das richtig, das ich in den Proxyeinstellungen https://rpcprox.DOMAIN.de eintragen muss? oder https://owa.DOMAIN.de ??
    hab beide Varianten gelesen...

    Hab soeben mit meinem Anbieter des Zertifikates telefoniert... owa.DOMAIN.de wird zum beispiel nicht abgedeckt.
    Also ein Single Zertifikat.

     

    Was würde ich nur dafür geben 2 Stunden neben einem experten zu sitzen und dem Fragen stellen zu können...

     

    Ich bin einer der sich EIGENTLICH einliest..  bevor er Änderungen vornimmt, wie jetzt Outlook Anywhere zu konfigurieren. Jedoch war das alles jetzt nicht möglich

    da alles so plötzlich passierte... sorry für die Unangenehmlichkeiten die ich hier vielleicht aufrufe!

    Mittwoch, 15. Dezember 2010 10:13
  • Von welchen Dateien sprechen wir denn jetzt und was willst du über die GPO's verteilen?

    nein, bei den Proxyeinstellungen trägst du in deinem Falle : mail.domain.de ein.

    Tja, für das nächste Mal weisst du ja was du dann ja was zu tun ist...
    Mal davon abgesehen... wenn du dich überall RICHTIG "einlesen" würdest, dann wären viele deiner Fragen beantwortet und du müsstest die nicht hier stellen. ;-)

     

    Mittwoch, 15. Dezember 2010 10:40
  • mail.domain.de ...

    ich habe aber keine subdomain.

     

    Mittwoch, 15. Dezember 2010 10:46
  • Wenn jeder neue Client seine Konfiguration automatisch übernehmen soll, solltest du einfach die wunderbare Autokonfiguration nutzen.

    Die bringt Exchange ab 2007 direkt mit. Dann muss eigentlich fast nur noch ein sauberes DNS konfiguriert werden (vorzugsweise mit einem Host Eintrag  im öffentlichen DNS "autodiscover.domain.tld" und ein SAN Zertifikat das alle Namen externe und interne abdeckt. Such mal bitte hier ein wenig im Forum, gibt schon einige Beiträge zum Thema Exchangezertifikate.


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 10:48
  • Wie ist denn dein Exchangeserver von extern erreichbar? Sicher über eine Ip Adresse.

    Und die wird doch im DNS sicher mit einem Namen im Stile "Namedesservers.domain.tld" aufgelöst.

    Die Proxyeinstellungen geben den Server an den du ansprichst der für dich die Anfragen an Exchange von Https umwandelt und an Exchange weiterleitet. Der Server muss ja irgendwie öffentlich erreichbar sein.


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 10:51
  • ja, darüber habe ichmich schon informiert... kostet mich 150€ im jahr.

    möcht ich nicht :)

     

    ich machs jetzt erstmal ohne zertifikat, was ja auch möglich ist.

    Was muss ich genau jetzt in den Proxyeinstellungen eintragen? https://domain.de/rpc ? /owa? oder was anderes?

    Mittwoch, 15. Dezember 2010 10:52
  • So wie es schon steht:

    im externen DNS wirst du für deinen Server einen Hosteintrag gesetzt haben um Ihn zum Beispiel Extern per RDP zu erreichen. Wenn du dann, wie auch immer ein Forwarding auf deinen RPC-Proxy Server eingerichtet hast sind wir schon auf dem richtigen Weg. Dann solltest du im Outlook nur noch eintragen müssen den Namen den dein Server im öffentlichen Namensraum hat. Sprich in die Felder sollte einfach

    Diese URL zum Verbinden mit dem Exchange-Proxyserver verwenden:  Hostname.domain.tld

    Hostname=a-record im öffentlichen DNS welcher hoffentlich bei deinem Provider in der Zone "domain" hinterlegt ist.

    Eventuell schaust du auch noch einmal bei der Suchmaschine deiner Wahl nach Ergebnissen zu FQDN und DNS.

     


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 11:06
  • im DNS server habe ich noch nichts verändert.

    hast mir ne anleitung, was ich dort genau zu verändern habe?

    Mittwoch, 15. Dezember 2010 11:23
  • Hast du eine feste öffentliche IP-Adresse?

    Ich denke schon.

    Du willst mir jetzt sagen du hast noch nicht einmal die DNS Zone bei deinem Provider angeschaut?

    Keine Host Records und keine MX Records gesetzt?


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 11:27
  • Ja habe eine feste öffentlich IP.

    Host Record und MX Record sind beim Provider gesetzt auf domain.de Prio:10

     

    Bitte erklär mir doch kurz was ich in meinem Server Manager am DNS Server vornehmen muss

    und was dann im als Proxyserver einzutragen ist, wäre dir sehr dankbar.

    proxyserver: https://domain.de kann ja nicht sein,oder?

     

    Muss den im Outlook bei der Exchange Server Adresse nicht meine domain rein? momentan steht drin: asetzer-server.asetzer.local demnach wird er ja auch über outlook anywhere das interne zertifikat installieren wollen,oder nicht?
    Mittwoch, 15. Dezember 2010 12:01
  • Hostest du intern deine .local und deine .de domain?

    Ich frage das nur weil du intern deine domain.de Zone bearbeiten möchtest...


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 13:16
  • Konfigurierst du dein System auch mal von extern? Falls ja wie sprichst du das System dann an?

    Über RDP oder VPN und dann RDP oder wie?

    Wenn du ein nslookup -type=mx auf deine öffentliche Emaildomain machst. Gibt es dort einen Eintrag für deinen Mailserver zurück?

    Ansonsten falls du über https://domain.de/owa deinen OWA aufrufen kannst und dein Zertifikat das abdeckt sollte beim Proxyserver domain.de als Eintrag reichen. Der Punkt etwas später in der Konfiguration ist da schon etwas wichtiger "Verbindung nur mit Proxyservern herstellen, deren Zertifikat den folgenden Prinzipalnamen enthalten: msstd:domain.de

    Dann noch den Zugriff über schnelle und langsame Verbindungen auf aktiv setzen und dann sollte wenn sowohl DNS als auch RPC Proxy und dein Zertifikat so stimmen wie du das geschrieben hast das ganze funktionieren.


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 13:37
  • ich konfigurier ihn von extern über remotedesktopverbindung.

     

    mein zertifikat deckt https://domain.de/owa ab.

    Habe nun domain.de als proxy eingetragen und msstd:domain.de ebenfalls.

    es kommt immernoch die zertifikaten meldung...

    hier ein screenshot...

    http://img59.imageshack.us/img59/7581/outlooka.jpg
    Mittwoch, 15. Dezember 2010 13:55
  • Der Thread scheint keine Ende zu nehmen. Also nochmal ein Hinweis von mir: http://support.microsoft.com/kb/940726/de 

    Bitte alle Punkte einmal überprüfen, so das wenigstens das als Fehlerquelle ausgeschlossen werden kann. Danke! Ich meine auch wirklich alles! Nicht nur die erste Zeile, sondern komplett lesen, verstehen und ans Werk gehen. Eher gibt es keine Hilfestellung mehr! Sowohl von mir, als auch von Marcel, Christian etc. ;-)

    Gruß

    Martin

    Mittwoch, 15. Dezember 2010 14:05
  • okay, alles klar werde ich tun. und mich dann nochmal melden

    Aber der Synchronisationsfehler hat damit ja nichts zu tun,oder?

    Mittwoch, 15. Dezember 2010 14:08
  • Wenn ich den Cache Modus ausschalte funktioniert es, das weiß ich... nur ist das die feine Lösung?
    Mittwoch, 15. Dezember 2010 14:45
  • lösche die alte OST-Datei und aktiviere den Cached Mode erneut. Ist der Fehler dann weg?

    Mittwoch, 15. Dezember 2010 14:52
  • Tatsache,

     

    ein ordentliches SAN Zertifikat und einmal ordentlich konfiguriert erspart dir und uns die gesamte Kommunikation hier.

    Hast du jetzt bei deinem Exchangekonto die Anbindung über HTTPS erzwungen?


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 15:27
  • wenn die 2 häkchen das erzwingen, ja...

     

    Im Outlook beides Haken aktiv:

    - Langsames Netzwerk...

    - Schnelles Netzwerk...

     

    Oder ist Serverseitigs das erzwingen auch noch nötig?

    Das ordentliche SAN Zetifikat hätte ich gerne... ja aber als privat man bisschen heftig 150€ im Jahr

    die .ost Datei kann ich nicht löschen

    Mittwoch, 15. Dezember 2010 15:40
  • Mach mal bitte auf dein Trayicon von Outlook mit gedrückter Steuerungstaste einen Linksklick. Und gehe dann auf Verbindungsstatus.

    Wenn dort irgendeine Serververbindung nicht auf https steht weisst du schon wieso die Zertifikatsfehlermeldung kommt.

    Wenn die beiden Haken aktiv sind, reicht das eigentlich.


    Marcel Brabetz
    Mittwoch, 15. Dezember 2010 15:47
  • überall steht HTTPS...
    ich meld mich wieder ich hab nen plan.
    Mittwoch, 15. Dezember 2010 16:21
  • wenn ich nach der Anleitung bezüglich der Sicherheitszertifikatenmeldung richte.... bekomme ich folgende Meldung in der Shell

     

    Eingetippt habe ich:


    [PS] C:\Windows\system32>set-clientaccessserver-Identity asetzer-server -autodiscoverserviceinternaluri https://DOMAIN.de/autodiscover/autodiscover.xml

     

    Als Fehlermledung bekommen habe ich:

    Die Benennung "set-clientaccessserver-Identity" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei od

    er eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofe

    rn enthalten), und wiederholen Sie den Vorgang.

    Bei Zeile:1 Zeichen:32

    + set-clientaccessserver-Identity <<<<  asetzer-server -autodiscoverserviceinternaluri https://DOMAIN.de/autodiscover/

    autodiscover.xml

        + CategoryInfo          : ObjectNotFound: (set-clientaccessserver-Identity:String) [], CommandNotFoundException

        + FullyQualifiedErrorId : CommandNotFoundException

     

    Mittwoch, 15. Dezember 2010 20:32
  • zu 99,99% bekommst du den fehler angezeigt, weil es das cmdlet nicht gibt. Wie in deinem fall. 

    Das cmdlet ist: Set-ClientAccessServer 

    Merk dir folgendes! Cmdlets bestehen aus einen Verb und einen Substantiv! Also zwei nicht drei Teilen! Identity ist nur der Parameter den du übergibst. Aber das hättest du auch selbst rausfinden können!!

    Mittwoch, 15. Dezember 2010 20:41
  • Guten Morgen,

    Schritt 1 hat funktioniert, ich habe es rauskopiert aus der Technet anleitung,

    jedoch geht es bei Schritt 2 grad weiter....

    SCHRITT 2:

     

    [PS] C:\Windows\system32>Set-WebServicesVirtualDirectory -Identity "asetzer-server\EWS" -InternalUrl https://DOMAIN.de
    ews/exchange.asmx
    Der Vorgang konnte nicht ausgeführt werden, weil das Objekt 'asetzer-server\EWS' nicht auf 'asetzer-server.asetzer.loca
    l' gefunden wurde.
        + CategoryInfo          : NotSpecified: (0:Int32) [Set-WebServicesVirtualDirectory], ManagementObjectNotFoundExcep
       tion
        + FullyQualifiedErrorId : 6CC4A40A,Microsoft.Exchange.Management.SystemConfigurationTasks.SetWebServicesVirtualDir
       ectory

    Donnerstag, 16. Dezember 2010 05:40
  • auch dieser Fehler tritt zu 99,99% auf, wenn das Objekt auch wirklich nicht existiert. Als Identity übergibst du in deinem Fall den Wert "asetzer-server\EWS (Standardwebsite)" So steht es auch in dem TechNet Artikel! Da hättest du ebenfalls selbst drauf kommen können! Ein Blick in den IIS hätte genügt... oder den Artikel aufmerksamer lesen...
    Donnerstag, 16. Dezember 2010 07:58
  • Hi Andy,

    was passiert, wenn morgen die Clients sich nicht mehr mit dem Exchange
    verbinden? Bitte such dir externe Unterstützung oder besuch zumindestens einen
    Exchange-Kurs, damit du den Server auch verwalten kannst.

    Das Forum dient der Unterstützung - es kann dir aber nicht alles abnehmen!
    Der Thread wird gerade rekordverdächtig lang, ohne dass es sich um ein
    riesiges Problem handelt...

    Resprekt an Martin und Marcel, dass sie noch mitlaufen!

    Viel Erfolg und Grüße Christian

    Donnerstag, 16. Dezember 2010 08:12
    Moderator
  • Meine Güte, ich rast gleich aus..

     

    [PS] C:\Windows\system32>Set-WebServicesVirtualDirectory -Identity "asetzer-server\EWS (Standardwebsite)" -InternalUrl https://DOMAIN.de/ews/exchange.asmx


    Der Vorgang konnte nicht ausgeführt werden, weil das Objekt 'asetzer-server\EWS (Standardwebsite)' nicht auf 'asetzer-s
    erver.asetzer.local' gefunden wurde.
        + CategoryInfo          : NotSpecified: (0:Int32) [Set-WebServicesVirtualDirectory], ManagementObjectNotFoundExcep
       tion
        + FullyQualifiedErrorId : 5D63649D,Microsoft.Exchange.Management.SystemConfigurationTasks.SetWebServicesVirtualDir
       ectory

    Donnerstag, 16. Dezember 2010 08:13
  • @Christian: Ich habe einfach die Hoffnung, das der Zertifikatsfehler mit dem Abarbeiten des Technet Artikels weg ist. Es geht zwar zäh voran, aber ich sehe ein fünkchen Licht am Horizont. Falls danach wieder was ist, dann klinke ich mich aus ;-)

    @Andy: Was sagt denn: Get-WebServicesVirtualDirectory | ft Name

    Donnerstag, 16. Dezember 2010 08:48
  • alle Schritte erfolgreich durchgeführt.
    Donnerstag, 16. Dezember 2010 09:00
  • Thanks god. Trommelwirbel...
    Donnerstag, 16. Dezember 2010 09:13
  • Herzlichen Glückwunsch,

     

    ein Glück das gestern noch Weihnachtsfeier war und ich erst jetzt wieder mal nen Blick rein werfe.

    Ich hoffe mal das wars jetzt.

     

    ps.: Die Benachrichtigung funktioniert auch nicht immer hundertprozentig oder?


    Marcel Brabetz
    Donnerstag, 16. Dezember 2010 09:16
  • Hi Marcel,

    ja die kommen wohl wieder etwas später - mal abwarten woran es dieses mal liegt ;)

    http://social.technet.microsoft.com/Forums/en-US/reportabug/thread/73f18a37-7dc6-4003-8b61-9aa17d6e2c1b

    Viele Grüße

    Christian

    Donnerstag, 16. Dezember 2010 09:53
    Moderator
  • ich danke euch vielmals !! es funktioniert...!

    Danke für die Geduld und Entschuldigung für die überstrapazierte Nerven.

     

    gruß asetzer

    Donnerstag, 16. Dezember 2010 15:52