none
DHCP / DNS (Workgroup) PTR Records werden angelegt, A Records nicht RRS feed

  • Frage

  • Moin zusammen,

    ich habe einen Windows 2019 Server installiert (Workgroup, also kein AD DS), der Server soll DHCP und DNS für Windows und Non-Windows Clients übernehmen. Vorgegangen bin ich anhand der folgenden Anleitung von Ace Fekay:

    https://blogs.msmvps.com/acefekay/tag/dns-in-a-workgroup/

    DHCP funktioniert und als DNS Suffix hat der Server "box" bekommen, dieser DNS Suffix wird auch per DHCP Option 015 verteilt.

    Die Geräte im Lab bekommen DHCP Leases und der DHCP Server trägt entsprechende PTR Records in die Reverse Lookup Zone ein. A Records werden allerdings nicht erzeugt.

    Meine Vermutung ist das es mit dem DNS Suffix "box" und der falschen Schreibweise an irgendwelchen Stellen zusammenhängt, ich weiß aber nicht wie ich das verifizieren kann.

    Kann mir jemand einen Tipp geben was ich diesbezüglich prüfen kann? Gibt es ein Logging des DHCP Servers für das Dynamic Update der DNS Records? Im EventLog selbst ist nichts auffälliges diesbezüglich zu sehen.

    Für jede Hilfe dankbar grüßt,

    Rolf

    Sonntag, 8. November 2020 23:13

Antworten

  • Ich vermute mal dass die Endung "box" nicht funktioniert, da diese Endung inzwischen offiziell ist und als Domain registriert sein muss.
    Das Problem mit dieser Endung habe ich auch mit meiner "Fritz.box", da die DNS-Auflösung ins Web eine ungültige IP-Adresse liefert, die als "nicht erreichbar" statt "unbekannt" gemeldet wird. Die Endung "Box" der Fritzbox ist auch nicht änderbar, da weigert sich AVM bereits seit Jahren.

    Eine Box-Endung muss als öffentliche Domain registriert sein sonst funktionierts nicht.

    Montag, 9. November 2020 07:09
  • Moin,

    single label Domains sind zwar theoretisch von Windows supported, aber sorgen sehr oft für irgendwelche Seiteneffekte. Kannst Du für Dein Lab einen ordentlichen, mindestens zweiteiligen Domainnamen setzen und schauen, ob es dann besser funktioniert?


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Montag, 9. November 2020 07:22

Alle Antworten

  • Ich vermute mal dass die Endung "box" nicht funktioniert, da diese Endung inzwischen offiziell ist und als Domain registriert sein muss.
    Das Problem mit dieser Endung habe ich auch mit meiner "Fritz.box", da die DNS-Auflösung ins Web eine ungültige IP-Adresse liefert, die als "nicht erreichbar" statt "unbekannt" gemeldet wird. Die Endung "Box" der Fritzbox ist auch nicht änderbar, da weigert sich AVM bereits seit Jahren.

    Eine Box-Endung muss als öffentliche Domain registriert sein sonst funktionierts nicht.

    Montag, 9. November 2020 07:09
  • Moin,

    single label Domains sind zwar theoretisch von Windows supported, aber sorgen sehr oft für irgendwelche Seiteneffekte. Kannst Du für Dein Lab einen ordentlichen, mindestens zweiteiligen Domainnamen setzen und schauen, ob es dann besser funktioniert?


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Montag, 9. November 2020 07:22
  • Vielen Dank zusammen!

    Nach dem ändern auf domainname.local funktioniert alles wie es soll.

    Dienstag, 10. November 2020 13:41