none
Autodiscover für mehrere Domains mit einem Zertifikat RRS feed

  • Frage

  • Hi zusammen

    Habe folgendes Problem mit dem Autodiscover:

    Ich habe folgende Domains, welche auf einem Server laufen:

    domainx.ch
    domainy.ch

    Ich habe mir ein Zertifikat gekauft, welche für domainx.ch registriert ist. Jedoch möchte ich, dass das Autodiscover auch auf domainy.ch richtig und möglichst ohne Meldungen funktioniert. Habe es mit einem SRV-Eintrag versucht, jedoch bin ich mir nicht ganz sicher ob das korrekt ist... Auf jeden Fall bringt er auf domainy.ch immer einen Fehler von autodiscover. Somit kann ich auch die Funktion "automatisch Antworten" und beim Einrichten von Outlook die Autodiscover Funktion nicht verwenden.

    Kann mir jmd. helfen? Danke!!!

    Freitag, 29. März 2013 17:56

Antworten

  • Hi Fabrice,

    Entschuldige, hier die Antworten:

    Auf dem Server ist für die Instandsetzung erstmal keine Proxy oder Security Software.

    Der Client ist der wichtigere Teil...

    Ich nutzte Outlook 2010 und es handelt sich um einen Exchange 2013 auf Server 2012.

    OK, was steht denn jetzt im Profil und was in den Proxysettings?

    Hier die Ausgaben der Abfragen:

    Konfigurier die externen URLs - siehe Posttasks oder die zweite URL:
    http://technet.microsoft.com/en-us/library/jj218640(v=exchg.150).aspx

    http://msexchangeguru.com/2013/01/10/e2013-outlook-anywhere/

    Bei der Abfrage von der GUID habe ich in der Shell das gleiche Ergebnis wie im Outlook erhalten.

    Was meinst du da - den Namen im Profil? Das wäre iO...


    Viele Grüße
    Christian

    Dienstag, 2. April 2013 16:53
    Moderator

Alle Antworten

  • Hi Colodian,

    SRV ist eine Umleitung, wenn nur eine Domain im Cert hast.

    Wenn du beide Namen im Cert hast, musst du nur den Autodiscovereintrag machen:
    http://www.more2know.nl/2010/05/18/exchange-autodiscover-and-multiple-domains/

    Klappt der OWA-Zugriff ohne Fehler und was liefert Outlook Email-Autokonfigurationstest?
     -- Viele Grüße
    Christian

    Freitag, 29. März 2013 18:18
    Moderator
  • Hallo Christian

    Danke für deine schnelle Antwort!

    Genau, ich brauche etwas in Richtung SRV.

    Der OWA-Zugriff kann für jede Domain einheitlich auf die Stammdomain also domainx.ch weitergeleitet werden. Jedoch bei Outlook erhalte ich bei domainy.ch immer folgenden Fehler: autodiscover.domainy.ch Zertifikatfehler. Eigendlich wäre das Ziel das er für Domain domainy.ch autodiscover.domainx.ch verwendet, damit der Name des Zertifikates übereinstimmt.

    Die Autokonfiguration hat fast geklappt. Jedoch bringt er am Schluss die Meldung, dass ich im Online Modus sein muss. Wenn ich danach manuell alles einrichte, erhalte ich wie gesagt den Zertifikatfehler und "automatische Antwort" funktioniert nicht.

    Danke für deine Hilfe!

    Freitag, 29. März 2013 18:46
  • Hi Colodian,

    teste die Autoermittlung hiermit:
    https://www.testexchangeconnectivity.com/


    Viele Grüße
    Christian

    Freitag, 29. März 2013 18:50
    Moderator
  • Danke für die Antwort!

    Ja, das Problem ist, dass der Namen autodiscover.domainy.ch nicht mit dem Zertifikat übereinstimmt. Ein CNAME würde da auch nichts helfen oder?

    Freitag, 29. März 2013 19:44
  • Hi Colodian,

    Danke für die Antwort!

    Ja, das Problem ist, dass der Namen autodiscover.domainy.ch nicht mit dem Zertifikat übereinstimmt. Ein CNAME würde da auch nichts helfen oder?

    was steht denn jetzt alles im Cert? Lenk auf autodiscover.domainx.ch, denn da scheint ja alles zu laufen...


    Viele Grüße
    Christian

    Freitag, 29. März 2013 20:46
    Moderator
  • Hallo Christian

    Also im Zertifikat ist alles für domainx.ch...

    Wie kann ich den autodiscover.domainy.ch auf autodiscover.domainx.ch abändern?

    Freitag, 29. März 2013 20:51
  • Hi Colodian,

    Hallo Christian

    Also im Zertifikat ist alles für domainx.ch...

    Wie kann ich den autodiscover.domainy.ch auf autodiscover.domainx.ch abändern?

    Ein cname bringt nichts, da er nicht im Cert steht. Hast du bei der zweiten Domain bereits einen SRV-Record? Bei welchem Provider bist du?

    domainy wird von den Clients dieser Domain versucht aufzulösen und die Anfrage musst du auf den record von domainx umgelenken.

    Wird im ersten Link beschrieben...


    Viele Grüße
    Christian

    Samstag, 30. März 2013 07:45
    Moderator
  • Hallo Christian

    Im Moment habe ich auf domainy.ch lediglich einen SRV-Record, einen MX-Record und einen A-Record für mail.domainy.ch.  Und das wars. Fehlt da noch ein A-Record oder so etwas?

    Ich habe aber folgende Probleme (ein neues, ganz böses ist aufgetaucht...):

    1) Beim einrichten:

    Dieses ist nicht so schlimm, da ich es auch manuell einrichten kann.

    Jedoch:

    Wenn ich alles eingerichtet kann ich in Outlook arbeiten. Beim erneuten Öffnen kann Outlook dann auf einmal keine Verbindung mehr herstellen. Keine Ahnung wieso keine Verbindung mehr hergestellt werden kann.

    Und zuletzt (wenn Outlook funktioniert):

    Funktioniert die automatische Antwort nicht...

    Danke für deine Hilfe!!!


    Samstag, 30. März 2013 10:10
  • Hi Fabrice Locher,

    Im Moment habe ich auf domainy.ch lediglich einen SRV-Record, einen MX-Record und das wars. Fehlt da noch ein A-Record oder so etwas?

    wohin zeigt denn der SRV-Record und bei welchem Provider?

    Ich habe aber folgende Probleme (ein neues, ganz böses ist aufgetaucht...):

    Was sagt denn: https://www.testexchangeconnectivity.com/

    Die richtige Domain wäre hilfreich...


    Viele Grüße
    Christian

    Samstag, 30. März 2013 20:40
    Moderator
  • Hey Christian

    Danke für deine Antwort.

    Also folgende Domains:

    Domain mit Zertifikat: contoweb.ch
    Andere Domain: locher-ruheberg.ch

    Folgende SRV-Eintrag ist vorhanden:

    DNS Verwaltung ist bei alfahosting.de, VPS bei Contabo.

    Hoffe das hilft dir weiter!


    Samstag, 30. März 2013 22:20
  • Hier das Ergebnis vom Test:

    Samstag, 30. März 2013 22:21
  • Hi Fabrice Locher,

    Hier das Ergebnis vom Test:

    <http://social.technet.microsoft.com/Forums/getfile/265026>

    Autodiscovertechnisch sieht alles iO aus und jetzt ist noch die Fragen, warum er beim Neustart keine Verbindung mehr hat.

    Ist ein Proxy oder andere Security-Software auf dem Client aktiv?
    http://thoughts.stuart-edwards.info/index.php/sysadmin/exchange-2010/your-automatic-reply-settings-cannot-be-displayed-because-the-server-is-currently-unavailable

    Welchen Outlook-Client nutzt du? Exchange 2013 ist aktiv, wenn ich es richtig gesehen habe?

    Auch die virtuellen Verzeichnisse müsste man sich jetzt mal anschauen:
    Get-WebServicesVirtualDirectory
    Get-OabVirtualDirectory
    Get-AutodiscoverVirtualDirectory
    Get-ActiveSyncVirtualDirectory


    Viele Grüße
    Christian

    Sonntag, 31. März 2013 11:11
    Moderator
  • Hallo Christian

    Also die Verbindung verliert er meiner Meinung deshalb:
    Man trägt bei den Exchange-Proxyeinstellungen ja den Exchange Proxy-Server ein. In diesem Falle ist das z.B mail.locher-ruheberg.ch. Dann klappt die Verbindung auch. Wenn ich jetzt aber Outlook nach einem Neustart wieder starte, ist beim Proxy-Server auf einmal der interne Hostname des Servers inkl. Domain. Also z.B Srv01.internedomain.local...

    Sonntag, 31. März 2013 12:06
  • Hi Fabrice Locher,

    du sollest auf die Fragen antworten, denn im Profil kann ruhig der interne Name stehen, sofern die Proxystettings richtig sind.

    Dort musst du ansetzen und die Einstellungen müssen mit den Serversettings übereinstimmen.
    http://exchangeserverpro.com/how-to-configure-exchange-server-2010-outlook-anywhere

    Das Verhalten ist von der Serverversion abhängig und darum sind die Anworten wichtig. So steht bei Exchange 2013 weder der interne noch der externe Server im Profil, sondern die MailboxGUID:
     http://www.howexchangeworks.com/2012/11/mailboxguid-smtp-domain-is-the-new-endpoint-in-outlook-for-exchange-2013-mailboxes.html


    Viele Grüße
    Christian

    Montag, 1. April 2013 07:59
    Moderator
  • Hoi Christian

    Entschuldige, hier die Antworten:

    Auf dem Server ist für die Instandsetzung erstmal keine Proxy oder Security Software.
    Auf dem Client iist Symantec Endpoint Protection aktiviert.

    Ich nutzte Outlook 2010 und es handelt sich um einen Exchange 2013 auf Server 2012.

    Hier die Ausgaben der Abfragen:

    Bei der Abfrage von der GUID habe ich in der Shell das gleiche Ergebnis wie im Outlook erhalten.
    Montag, 1. April 2013 09:45
  • Hier noch ein kleiner Anhang, welcher mich auch ein wenig erstaunt hat:

    Beim Exchange Test habe ich die RPC over HTTPS Verbindung getestet. Den Server sollte es via Autodiscover ermitteln. Folgendes Ergebnis:

    Warum wird hier schon nach dem internen Servername gesucht?

    Montag, 1. April 2013 09:56
  • Hi Fabrice,

    Entschuldige, hier die Antworten:

    Auf dem Server ist für die Instandsetzung erstmal keine Proxy oder Security Software.

    Der Client ist der wichtigere Teil...

    Ich nutzte Outlook 2010 und es handelt sich um einen Exchange 2013 auf Server 2012.

    OK, was steht denn jetzt im Profil und was in den Proxysettings?

    Hier die Ausgaben der Abfragen:

    Konfigurier die externen URLs - siehe Posttasks oder die zweite URL:
    http://technet.microsoft.com/en-us/library/jj218640(v=exchg.150).aspx

    http://msexchangeguru.com/2013/01/10/e2013-outlook-anywhere/

    Bei der Abfrage von der GUID habe ich in der Shell das gleiche Ergebnis wie im Outlook erhalten.

    Was meinst du da - den Namen im Profil? Das wäre iO...


    Viele Grüße
    Christian

    Dienstag, 2. April 2013 16:53
    Moderator
  • Hallo Christian

    Heute am Mittag ist es mir endlich gelungen. Ganz simpel, der Outlook Anywhere - externe Host Eintrag hat gefehlt. Genau was du jetzt beschrieben hast. 
    Danke für deine Hilfe!!!

    lg Fabrice

    Dienstag, 2. April 2013 18:20
  • Hi Fabrice Locher,

    Danke für deine Hilfe!!!

    schön zu hören und danke für die Rückmeldung!


    Viele Grüße
    Christian

    Mittwoch, 3. April 2013 04:58
    Moderator