none
Neu erstellte Zertifikatvorlage taucht nicht auf RRS feed

  • Frage

  • Hallo zusammen,
    zum System selber, es gibt zwei DC´s in der Domäne (Funktionsebene 2003) einer der DCs ist ein Win2k8 Std. und einer Win2k3R2 Std. Ich habe auf dem Win2k8 eine PKI installiert. Dann habe ich eine neue Zertifikatvorlage erstellt und wollte diese dann aktivieren. Leider taucht die neu erstellte Zertifikatvorlage nicht auf? Ich kann Sie also nicht aktivieren. Ich habe jetzt schon den Server einmal neu gestartet und einen Tag gewartet. Die Sicherheitsberehtigung auf der Vorlage hab ich so eingestellt das beide DCs Lesen und Registrieren dürfen (Computerkonto hinzugefügt). Auth. Benutzer dürfen auch lesen...

    Als zusätzlich Info, es war wohl schon mal eine Windows CA auf dem 2003er installiert und diese wurde dann wieder entfernt. Warum das gemacht wurde weiß ich auch nicht. Jedenfalls sind im ADSI Edit noch rückstände von der CA vorhanden. Ist das normal? Damals gab es keine Probleme bei der Deinstallation...

    Hat vielleicht jemand ein Tip für mich was ich noch Kontrollieren kann?

    Gruß Kirus

    Donnerstag, 13. Januar 2011 12:59

Antworten

Alle Antworten

  • Hi,

    Am 13.01.2011 13:59, schrieb Kirus:

    zein Win2k8 Std. und einer Win2k3R2 Std.

    Die Standard Edition kann keine eignen ZertVorlagen bereitstellen.
    Einer der Unterschiede zur Enterprise Ed. die in keiner ÜBersicht
    auftauchen.

    Du musst ein wenig mit adsiedit "pfuschen"  ...
    http://www.andreas-buergel.com/kb/windows-server-2003/eigene-zertifikatvorlagen-in-windows-server-2003-standard-edition.html

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    • Als Antwort markiert Kirus Samstag, 15. Januar 2011 01:05
    Donnerstag, 13. Januar 2011 19:25
  • Hallo Mark,

    danke für diesen super Tipp! Es funktioniert! Eins kann ich mir nur nicht erklären, bei einem anderen Kunden habe ich auch keine Enterprise CA gehabt und da ging es ohne Probleme?! Wie kann das sein? Dort wurde auch nur Win2k8 Std. eingesetzt?!

    Gruß Kirus

    Samstag, 15. Januar 2011 01:05
  • Hi,

    Am 15.01.2011 02:05, schrieb Kirus:

    keine Enterprise CA gehabt und da ging es ohne Probleme?!

    Nicht Enterprise CA, sonder tatsächlich "Windows Server 200x Standard
    Ed." oder "Windows Server Enterprise/Datacenter Edition"

    Eventuell, ist es auf einem "Windows Server Standard" als Standalone
    CA ohne Active Directory möglich, da dann diese Vorlagen nicht im
    AD hinterlegt sind, aber das habe ich noch nicht ausprobiert, oder
    nicht drauf geachtet.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    Samstag, 15. Januar 2011 10:48
  • Hallo Mark,

    also es war ein Windows Server 2008 Standard Server mit AD und einer CA. Und da gab es keine Probleme. Ich kann es mir einfach nicht erklären?!

    Gruß Kirus

    Samstag, 15. Januar 2011 18:08
  • Servus Kirus,

    hab das Problem jetzt auch schon in zwei Firmen gehabt. Server 2008 Standard Server mit AD und einer CA. Irgendwann ging's dann doch (ohne ADSI_Template-Version ändern).

    - Vielleicht mit falschem Benutzerkonto angemeldet? (Domain Admin/Lokaler Admin)

    - Vielleicht MMC öffen, Zertifikate Snap-In (Lokales Computerkonto wählen), dann rechte Maustaste auf Zertifikate, "Neues Zertifikat anfordern"

    - Vielleicht vergessen in der Zertifizierungsstelle die Zertifikatsvorlage neu auszustellen (Zertifizierungsstelle [lokal] - Zertifikatsvorlagen - Neu - "Auszustellende Zertifikatsvorlage")

    - Eigenschaften von Zertifikat falsch (Zweck, Sicherheit, Anwendungsrichtlinien, Antragstellername [aus Informationen aus dem AD, Vollständig definierter Name, UPN])

    Grüße

    Fränz

    Freitag, 17. Februar 2012 16:55