none
Exchange 2010 Public Folder Mail Flow RRS feed

  • Frage

  • Hallo zusammen,

    wir haben ein Problem
    bei dem ich ganz dringend um eure Hilfe bitte.

    Und zwar gab es bislang nur einen Postfachserver.
    Für eine Umstellung auf eine DAG haben wir 2 zusätzliche Postfachserver eingerichtet,
    welche aber, um diese ausfühlich testen zu können, nicht in den Live Betrieb eingreifen sollten.
    Auf beiden neuen Server wurde eine Public Folder Datenbank angelegt, jedoch noch keine Replikation konfiguriert und alle Mailbox Datenbanken haben die alte Public Folder Datenbank als Standard hinterlegt.

    Nun fiel uns auf, dass wenn einer der neuen Server (bei welchem die Public Fodler Datenbank zuletzt eingerichtet wurde) nicht erreichbar ist, beharren alle Mails welche an den Public Folder gehen in der Warteschlange unseres Hub Servers.
    Das heißt der eine neue Server empfängt alle eingehenden Mails.

    Wie kann ich dies wieder so einstellen, dass der alte Server die Mails für den Öffentlichen Ordner erhält?

    Ich danke euch sehr!

    Mfg, Phenoxy

    Donnerstag, 10. Januar 2013 07:58

Antworten

  • Hallo Manfred,

    Ich habe nochmal etwas recherchiert und das Verhalten wurde tatsächlich gerade erst mit dem RU4v2 angepasst! Vorher war es so wie ich es oben beschrieben habe und wie in den Blogs dargestellt. Seit RU4v2 kannst Du nun aber die EdgeTransport.exe.config anpassen, um das Problem zu umgehen. Schau mal hier: http://support.microsoft.com/kb/2536846

    Sorry, hatte ich vorher nicht mehr gefunden!

    Viele Grüße

    Timo

    Freitag, 11. Januar 2013 18:25

Alle Antworten

  • Auf welchen ServicePack und RP Stand bist du? Es gab mal ein Problem da sind die Mails immer erst in dem als zu letzt installierten Public Folder gelandet und nicht in der "konfigurierten" in den Postfach DB Einstellungen.

    Gruß

    Jörg

    Donnerstag, 10. Januar 2013 10:20
  • Hey ja, das klingt genau nach meinem Problem.
    Hast du dazu noch ein wenig Details oder ein Statement von Microsoft?
    Wäre super ;-)

    Unsere Version ist Exchange 2010 SP2 Rollup 4-v2.

    Und schonmal recht herzlichen Dank!!

    Donnerstag, 10. Januar 2013 11:17
  • http://msexchangeteam.com/archive/2004/09/10/228114.aspx und http://technet.microsoft.com/en-us/library/aa996228(EXCHG.14.1).aspx beschreiben es ein bischen. Du kannst aber pro Public Folder Datenbank das Attribut "UseCustomReferralServerList" auf true setzen und dann die "CustomReferralServerList" pflegen, das sollte dann funktionieren.


    Donnerstag, 10. Januar 2013 12:14
  • Hallo Phenoxy2,

    die relevanten Links hat Dir Joerg ja bereits mit dem letzten Posting gegeben. Das Verhalten ist leider so, dass unter bestimmten Umstaenden (genauer beschrieben unter den beiden Links), Dein Hub Transport Server den juengsten Public Folder Store versucht zu kontaktieren, um von diesem zu erfahren welcher Public Folder Store ein Replikat des jeweiligen Folders hat. Ist der juengste Store dann nicht online, haengen die Mails in der Warteschlange auf dem Hub Transport.

    Ich war bis gerade eben auch der Meinung, dass es vor kurzem eine Anpassung bzgl. dieses Verhaltens - was nun schon von Version zu Version geschleppt wird - gab. Vermutlich habe ich mich da aber vertan - zumindest kann ich nichts mehr dazu finden.

    Du koenntest auf Deinen Hub Transport Servern zusaetzlich die Mailbox-Rolle installieren und dort einen lokalen und leeren Public Folder Store anlegen. Bevor der Hub Transport beim Routing naemlich nachschaut, welches der juengste Public Folder Store ist, guckt er erst einmal ob er nicht selbst sogar einen Public Folder Store hat. Wenn dem so ist, dann wird die Hierarchie vom lokalen Store ausgelesen und die Nachricht dann an einen der Stores geschickt, die ein Replikat des jeweiligen Folders haben.

    VG, Timo

    Donnerstag, 10. Januar 2013 12:31
  • Ich war bis gerade eben auch der Meinung, dass es vor kurzem eine Anpassung bzgl. dieses Verhaltens - was nun schon von Version zu Version geschleppt wird - gab. Vermutlich habe ich mich da aber vertan - zumindest kann ich nichts mehr dazu finden.

    Mit RUP2 für SP1 gab es afaik "Verbesserungen"..
    Donnerstag, 10. Januar 2013 12:54
  • Danke, danke!!!
    habt mir schon wirklich weitergeholfen.

    Wenn ich also die neuen Datenbanken lösche,
    funktionierte die alte Datenbank wieder unabhängig von den neuen Servern?!

    Aber wie bekomme ich eine Redundanz der Öffentlichen Ordner,
    wenn bei Ausfall des einen Servers der andere nicht übernimmt,
    sondern die Mails in der Warteschlange verharren?

    Gruß, Phenoxy
    Donnerstag, 10. Januar 2013 13:38
  • Hi,

    ja, wenn Du die neuen DBs loescht dann geht es erstmal wieder. Das ist wahrscheinlich aber nicht das Ziel, dass Du verfolgst, oder?

    Du koenntest auf Deinen Hub Transport Servern zusaetzlich die Mailbox-Rolle installieren und dort einen lokalen und leeren Public Folder Store anlegen. Bevor der Hub Transport beim Routing naemlich nachschaut, welches der juengste Public Folder Store ist, guckt er erst einmal ob er nicht selbst sogar einen Public Folder Store hat. Wenn dem so ist, dann wird die Hierarchie vom lokalen Store ausgelesen und die Nachricht dann an einen der Stores geschickt, die ein Replikat des jeweiligen Folders haben.

    VG, Timo



    • Bearbeitet Timo Geuken Donnerstag, 10. Januar 2013 14:45
    Donnerstag, 10. Januar 2013 14:44
  • Hi,
    so richtig stellte es sich bei mir interessanter Weise noch nicht und ich bin darüber noch gar nicht gestolpert, da die Server meist alle Rollen hatten und zwei HLBs dafür stehen. Joerg hat die Hinweise bereits gegeben und hier ist noch eine Beschreibung: http://www.proexchange.be/blogs/exchange2010/archive/2012/01/02/public-folder-high-availability-in-an-exchange-2010-dag-environment.aspx
    Grüße Christian
    Donnerstag, 10. Januar 2013 21:09
    Moderator
  • Hallo zusammen,

    Es geht hier nicht um Referrals (MAPI), sondern um das Nachrichten-Routing (SMTP) in/zu Public Foldern. Das mit den Referrals wurde mit SP1 RU2 behoben. Damit man auf das beschriebene Verhalten mit dem Routing überhaupt aufmerksam wird, muss schon eine Reihe von Dingen zutreffen:

    - Hub Transport Server dürfen keinen Public Folder Store haben (d.h. kein Multi-Role)

    - Der zuletzt installierte / angelegte Public Folder Server muss offline sein

    - Es muss eine Nachricht an einen E-Mail aktivierten Public Folder gesendet werden

    - Der Admin muss mitbekommen, dass die Nachricht auf dem Hub Transport in der Queue hängen bleibt

    Wieso, weshalb, warum: http://blogs.technet.com/b/exchange/archive/2004/09/10/228114.aspx

    Viele Grüße

    Timo

    Freitag, 11. Januar 2013 07:31
  • Hallo nochmal,

    leider funktioniert das von Timo beschriebene Verfahren in unserem Fall nicht,
    da wir 2 Hub Server im Einsatz haben,
    wobei einer immer die zuletzt eingerichtete Datenbank hätte und somit der SPOF wäre.

    Oder irre ich mich da?

    Habt ihr vielleicht eine andere Idee,
    wie ich das in unserem Scenario lösen kann?

    Danke euch!!

    Unser Aufbau:   2x Hub Server & 2x MB Server & 1x HUB/CAS/MB Server (dieser soll ersetzt werden)
                              Alle Server sind Exchange 2010 SP2 RUP 4-v2

    Freitag, 11. Januar 2013 08:53
  • Hallo Manfred,

    Ich habe nochmal etwas recherchiert und das Verhalten wurde tatsächlich gerade erst mit dem RU4v2 angepasst! Vorher war es so wie ich es oben beschrieben habe und wie in den Blogs dargestellt. Seit RU4v2 kannst Du nun aber die EdgeTransport.exe.config anpassen, um das Problem zu umgehen. Schau mal hier: http://support.microsoft.com/kb/2536846

    Sorry, hatte ich vorher nicht mehr gefunden!

    Viele Grüße

    Timo

    Freitag, 11. Januar 2013 18:25