none
"Phänomen" bei Softwareinstallation RRS feed

  • Frage

  • Hallo,
     
    vor einiger Zeit (Anfang des Jahres) hatte ich schonmal das Problem
    geschildert das bei einer Win 7 64 Bit Maschine die Softwareverteilung per
    GPO nicht funktioniert.
     
    Hintergrund war das der DFS-Share anscheinend nicht gefunden werden konnte
    "net source \\domäne\share is invalid"
     
    Damals konnte keine wirkliche Ursache festgemacht werden - ich habe damals
    die vorinstallierte Windowsversion (das war ein HP-Rechner) runtergeworfen
    und mit einer "normalen" Version ersetzt - siehe da, es ging.
     
    Jetzt hatte ich das Problem wieder, diesmal mit einem HP-Laptop... hier ein
    Ausschnitt aus dem Installerlog:
     
    MSI (s) (4C:78) [18:32:33:056]: SOURCEMGMT: Media is enabled for product.
    MSI (s) (4C:78) [18:32:33:056]: SOURCEMGMT: Attempting to use LastUsedSource from source list.
    MSI (s) (4C:78) [18:32:33:056]: SOURCEMGMT: Processing net source list.
    MSI (s) (4C:78) [18:32:33:056]: SOURCEMGMT: Trying source \\xxxx\files\SWDistri\NetPhone\x64\.
    MSI (s) (4C:78) [18:32:33:056]: Note: 1: 1402 2: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 3: 2
    MSI (s) (4C:78) [18:32:45:495]: Note: 1: 1314 2: \\xxxx\files\SWDistri\NetPhone\x64\
    MSI (s) (4C:78) [18:32:45:495]: ConnectToSource: CreatePath/CreateFilePath failed with: -2147483648 1314 -2147483648
    MSI (s) (4C:78) [18:32:45:495]: ConnectToSource (con't): CreatePath/CreateFilePath failed with: -2147483648 -2147483648
    MSI (s) (4C:78) [18:32:45:495]: SOURCEMGMT: net source '\\xxxx\files\SWDistri\NetPhone\x64\' is invalid.
    MSI (s) (4C:78) [18:32:45:495]: Note: 1: 1706 2: -2147483647 3: NetPhoneClientGerman64.msi
    MSI (s) (4C:78) [18:32:45:495]: SOURCEMGMT: Processing media source list.
    MSI (s) (4C:78) [18:32:45:511]: SOURCEMGMT: Trying media source D:\.
    MSI (s) (4C:78) [18:32:45:511]: Note: 1: 2203 2: D:\NetPhoneClientGerman64.msi 3: -2147287038
    MSI (s) (4C:78) [18:32:45:511]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
    MSI (s) (4C:78) [18:32:45:511]: Note: 1: 1706 2: -2147483647 3: NetPhoneClientGerman64.msi
    MSI (s) (4C:78) [18:32:45:511]: SOURCEMGMT: Processing URL source list.
    MSI (s) (4C:78) [18:32:45:511]: Note: 1: 1402 2: UNKNOWN\URL 3: 2
    MSI (s) (4C:78) [18:32:45:511]: Note: 1: 1706 2: -2147483647 3: NetPhoneClientGerman64.msi
    MSI (s) (4C:78) [18:32:45:511]: Note: 1: 1706 2:  3: NetPhoneClientGerman64.msi
    MSI (s) (4C:78) [18:32:45:511]: SOURCEMGMT: Failed to resolve source
    MSI (s) (4C:78) [18:32:45:511]: MainEngineThread is returning 1612
     
    Hier habe ich jetzt etwas breiter recherchiert und einen Fall gefunden, bei
    dem eine Änderung/Verkürzung des Pfades geholfen hatte sowie einen bei dem
    das nach Vergabe einer festen IP ging.
     
    Eine Änderung des Pfades hatte bei mir keine Wirkung - wohl aber die
    Vergabe einer festen IP-Adresse (normalerweise bekommen alle PCs hier per
    DHCP Ihre Adressen)...
     
    Der "Witz" daran ist das der Laptop per Dockingstation angeschlossen ist,
    es aber weder mit der im Laptop integrierten noch mit der Netzwerkkarte in
    der Dockingstation ging solange DHCP aktiv war.
     
    Kann mir das jemand plausibel erklären?
     
    Kann der Treiber beider Netzwerkkarten so defekt sein das so ein Symptom
    auftritt?
     
    Thomas
     
    Dienstag, 18. Oktober 2011 06:45

Alle Antworten

  • Hallo,

    >Der "Witz" daran ist das der Laptop per Dockingstation angeschlossen ist,
    >es aber weder mit der im Laptop integrierten noch mit der Netzwerkkarte in
    >der Dockingstation ging solange DHCP aktiv war.
    >Kann mir das jemand plausibel erklären?
    vermutlich hat das ganze mit der Namenauflösung zu tun:

    >SOURCEMGMT: Failed to resolve source
    Einen Ansatz wäre noch, wenn du in der lokalen host-Datei diesen Server einträgs und dann wieder auf DHCP stellst.
    (nur als Test natürlich)
    So wie es ausschaut startet der Treiber für die Netzwerkkarte zu spät oder
    zumindest steht zu diesem Zeitpunkt kein Netzwerk zur Verfügung.

    Natürlich wären wir hier auch wieder bei der FAQ 36, die du aber hoffentlich ja schon gesetzt hast.

    MVP - Group Policy http://matthiaswolf.blogspot.com/
    Dienstag, 18. Oktober 2011 07:12
    Beantworter
  • -2147483648 = 0x80000002 = Path not found. Kannst Du per "psexec -s cmd"
    aus dieser Commandline auf Dein Paket zugreifen? (Dir reicht schon...)
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Dienstag, 18. Oktober 2011 15:11
    Beantworter