none
Problem mit windows 2008 R2 Server und domaincontroller RRS feed

  • Frage

  • Hallo Zusammen,

    Ich habe ein DC mit Windows 2008 R2 Server. Nun wollte ich ein Windows 2016 Server zu bestehenden Domänen hinzufügen(Promoten). In den letzten Schritt bekomme ich die Fehlermeldung:

    ##

    Adprep was unable to complete because the call back function failed.

    Error message: Unable to access the computer "meindom.com". Access is denied

    ###

    Hat jemand eine Idee warum?

    Vielen Dank

    Keywan

    Donnerstag, 7. September 2017 10:50

Antworten

Alle Antworten

  • Moin,

    keine definitive Lösung, aber ein Paar Punkte:


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Donnerstag, 7. September 2017 15:31
  • # Der Account ist in Enterprise Admin group

    # Ja es laeuft als Network service

    # habe ich nicht ausprobiert, es heißt ich muss mit CD 2016 auf DC 2008 adprep ausfuehren.

    reicht es wenn ich adprep /forestprep und adprep /domainprep ausfuehre?

    #ja ist er als DNS muss nachschauen

    Der Fehler ist eigentlich so:

    ADPrep execution failed --> System.ComponentModel.Win32Exception (0x80004005): A device attached to the system is not functioning.
    Check the log files in the C:\Windows\debug\adprep\logs\20140724151513 directory for detailed information.



    • Bearbeitet mpng2008 Donnerstag, 7. September 2017 18:20
    Donnerstag, 7. September 2017 17:49
  • Moin,

    Enterprise Admin ist nicht per se Schema Admin. Da muss das Account expliziot rein, wenn es noch nicht da ist.

    Device attached is not functioning ist eigentlich so ein Remote Registry-Ding. Kannst Du, falls noch nicht geschehen, auf beiden Maschinen die Firewall "auf Durchzug stellen"? Also im Domänen-Profil ein, aber eingehende wie ausgehende Verbindungen zulassen. Und sicherstellen, dass Remote Registry auf beiden Masxhinen läuft und funzt (Test: mit Regedit vom jeweils anderen Rechner verbinden).

    Und ja, von der 2016 CD, in 2008 gemountet, die beiden Befehle ausführen.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Donnerstag, 7. September 2017 18:47
  • Perfekt ich habe auf windows 2008 R2 die Remote Registry auf "Local Service" gestellt und neu gestartet und es tut jetzt.

    Nun ist Windows 2016 als DC in Windows 2008 R2 integriert. Ich will die FSMOs noch auf Windows 2008 R2 laufen lassen dann wenn ich mein physikalischen DC Windows 2008 R2 auf Windows 2016 ustellen dann werde ich die FSMOs von Windows 2008 R2 auf Windows 2016 migrieren und auf  ein neuen physikalischen Rechner Windows 2016 neu installieren und in die Domäne nehmen und als DC promoten und dann die FSMOs zurück die neuen physikalischen Rechner Windows 2016 transferieren. Ist die vorgehensweise richtig?

    • Bearbeitet mpng2008 Donnerstag, 7. September 2017 19:43
    Donnerstag, 7. September 2017 19:03
  • Ja, das kannst Du so machen. Zwischendurch musst Du dich aber noch vergewissern, dass die Replikation funktioniert und z.B. auch die DNS-Zonen korrekt repliziert werden. Aber auch der Inhalt von SYSVOL, wozu auch die GPO gehören, solltest Du überprüfen, bevor Du einen DC herunterstufst.

    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Donnerstag, 7. September 2017 20:02
  • ich habe die Inhalte vom SYSVOLL auf den neu errichteten DC mit windows 2016 server mit dem SYSVOLL auf dem Windows 2008 R2 verglichen, sind identisch und repliziert worden. Auch den DNS server und zonen sind exakt repliziert.

    Wenn ich den DNS Manager auf dem Windows 2008 R2 und DNS Manager auf dem Windows 2016 Server vergleiche, sind alle Zonen und Inhalte identisch.

    Es heißt für mich, dass die DC mit Windows 2016 Server erfolgreich in die Domäne mit Windows 2008 R2 aufgenommen worden ist. Oder übersehe ich was?

    Nun kann ich beruhigt die zweite DC mit Windows 2008 R2(VMWARE) herunterstufen und aus der Domäne nehmen und danach wieder eine DC mit Windows 2016 aufsetzen und in die Domäne nehmen und ihn wieder promoten. Kann ich so vorgehen? Wenn es alles perfekt läuft, kann ich als letztes mein physikalischen DC mit Windows 2008 R2 auch auf Windows 2016 Server umstelle,denn alle FSMOs laufen zurzeit auf die physikalischen DC mit Windows 2008 R2. Zuerst transfereie ich alle FSMOs auf mein neu errichteten DC mit Windows 2016 und stufe ich den physikalischen DC mit Windows 2008 R2 herunter und nehme ihn aus de Domäne. Setze einen neuen physikalischen Rechner mit Windows 2016 Server auf und nehme ihn in der Domäne und promote ich ihn und transferie die FSMOs vom DC Windows 2016(VMWARE) auf dem neu errichteten physikalischen DC mit Windows 2016 Server. so kann ich es machen oder gibt es was, was ich vergessen habe?

    Vielen Dank für deine Hilfe

    Keywan

    Freitag, 8. September 2017 06:52
  • Moin, ja, alles richtig, und immer daran denken: nach jedem Schritt abwarten und verifizieren, dass er auch abgeschlossen ist!

    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Freitag, 8. September 2017 07:09
  • vielen Dank für deine Hilfe. Was mir aufgefallen ist, dass ich die weder SYSVOLL noch Netlogon aus meinem Client keinen Zugriff habe. Er fragt nach username und Password, ich gebe es ein, aber weiterhin keinen Zugriff. Ist es normal?
    Freitag, 8. September 2017 08:41
  • vielen Dank für deine Hilfe. Was mir aufgefallen ist, dass ich die weder SYSVOLL noch Netlogon aus meinem Client keinen Zugriff habe. Er fragt nach username und Password, ich gebe es ein, aber weiterhin keinen Zugriff. Ist es normal?

    nein

    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    • Als Antwort markiert mpng2008 Donnerstag, 14. September 2017 06:32
    Freitag, 8. September 2017 08:43
  • das selbe gilt für Windows 2008 R2 server. Was kann man da machen?

    Ich glaube zu wissen, dass es an 'Winodws 10 Client liegt. Ich habe Windows 10 Client. Man muss in gpedit.msc Änderungen vornehmen.

    Computer -> Administrative Templates -> Network -> Network Provider -> Hardened UNC Paths, enable the policy and click "Show" button.

    • Bearbeitet mpng2008 Freitag, 8. September 2017 08:51
    • Als Antwort markiert mpng2008 Donnerstag, 14. September 2017 06:32
    Freitag, 8. September 2017 08:48