none
Windows Freigabe "Dieser Ordner ist leer" RRS feed

  • Frage

  • Hallo liebe Comunity,

    ich bin seit einigen Tagen mit meinem rel. frischen Lenovo Notebook ein - anscheinend - nicht lösbares Problem.

    Eine SMB-Freigabe ist von allen verwendeten Betriebssystemen aufrufbar, nur von meinem Windows 10 Notebook nicht.

    • Windows 10 Pro (Version 1809, Build 17763.615)
    • Netzwerk: Privat
    • Netzwerkerkennung eingeschaltet
    • Datei- und Druckerfreigabe aktiviert
    • SMB 1.0/CIFS File Sharing Support (Windows-Feature) installiert

    Rufe ich das Netzwerkgerät (WD NAS) im Windows-Explorer via \\192.168.0.100 auf, quittiert mir der Explorer das mit der Meldung: "Dieser Ordner ist leer"

    Auf Unixoiden Systemen habe ich nicht ansatzweise derartige Probleme.

    Android, Manjaro Linux (xfce), Linux (headless Raspbian)

    Da ich keine Bilder oder Links posten darf, hier nur die Ausgabe vom Linux-Terminal:

    root@skynet: smbclient -L 192.168.0.100 -U guest%
    WARNING: The "syslog" option is deprecated
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.0.9]
    
    	Sharename       Type      Comment
    	---------       ----      -------
    	IPC$            IPC       IPC Service (Network Attached Storage)
    	Recycle Bin - Volume_1 Disk      Recycle Bin Directories
    	firetv          Disk      
    	steffi          Disk      
    	plex_conf       Disk      
    	git             Disk      
    	TimeMachineBackup Disk      
    	SmartWare       Disk      
    	Public          Disk      
    	Phil            Disk      
    	.twonkymedia    Disk      
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.0.9]
    
    	Server               Comment
    	---------            -------
    	NAS                  Network Attached Storage
    
    	Workgroup            Master
    	---------            -------
    	WORKGROUP 

    Prinzipiell kann ich unterstellen, dass die Freigaben funktionieren.

    Meine Frage ist: Was braucht Windows 10, damit es einwandfrei auf SMB-Shares zugreifen kann? Ich komm einfach nicht dahinter und würde mich außerordentlich über einen Hinweis freuen.

    Liebe Grüße

    Phil

    Dienstag, 30. Juli 2019 15:09

Antworten

  • Hallo und vielen Dank für Deine Antwort.

    Der Samba-Server unterstützt die Protokolle 1, 2 & 3. Das Umstellen auf Prot.-Version 1 oder die Erneuerung der Hardware wäre an dieser Stelle irgendwie absurd.

    Nach Durchwühlen meiner Log-Files bin ich auf einen Eintrag gestoßen, der mich stutzig gemacht hat:

    [2019/07/30 17:34:52.659739, 0] auth/auth.c:299(auth_check_ntlm_password) CIFS: Authentication for user [nicht_existierender_benutzer] has FAILED.

    Windows schickt wohl automatisch die Windows-Anmelde-Credentials zum Samba-Server. Es handelte sich in diesem Fall um den Usernamen meines Windows 10-Rechners.

    Folgendes hat mir geholfen:

    Using REGEDIT it's necessary to create a DWORD value called 'AllowInsecureGuestAuth' in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set this new value to 1. A reboot will also be necessary.

    Quelle: Darf leider keine Links einfügen :-/

    Möglicherweise gibt es eine derartige Option auch in den Gruppenrichtlinien(????)

    Liebe Grüße


    • Bearbeitet Phido Dienstag, 30. Juli 2019 20:57
    • Als Antwort markiert Phido Dienstag, 30. Juli 2019 21:09
    Dienstag, 30. Juli 2019 20:56

Alle Antworten

  • Da gibt's mal wieder 2 Möglichkeiten:
    a) alle anderen Freigaben müssen von SMB1 auf mindestens SMB2 besser SMB3 umgestellt werden.
    b) Windows 10 über Features hinzufügen die standardmäßig deaktivierte SMB1 wieder aktivieren.

    Allgemein wird hier Lösung a) preferiert;-), wobei wenn a) bei einigen Geräten nicht geht, dann diese Geräte eben erneuern bzw. updaten (mal so polemisch).

    Dienstag, 30. Juli 2019 16:48
  • Hallo und vielen Dank für Deine Antwort.

    Der Samba-Server unterstützt die Protokolle 1, 2 & 3. Das Umstellen auf Prot.-Version 1 oder die Erneuerung der Hardware wäre an dieser Stelle irgendwie absurd.

    Nach Durchwühlen meiner Log-Files bin ich auf einen Eintrag gestoßen, der mich stutzig gemacht hat:

    [2019/07/30 17:34:52.659739, 0] auth/auth.c:299(auth_check_ntlm_password) CIFS: Authentication for user [nicht_existierender_benutzer] has FAILED.

    Windows schickt wohl automatisch die Windows-Anmelde-Credentials zum Samba-Server. Es handelte sich in diesem Fall um den Usernamen meines Windows 10-Rechners.

    Folgendes hat mir geholfen:

    Using REGEDIT it's necessary to create a DWORD value called 'AllowInsecureGuestAuth' in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set this new value to 1. A reboot will also be necessary.

    Quelle: Darf leider keine Links einfügen :-/

    Möglicherweise gibt es eine derartige Option auch in den Gruppenrichtlinien(????)

    Liebe Grüße


    • Bearbeitet Phido Dienstag, 30. Juli 2019 20:57
    • Als Antwort markiert Phido Dienstag, 30. Juli 2019 21:09
    Dienstag, 30. Juli 2019 20:56
  • Am 30.07.2019 schrieb Phido:

    Folgendes hat mir geholfen:

    Using REGEDIT it's necessary to create a DWORD value called 'AllowInsecureGuestAuth' in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set this new value to 1. A reboot will also be necessary.

    Quelle: Darf leider keine Links einfügen :-/

    Dann werde kreativ und lass das http:// einfach weg. :P

    Möglicherweise gibt es eine derartige Option auch in den Gruppenrichtlinien*(????)*

    Millionenfach zu finden mit der DWORD Bezeichnung.
    https://www.thomas-reichel.com/archive/90

    Auf jeden Fall Danke für die Rückmeldung. ;)

    Servus
    Winfried


    WSUS Package Publisher:
    https://github.com/DCourtel/Wsus_Package_Publisher
    HowTos zum WSUS Package Publisher
    https://www.wsus.de/wsus-package-publisher/
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren:
    https://github.com/JochenKalmbach/communitybridge
    GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/

    Mittwoch, 31. Juli 2019 04:53