none
Aufbewahrungsrichtlinie greift nicht RRS feed

  • Frage

  • Hallo.

    Server 2012 R2. Exchange 2013, Domäne 2012 R2

    Ich habe eine Aufbewahrungsrichtlinie erstellt, die alle Mails, älter als 2 Tage in den gelöschten Objekten löscht Leider tut sie das nicht.

    Eine weitere Richtlinie die alle Mails älter als 90 Tage im Postfach löscht wiederum geht.

    Wie kommt man dem Problem auf die Spur? Wo kann man schauen? Bin da echt ratlos. Im Grunde kann man ja nichts falsch machen.

    Get-Mailbox | ft Name, RetentionPolicy, RetentionHoldEnabled

    ist false

    Start-ManagedFolderAssistant

    hilft auch nicht.

    Gruss Ingo





    Donnerstag, 13. Oktober 2016 07:38

Antworten

  • Moin,

    und habt ihr euch auch den MFA Log angeschaut?

    Export-MailboxDiagnosticLogs –Identity <betroffener user> -ExtendedProperties

    So mega aussagekräftig ist es freilich nicht, aber ein Vergleich zwischen dem 90-Tage-User und dem 2-Tage-User könnte vielleicht etwas zutage bringen.

    Wenn alle Stricke reißen, das Logging hoch drehen und schauen, ob was auftaucht:

    Set-EventLogLevel -id "MSExchangeMailboxAssistants\Service" -level expert 
    
    Set-EventLogLevel -id "MSExchangeMailboxAssistants\Email_Lifecycle_Assistant" -level expert 
    
    Set-EventLogLevel -id "MSExchangeMailboxAssistants\ELC Library" -level expert

    Nebenbemerkung: Wenn die 90-Tage-Löschung per Default gesetzt wird, dann werden die Messages auch nicht sichtbar markiert.


    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Samstag, 15. Oktober 2016 07:04

Alle Antworten

  • Moin,

    und siend die Mails im Posteingang tatsächlich mit diesem 2-Tage-Tag getaggt?


    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Donnerstag, 13. Oktober 2016 15:36
  • Hallo.

    Dir Richtlinie wirkt nicht auf den Posteingang sondern auf die gelöschten Objekte. Was meinst Du mit getaggt?

    Gruss Ingo

    Donnerstag, 13. Oktober 2016 17:34
  • so was hier:


    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Donnerstag, 13. Oktober 2016 20:38
  • Guten Morgen.

    Tut mir leid wenn es gerade etwas mühsam ist mit mir, aber wie soll das gehen? Die Mails die es betrifft, die werden ja endgültig gelöscht und sind weg. Und bei denen die z. B. Morgen dran wären steht nichts dran. Auch kein Eintrag im Kontextmenü.

    Gruss Ingo

    Freitag, 14. Oktober 2016 05:43
  • Moin,

    dann ist die Frage ja beantwortet ;-) Deine Richtlinie wird also nicht einmal auf die Elemente angewandt. Da musst Du wirklich noch einmal kritisch prüfen, ob Deine Aufbewahrungsrichtlinie korrekt ist - alle Tags drin inkl. eines Default-Tag alle Tags aktiviert, Zuordnung zur Mailbox usw.

    Vielleicht noch einmal zuordnen, Start-MFA anstoßen, Viertelstunde warten... 


    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Freitag, 14. Oktober 2016 06:32
  • Guten Morgen.

    Das hilft mir jatzt aber auch nicht wirklich weiter. So wie Du schreibst ist es auch nicht. Bei der Policy die funktioniert sind die Mails auch  nicht markiert, und sind am nächsten Tag gelöscht.

    Die Policy habe ich schon x Mail überprüft. Sogar schon neu erstellt. Alle Abfragen dazu sind positiv. Sie wurd nur nicht angewandt. Ein Bekannter von mir, hier auch nicht ganz unbekannt, hat sich das auch schon angeschaut und keine Fehler gefunden.

    Gruss Ingo

    Samstag, 15. Oktober 2016 06:22
  • Moin,

    und habt ihr euch auch den MFA Log angeschaut?

    Export-MailboxDiagnosticLogs –Identity <betroffener user> -ExtendedProperties

    So mega aussagekräftig ist es freilich nicht, aber ein Vergleich zwischen dem 90-Tage-User und dem 2-Tage-User könnte vielleicht etwas zutage bringen.

    Wenn alle Stricke reißen, das Logging hoch drehen und schauen, ob was auftaucht:

    Set-EventLogLevel -id "MSExchangeMailboxAssistants\Service" -level expert 
    
    Set-EventLogLevel -id "MSExchangeMailboxAssistants\Email_Lifecycle_Assistant" -level expert 
    
    Set-EventLogLevel -id "MSExchangeMailboxAssistants\ELC Library" -level expert

    Nebenbemerkung: Wenn die 90-Tage-Löschung per Default gesetzt wird, dann werden die Messages auch nicht sichtbar markiert.


    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Samstag, 15. Oktober 2016 07:04