none
VLAN und HYPER-V RRS feed

  • Frage

  • Hi,

    ich muss ein VLAN im HYPER-V einrichten. Soweit so gut - Ablauf ist bekannt. Leider gibt es hier ein paar "grrrrs" von mir. Evtl. kann mit jemand helfen evtl. mit Workaround.

    Der HYPER-V läuft mit Intel NIC 82574EB.

    Als erstes stieß ich auf dieses hier: (Intel knows issue)

    VLANs are not supported on VMQ enabled adapters and teams
      ---------------------------------------------------------
      If you create a VLAN on a VMQ enabled adapter, the VMQ setting will
      automatically be set to disabled. The same will happen if you create a
      VLAN on a team whose member adapters have VMQ enabled.

    Heißt entweder VLAN oder VMQ - grrrr.

    Das ist schon fast ein "no go". Trotzdem würde ich es wagen. Dann kommt der bekannte 2. Hammer

    Die VLAN lassen sich nicht erzeugen, wenn schon ein virtueller Switch auf dem NIC liegt. Also virt. Switch löschen, was natürlich dazu führt, dass die NIC Konfig in allen Gästen defekt geht und man im Nachgang alles per Hand wieder einstellen muss. OK auch das wäre noch kein KO.

    Also VMQ aus, VLAN erstellt, danach versucht als erstes den oben gelöschten virtuellen Switch wieder zu erzeugen.
    Hier meldet der HYPER-V V3 nun sinngemäß: Der NIC ist Mitglied eines Teams und es kann kein virtueller Switch erzeugt werden.

    Ende der Übung. Hier komme ich nicht weiter...
    Ein HYPER-V V3 Team ist es nicht - halt nur ein Team aus NIC plus virtuellem VLAN.

    Jemand eine Idee zur Lösung?


    Danke und liebe Grüße Oliver Richter

    Montag, 10. Dezember 2012 16:48

Antworten

  • Hi,

    1) konfiguriere die VLAN au dem Hyper-V Host in dem VM-Switch und nicht in der NIC Software
    2) fuer die VM kannst Du ueber den VM-Switch mehrere Ports zur Verfuegung stellen und jedenn Port zu einem VLAN referenzieren. Lesenswert finde ich hier:
    http://www.microsoft.com/en-us/download/details.aspx?id=30160
    (Betrift zwar NIC Teaming schafft aber viele Grundlagen)
    http://www.aidanfinn.com/?p=10164
    Wegen Intel und VLAN/VMQ schau mal (evtl. trifft das auf Dich zu?):
    http://www.intel.com/support/network/sb/CS-030993.htm


    regards Marc Grote aka Jens Baier - www.it-training-grote.de - www.forefront-tmg.de - www.nt-faq.de

    • Als Antwort markiert Oliver Richter Dienstag, 11. Dezember 2012 09:46
    • Tag als Antwort aufgehoben Oliver Richter Dienstag, 11. Dezember 2012 09:46
    • Als Antwort markiert Oliver Richter Dienstag, 11. Dezember 2012 09:52
    Montag, 10. Dezember 2012 18:00
  • Vielen lieben Dank @Marc

    Das Problem ist deutlich einfacher gelöst als ich dachte. Scheinbar neige ich immer dazu, die Anforderungen viel zu komplex zu sehen und verfuddelt ich mich.

    Die Lösung ist schier trivial. Mein Ablauf zur Lösung war:

    Es gab ja schon für die benötigte interne LAN Karte einen VM- Switch. So habe ich lediglich den TMG Gast beendet, eine neue LAN Kart im VM Gast Konfig Dialog hinzugefügt (das wäre schön, wenn dies noch HotPlug ginge ;-) Diese dann VLAN aktiviert und die VLAN ID 199 zugeordnet.

    Jetzt die "neue" VLAN Karte im TMG eingerichtet und die Regeln im TMG gemacht - fertig.

    In die Problematik mit dem VMQs komme ich gar nicht rein mit dieser Variante. Also alles chic und fein.

    Damit ist das Problem geklart und auch der andere Thread.

    http://social.technet.microsoft.com/Forums/de-DE/forefrontde/thread/98d6a22d-f23c-420e-be69-dae51c36a53b


    Danke und liebe Grüße Oliver Richter

    • Als Antwort markiert Oliver Richter Dienstag, 11. Dezember 2012 09:52
    Dienstag, 11. Dezember 2012 09:51

Alle Antworten

  • Hi,

    1) konfiguriere die VLAN au dem Hyper-V Host in dem VM-Switch und nicht in der NIC Software
    2) fuer die VM kannst Du ueber den VM-Switch mehrere Ports zur Verfuegung stellen und jedenn Port zu einem VLAN referenzieren. Lesenswert finde ich hier:
    http://www.microsoft.com/en-us/download/details.aspx?id=30160
    (Betrift zwar NIC Teaming schafft aber viele Grundlagen)
    http://www.aidanfinn.com/?p=10164
    Wegen Intel und VLAN/VMQ schau mal (evtl. trifft das auf Dich zu?):
    http://www.intel.com/support/network/sb/CS-030993.htm


    regards Marc Grote aka Jens Baier - www.it-training-grote.de - www.forefront-tmg.de - www.nt-faq.de

    • Als Antwort markiert Oliver Richter Dienstag, 11. Dezember 2012 09:46
    • Tag als Antwort aufgehoben Oliver Richter Dienstag, 11. Dezember 2012 09:46
    • Als Antwort markiert Oliver Richter Dienstag, 11. Dezember 2012 09:52
    Montag, 10. Dezember 2012 18:00
  • Vielen lieben Dank @Marc

    Das Problem ist deutlich einfacher gelöst als ich dachte. Scheinbar neige ich immer dazu, die Anforderungen viel zu komplex zu sehen und verfuddelt ich mich.

    Die Lösung ist schier trivial. Mein Ablauf zur Lösung war:

    Es gab ja schon für die benötigte interne LAN Karte einen VM- Switch. So habe ich lediglich den TMG Gast beendet, eine neue LAN Kart im VM Gast Konfig Dialog hinzugefügt (das wäre schön, wenn dies noch HotPlug ginge ;-) Diese dann VLAN aktiviert und die VLAN ID 199 zugeordnet.

    Jetzt die "neue" VLAN Karte im TMG eingerichtet und die Regeln im TMG gemacht - fertig.

    In die Problematik mit dem VMQs komme ich gar nicht rein mit dieser Variante. Also alles chic und fein.

    Damit ist das Problem geklart und auch der andere Thread.

    http://social.technet.microsoft.com/Forums/de-DE/forefrontde/thread/98d6a22d-f23c-420e-be69-dae51c36a53b


    Danke und liebe Grüße Oliver Richter

    • Als Antwort markiert Oliver Richter Dienstag, 11. Dezember 2012 09:52
    Dienstag, 11. Dezember 2012 09:51