none
Win8.1 Tasksequenz Image undeployable RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    bei der Ausführung einer Win8.1 Enterprise Tasksequenz kann diese nicht komplett abgeschlossen werden. Oberflächlich gesehen scheint alles ok, man kann sich anmelden, auch die, an den Task angehängte, Software wurde installiert, jedoch ist unter dem Pfad C:\Windows\Setup\State in 9von10 Fällen in der Datei State.ini der ImageState "undeployable" und als weiterer Unterordner in Setup bleibt der Ordner scripts erhalten.

    Ich habe bereits das zu Grunde liegende Win8.1 Image neu erstellt, mit oder ohne Sprachpakete, ebenso unterschiedliche Tasksequenzen ohne zusätzliche Software.

    SCCM Version: 1702

    boot Image version 10.0.15063.0 mit APK1703 erstellt

    Verwendetes Image: Win_Ent_8.1_64Bit_English_-3_MLF_X19-84068 aus dem VLSC von Microsoft

    Im Log wird als abschließender return Code 0 zurückgegeben.

    Als Folge des "undeployable" Statuses kann ein Client-Zertifikat für SCCM nicht angewendet werden, wodurch das Software Center auf dem Client nicht aktualisiert werden kann und in der Systemsteuerung des Configuration Managers nicht alle Aktionen zur Verfügung stehen.

    Ich hoffe, Ihr könnt mir weiterhelfen.

    Beste Grüße,

    Michael Schmude

    Montag, 31. Juli 2017 09:59

Alle Antworten

  • Als Folge des "undeployable" Statuses kann ein Client-Zertifikat für SCCM nicht angewendet werden

    Woher kommt denn diese Schlussfolgerung?

    Läuft die TS sonst ohne Fehler durch? Ist etwas in den Windows Setup Logs zu sehen (\debug bzw \panther)?


    Torsten Meringer | http://www.mssccmfaq.de

    Montag, 31. Juli 2017 10:56
    Beantworter
  • Woher kommt denn diese Schlussfolgerung?


    Kann auch nur Zufall sein, aber bisher wurde das Zertifikat nie hinzugefügt, wenn der ImageState undeployable anzeigte.

    Ich habe gerade einen Client neu aufgesetzt und im NetSetup im debug-Ordner sind keine Auffälligkeiten, der Client wird in die gewünschte OU aufgenommen.

    Im wiatrace.log folgende Meldung:

    WIA: 800.804 313 0 0 [sti_ci.dll] ERROR: OnDIF_DESTROYPRIVATEDATA, Invalid argument

    Im panther-Ordner, setuperr.log:

    Error CBS Failed to load
    Session:4980_2288056687 [HRESULT=0x80070002-ERROR_FILE_NOT_FOUND]

    und im setupact.log ist der ImageState zu finden, hier traten folgende Meldungen auf:

    2017-07-31 12:40:56, Warning               SYSPRP ActionPlatform::GetValue: Error from RegQueryValueEx on value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep; dwRet = 0x2
    
    2017-07-31 03:41:39, Warning                      [setup.exe] WofEnumWimEntries failed: 0x80070001.
    
    2017-07-31 03:41:39, Warning                      [setup.exe] WofEnumWimEntries failed: 0x80070001.
    
    2017-07-31 03:41:41, Warning               SYSPRP ActionPlatform::DeleteValue: Registry value DecompressOverride to be deleted does not exist under key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide
    
    2017-07-31 03:41:41, Warning               SYSPRP ActionPlatform::DeleteValue: Registry value SysprepMode to be deleted does not exist under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
    
    2017-07-31 03:41:41, Warning    [0x0f008f] SYSPRP RunRegistryDlls:Registry key is either empty or malformed: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\SysPrepExternal\Specialize
    
    2017-07-31 03:41:42, Error                 CBS    Failed to load Session:4980_2288056687 [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]

    Montag, 31. Juli 2017 13:19
  • Nur mit den Logauszügen kommt man (= zumindest ich) nicht weiter. Es wären alle Logs (Windows plus ConfigMgr) nötig, um der Sache weiter auf den Grund zu gehen.

    Torsten Meringer | http://www.mssccmfaq.de

    Montag, 31. Juli 2017 14:12
    Beantworter
  • Nur mit den Logauszügen kommt man (= zumindest ich) nicht weiter. Es wären alle Logs (Windows plus ConfigMgr) nötig, um der Sache weiter auf den Grund zu gehen.
    Welche Log-Dateien wären denn in dem Fall interessant? Wir sind gerade erst dabei, SCCM einzusetzen und ich bin noch nicht so vertraut mit all den verschiedenen Logs und ihren Speicherorten. Bisher habe ich nur mit der CCM-Log beim Ausrollen des SCCM-Clients Erfahrung...
    Montag, 31. Juli 2017 14:25
  • %windir%\ccm\logs\*.* und \Debug und \Panther in %windir%.

    Torsten Meringer | http://www.mssccmfaq.de

    Montag, 31. Juli 2017 14:42
    Beantworter
  • Hallo,

    um ein wenig mehr an Informationen zu diesem Thema bereitzustellen.

    Das Zertifikat wird nicht über die Gruppenrichtlinie gezogen, da keine Computerrichtlinien angewendet werden können.

    Lediglich die Benutzerrichtlinien werden angewendet.

    Nach erneuten Installationen über PXE erscheint teils der Status: "IMAGE_STATE_COMPLETE" und teils nicht.

    Wir stellen derzeit ein neues Image zusammen, welches auf aktuellem Patchstand ist um einen eventuellen Fehler dadurch auszuschließen.

    Eine Bereitstellung hier im Forum, mit allen Log Dateien, ist nicht ohne weiteres möglich, da diese dem NDA des Kunden unterliegen.

    Sollte das neue Image nicht den gewünschten Erfolg bringen, werde ich die Logs, soweit möglich editieren um sie hier posten zu können.

    Grüße

    Donnerstag, 3. August 2017 05:57