none
Migration SP 2010 in eine neue WebApplication einer bestehenden SP2013 Farm

    Frage

  • Hallo und guten Tag.

    Vielleicht kann mir hier jemand Ressourcen für eine SP Migration empfehlen.

    Ich habe bis jetzt nur Step-by-Step Anleitungen gefunden, die sich mit einer SP2010 Migration in eine frisch installierte SP2013 Farm beschäftigen.

    Wir haben eine produktive SP2013 Farm, die bereits einige Web Applications hostet. Wir wollen nun Inhalte, einer noch vorhandenen SP 2010 Farm auf die SP 2013 Farm übernehmen.

    Die Inhalte der Quellfarm sollen in eine neue Web-Application auf der SP2013 Farm übernommen werden, mit getrennten Search- und Managed-Metadata-Services. Die vorhandenen Portale auf dem SP 2013 haben keinerlei Berührungspunkte mit dem zu migrierenden Portal, daher soll dieses komplett autark in der 2013 Farm laufen.  

    Für eine Migration von 2010 in eine unberührte 2013 Farm gibt es genug Anleitungen, aber für dieses Szenario habe ich kaum etwas gefunden.

    Grüße Antonio

    Mittwoch, 21. März 2018 15:03

Antworten

  • Hi Antonio,
    zuerst sind natürlich die benötigten Service-Anwendungen zu migrieren. Bezüglich MetaDataService ist dafür eine weitere MetaDataService-Anwendung zu erzeugen, die aber die von SharePoint 2010 wiederhergestellte Service-Datenbank nutzt. Mit der Erzeugung der neuen MetaDataService-Anwendung wird die zugewiesene "alte (2010)" Datenbank automatisch migriert. Wenn dann in der CA diese neue (zweite) MetaDataService-Anwendung aufgerufen wird, sind dort auch nur die alten Termini (vom 2010) enthalten. Deine Schilderung lässt vermuten, Dass Du bei der Erstellung der neuen (zweiten) MetaDataService-Anwendung die Datenbank der ersten vorhandenen MetaDataService-Anwendung genutzt hast und nicht die vom 2010 wiederhergestellte Datenbank. Also, bei der Erstellung der neuen MetaDataService-Anwendung musst Du bei der Erstellung über die CA-Oberfläche buchstabengenau die Bezeichnung der wiederhergestellten alten Datenbank angeben. Bei den Standardeinstellungen wird die vorhandene Datenbank des 2013 genutzt, wenn da auch die Standardeinstellungen genutzt wurden.


    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks

    Donnerstag, 22. März 2018 10:52

Alle Antworten

  • Hi Antonio,
    das Szenario ist genau das gleiche. Andere WebAnwendungen haben mit dem Upgrade nicht zu tun.

    Wo siehst Du da Probleme?


    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks

    Mittwoch, 21. März 2018 16:53
  • Hi Peter,

    Danke für deine Antwort.

    Also, wenn das so ist, dann bin ich schon mal beruhigt.

    Ich versuchte zum Beispiel auf der 2013 Testumgebung als ersten Schritt eine neue Managend Metadaten Service Application anzulegen. Dazu habe ich erst die passende MM-Datenbank aus der 2010 Umgebung auf dem SQL der 2013 Farm rückgesichert.

    Anschließend eine neue Service Application angelegt und auf die rückgesicherte 2010-DB verwiesen. Er hat ohne Fehler die neue Service Application + Connection angelegt. Nur wenn ich jetzt in der Central Administration die neue SA aufrufe, sehe ich nur die Terms, die schon vorher in der 2013 Farm vorhanden waren.

    Da das zwar so ohne Fehler klappte, ich aber jetzt die rückgesicherten Metadaten nirgendwo finde, hat mich zweifeln lassen, ob ich wirklich auch dem Weg bin. Wie gesagt, ich habe nur Anleitungen für die Migration in eine frische Farm gefunden und Nichts, wo beispielsweise das Thema mit zusätzlichen SA behandelt wird. Wenn ich das Problem mit den SA gelöst habe, geht es vielleicht auch ganz straight weiter, wer weiss.

    Beste Grüße Antonio

    Donnerstag, 22. März 2018 10:27
  • Hi Antonio,
    zuerst sind natürlich die benötigten Service-Anwendungen zu migrieren. Bezüglich MetaDataService ist dafür eine weitere MetaDataService-Anwendung zu erzeugen, die aber die von SharePoint 2010 wiederhergestellte Service-Datenbank nutzt. Mit der Erzeugung der neuen MetaDataService-Anwendung wird die zugewiesene "alte (2010)" Datenbank automatisch migriert. Wenn dann in der CA diese neue (zweite) MetaDataService-Anwendung aufgerufen wird, sind dort auch nur die alten Termini (vom 2010) enthalten. Deine Schilderung lässt vermuten, Dass Du bei der Erstellung der neuen (zweiten) MetaDataService-Anwendung die Datenbank der ersten vorhandenen MetaDataService-Anwendung genutzt hast und nicht die vom 2010 wiederhergestellte Datenbank. Also, bei der Erstellung der neuen MetaDataService-Anwendung musst Du bei der Erstellung über die CA-Oberfläche buchstabengenau die Bezeichnung der wiederhergestellten alten Datenbank angeben. Bei den Standardeinstellungen wird die vorhandene Datenbank des 2013 genutzt, wenn da auch die Standardeinstellungen genutzt wurden.


    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks

    Donnerstag, 22. März 2018 10:52