none
Fehlermeldung beim Sortieren - warum? RRS feed

  • Frage

  • Hallo,

    wir erhalten eine Fehlermeldung im CRM 4.0 Online, wenn wir nach Postleitzahl (aufsteigend) sortieren wollen. Es ist eine selbst erstellte Ansicht und die Fehlermeldung erhält nur eine Benutzerin. Der Admin nicht - aber ich habe auch schon die Berechtigungen der Benutzerin angepasst und es hat nichts geholfen.

    Fehlermeldung:

    "Es ist ein Fehler aufgetreten. Wiederholen Sie diese Aktion... oder wenden Sie sich an den Admin."
    Nach Bestätigung mit OK steht in der Ansicht: "Fehler bei der Rasteraktualisierung"

    Vielen Dank im Voraus

    Viele Grüße

    Frank


    Tschö Frank

    Montag, 28. Januar 2013 10:10

Antworten

  • Hallo Frank,

    die Ursache kann auch ein Feld sein, in dem durch Copy und Paste ein verstecktes Sonderzeichen hinzugefügt wurde.

    Ich würde an deiner Stelle so vorgehen, das ich die Suche immer weiter einschränken würde, bis ich den fehlerhaften Datensatz ermittelt habe. Dann würde ich mit dem SQL Server Manager diesen Datensatz direkt im SQL Server untersuchen und den Fehler beheben.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website XING LinkedIn Facebook Twitter

    • Als Antwort markiert moccacino Sonntag, 3. Februar 2013 21:47
    Dienstag, 29. Januar 2013 11:47
  • Hallo Frank,

    das sieht mir sehr nach einem Copy und Paste Fehler aus. Da wurde was in das Feld kopiert, mit dem das CRM nicht zurechtkommt.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website XING LinkedIn Facebook Twitter

    Dienstag, 29. Januar 2013 16:20

Alle Antworten

  • Hallo Frank,

    Erläutere mir bitte den Begriff "CRM 4.0 Online" - ich kann auch falsch liegen, aber meines Wissens nach gibt es MS CRM von Microsoft erst ab der Version 2011 gehostet!?

    Wenn du irgendwie Zugriff auf den Server hast aktiviere das Logging am CRM-Server und kontrolliere das dadurch erstellte Log-File (http://community.dynamics.com/product/crm/crmtechnical/b/crmjimwang/archive/2010/03/08/download-58-crm-4-0-diagnostics-tool-alternative-link.aspx)

    Liebe Grüße,

    Andreas


    Andreas Buchinger
    Microsoft Dynamics Certified Technology Specialist
    MCPD: SharePoint Developer 2010

    Montag, 28. Januar 2013 11:57
  • Hallo,

    CRM Online gibt es auch schon in der Version 4.0, allerdings nur im amerikanischen Raum, nicht in EMEA


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website XING LinkedIn Facebook Twitter

    Montag, 28. Januar 2013 12:09
  • Das ist ein gehostetes CRM Microsoft Dynamics CRM 4.0 (4.0.7333.3822 - alles auf deutsch). Auf dem Server gab es keinen Eintrag...


    Tschö Frank

    Montag, 28. Januar 2013 12:25
  • Hallo Frank,

    Es kommt sicher keine Fehlermeldung, wenn du am Server das Tracing aktivierst und dann den Vorgang (Sortierung) wiederholst?!

    Wenn du der betroffenen Benutzerin testweise die Admin-Rolle zuweist funktioniert die Sortierung auch nicht?! Hast du schon versucht den IE-Cache am Client der Benutzerin zu leeren?

    Liebe Grüße,

    Andreas

    @Michael: Danke für die Info bezüglich CRM 4.0 Online in US - die Info ist damals an mir irgendwie spurlos vorbeigegangen! :-)


    Andreas Buchinger
    Microsoft Dynamics Certified Technology Specialist
    MCPD: SharePoint Developer 2010


    Montag, 28. Januar 2013 12:35
  • Hallo Andreas,

    unser Admin hat mich den Vorgang wiederholen lassen und nichts auf dem Server sehen können.

    Der Benutzerin habe ich auch schon Admin-Rechte gegeben und den Cache gelöscht und schon andere Rechner zum Zugreifen und Ausprobieren verwendet... immer die gleiche Fehlermeldung beim aufsteigend sortieren... beim absteigend sortieren gibt es keine Fehlermeldung

    Ich habe jetzt festgestellt, dass es nichts mit der Sortierung zu tun hat, sondern wahrscheinlich mit dem Anzeigen von bestimmten Elementen. Beim Blättern bekomme ich die Fehlermeldung auch.

    Wir schauen morgen noch mal auf den Server und versuchen es darüber einzugrenzen... dann schreib ich morgen noch etwas dazu

    Vielen Dank schon mal!


    Tschö Frank

    Montag, 28. Januar 2013 13:44
  • Hallo Frank,

    Ich tippe in diesem Fall auf ein Attribut, dass einen fehlerhaften Wert enthält - meine Vermutung ist hier ein Lookup, dass als Wert '00000000-0000-0000-0000-000000000000' enthält.

    Solch einen Wert findest du leider nur direkt in der Datenbank - wobei ich nicht weiß, ob du diese Möglichkeit überhaupt hast?!

    Liebe Grüße,

    Andreas


    Andreas Buchinger
    Microsoft Dynamics Certified Technology Specialist
    MCPD: SharePoint Developer 2010

    Dienstag, 29. Januar 2013 07:50
  • Hallo Andreas,

    unser Admin hat zwar Zugriff auf die Datenbank, aber kennt sich mit der Struktur genausowenig aus wie ich.

    Wo genau (und wie) können wir nach diesem Wert suchen, wenn der Fehler bei den Firmen auftritt?

    Vielen Dank im Voraus


    Tschö Frank

    Dienstag, 29. Januar 2013 10:48
  • Hallo Frank,

    die Ursache kann auch ein Feld sein, in dem durch Copy und Paste ein verstecktes Sonderzeichen hinzugefügt wurde.

    Ich würde an deiner Stelle so vorgehen, das ich die Suche immer weiter einschränken würde, bis ich den fehlerhaften Datensatz ermittelt habe. Dann würde ich mit dem SQL Server Manager diesen Datensatz direkt im SQL Server untersuchen und den Fehler beheben.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website XING LinkedIn Facebook Twitter

    • Als Antwort markiert moccacino Sonntag, 3. Februar 2013 21:47
    Dienstag, 29. Januar 2013 11:47
  • Hallo Michael,

    wir haben jetzt herausgefunden, dass der Fehler im Feld Beschreibung liegen muss, weil man keine Fehlermeldung bekommt sobald das Feld nicht mehr in der Ansicht ist.

    Wir brauchen es aber in der Ansicht und suchen deshalb im Beschreibungsfeld nach dem Fehler - wenn wir was gefunden haben, dann melde ich mich


    Tschö Frank

    Dienstag, 29. Januar 2013 16:08
  • Hallo Frank,

    das sieht mir sehr nach einem Copy und Paste Fehler aus. Da wurde was in das Feld kopiert, mit dem das CRM nicht zurechtkommt.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website XING LinkedIn Facebook Twitter

    Dienstag, 29. Januar 2013 16:20
  • Hallo Michael,

    vielen Dank für die Antworten - ich habe mit der erweiterten Suche den Datensatz eingekreist und gefunden. Es waren tatsächlich merkwürdige Sonderzeichen, die man erst im Texteditor sehen konnte, als ich den Inhalt da rein kopiert hab. So konnte ich die störenden Zeichen finden und löschen.


    Tschö Frank

    Sonntag, 3. Februar 2013 21:50