none
TMG 2010, VPN mit falschem DNS Server RRS feed

  • Frage

  • Hallo,

    folgende Ausgangssituation:

    Client (Win7) -> VPN -> Firmennetzwerk A -> TMG -> Testnetzwerk B

    Wenn ich mit dem Client nun einen VPN-Tunnel zum TMG ins Testnetz "innerhalb" des FirmenVPNs machen möchte, bekommt der zweite VPN Tunnel immer einen DNS-Server des FirmenVPNs an erster Stelle. Also:

    1. DNS-Server: IP DNS-Server Firmennetzwerk
    2. DNS-Server: IP DNS-Server Testnetzwerk

    Somit ist natürlich keine Namensauflösung innerhalb des Testnetzes möglich. Wie bekomme ich das hin, dass in dem TestnetzwerkVPN der Firmen-DNS-Server nicht auftaucht?

    Bisher probiert: DNS-Server des TMG ist nur noch der des Testnetzes, im TMG die DNS-Server manuell eingetragen, in der VPN-Verbindung die DNS-Server manuell eingetragen.

    Grüße,
    Robert

    Mittwoch, 23. März 2011 10:11

Alle Antworten

  • Hallo Robert,

    geh mal ins Netzwerk und Freigabecenter. Dort dann auf Adaptereinstellungen ändern und dann über die Alt-Taste ins Menü Erweitert -> Erweiterte Einstellungen.

    Dort siehst du die Verbindungen Lan-Verbindungen und RAS-Verbindungen. Schiebe die RAS-Verbindungen an erster stelle, dann sollte der DNS-Server vom Testnetzwerk an erster Stelle stehen.

    Gruß

    Christian

     


    Christian Groebner MVP Forefront
    Mittwoch, 23. März 2011 10:15
    Moderator
  • Hallo Christian,

    Danke für Deine Antwort. Sorry für meine verspätete Reaktion, ich musste das Problem für eine Weile ruhen lassen, jetzt bin ich aber wieder "dran".

    Leider ist an der Stelle nur *ein* Punkt mit RAS-Verbindungen, diesen kann ich nicht weiter aufdröseln. Ich benötige, wie im Eingangspost beschrieben, eine Reihenfolge der VPN-Verbindungen untereinander.

    Grüße,

    Robert


    • Bearbeitet Robi-Wan Montag, 5. September 2011 14:28
    Montag, 5. September 2011 12:02
  • Hi Robert,

    du kannst VPN Verbindungen nur unterschiedlich prioritisieren, wenn es unterschiedliche VPN Protokolle sind. Hierzu musst du die NDISWAN Bindingorder in deiner Registry anpassen (keine GUI vorhanden)

    Du findest den Key unter...

    HKLM\SYSTEM\CurrentCS\services\NdisWan\Linkage\Bind (REG_Multi_SZ)

    \Device\{76336446-AB0D-4DA9-B76F-839501DEA1E3} = IKEv2
    \Device\{78032B7E-4968-42D3-9F37-287EA86C0AAA} = RAS Async Adapter
    \Device\{8E301A52-AFFA-4F49-B9CA-C79096A1A056} = WAN Miniport (PPPOE)
    \Device\{DF4A9D2C-8742-4EB1-8703-D395C4183F33} = WAN Miniport (PPTP)
    \Device\{E43D242B-9EAB-4626-A952-46649FBB939A} = WAN Miniport (L2TP)
    \Device\{71F897D7-EB7C-4D8D-89DB-AC80D9DD2270} = WAN Miniport (SSTP)

    ... bin mir derzeit nicht mehr ganz sicher, ob die Objekt-IDs auf allen Clients immer die gleiche ist. Schau von dem her mal nach, ob die Werte bei dir die gleichen sind? Falls nicht, dann orientiere dich an der Reihenfolge der Zeilen, da die effektive NDISWAN Default-Binding-Order immer gleich sein sollte...

    BTW: Alternativ kannst du in beiden VPN Verbindungen den DNS per Hand auf den von dir gewünschten Wert abändern. In deinem Szenario evtl. die einfachere Lösung. Ajo, bei einer Testumgebung könnte auch ein HOSTS file herhalten, oder?

    BTW2: Hab die oben genannten Keys schon lange nicht mehr angefasst. Von dem her würde ich mich über einen Erfahrungsbericht wie es mit aktuellen OS/SP ausschaut freuen^^

    -Kai

     

    Montag, 5. September 2011 18:36