none
windows 2012 server-sicherung auf nas funktioniert nicht (unzulässige funktion) RRS feed

  • Allgemeine Diskussion

  • hi,

    auf meinem windows 2012 datacenter funktioniert die server-sicherung auf eine NAS nicht. die einzige fehlermeldung die ich angezeigt bekomme bzw. die im logfile steht (c:\windows\logs\windowsserverbackup\) ist folgende:

    Fehler beim Sichern des Volumes "\\?\Volume{465eee26-6267-18e3-93f3-806e6fde6963}\": Unzulässige Funktion.

    ich habe versucht es über das grafische wbadmin tool zu starten aber auch mittels cmd.

    wenn ich die sicherung auf eine lokale partition sichere funktioniert es, würde aber wenig sinn machen..

    ist dieses phänomen jemand anders auch bekannt?

    Donnerstag, 19. Dezember 2013 10:50

Alle Antworten

  • > ist dieses phänomen jemand anders auch bekannt?
     
    Ja. Tausche das NAS aus.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Donnerstag, 19. Dezember 2013 12:13
  • das ist nicht wirklich die antwort die ich mir erhoffte :)
    Donnerstag, 19. Dezember 2013 15:27
  • > das ist nicht wirklich die antwort die ich mir erhoffte :)
     
    ...klar, aber es ist leider so. Und immerhin steht doch Weihnachten vor
    der Tür :-)
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Donnerstag, 19. Dezember 2013 16:13
  • Am 19.12.2013 schrieb stegfeld:

    auf meinem windows 2012 datacenter funktioniert die server-sicherung auf eine NAS nicht. die einzige fehlermeldung die ich angezeigt bekomme bzw. die im logfile steht (c:\windows\logs\windowsserverbackup\) ist folgende:

    Hat die Sicherung auf die NAS denn schon mal funktioniert?


    Servus
    Winfried

    Gruppenrichtlinien
    WSUS Package Publisher
    HowTos zum WSUS Package Publisher
    NNTP-Bridge für MS-Foren

    Donnerstag, 19. Dezember 2013 18:46
  • die windows server-sicherung nicht,

    es läuft jedoch eine andere backupsoftware (veeam) und diese sichert ohne probleme auf die NAS (QNap)

    Freitag, 20. Dezember 2013 10:36
  • nein, problem besteht weiterhin..
    Dienstag, 7. Januar 2014 08:40
  • Am 07.01.2014 09:40, schrieb stegfeld:

    nein, problem besteht weiterhin..

    Hasdt du denn zum Test die Sicherung einfach mal ein paar Tage auf eine Windows Share gemacht, um dein NAS als Fehlerquelle auszuschliessen?

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Dienstag, 7. Januar 2014 09:18
  • Die zeitgesteuerte Vollsicherung (inkl. Versionsverwaltung) über die GUI hat afaik auch bei älteren Windows Versionen nicht funktioniert, wenn das Ziel eine Netzwerkfreigabe ist. Ich glaube das geht nur, wenn das Netzwerkziel eine Windowsfreigabe ist. Vielleicht gibt es da wichtige Unterschiede zwischen CIFS und SMB.

    Was relativ schmerzfrei funktioniert ist die Einmalsicherung. Leider kommt man mit wbadmin da auch nicht viel weiter. Zumindest sind zeitgesteuerte Einmalsicherungen in unterschiedliche Ordner auf einer Netzwerkfreigabe möglich.

    Als kostenfrei Alternative kann ich AOMEI Backupper empfehlen. Es hat funktional zwar einige Defizite. Aber ist sehr zuverlässig, schnell und sogar für den komerziellen Gebrauch kostenlos.

    Mittwoch, 15. Januar 2014 17:50
  • Schaut so aus, als ob die NAS kein SMB 3.0 kann (hat nichts mit der Samba Version zu tun, heist Samba 3.X ist nicht gleich SMB 3.0).

    Siehe auch hier

    Gruß

    Update: vielleicht hilft dem ein oder anderen das hier noch weiter:

    http://newyear2006.wordpress.com/2014/01/28/gefhrliche-nas-backups-mit-windows-7-windows-8-windows-8-1-sowie-server-2008-r2-server-2012-und-server-2012-r2-und-fehlercode-0xc03a0005-mit-meldung-die-version-untersttzt-diese/



    • Bearbeitet tcr82 Montag, 7. April 2014 11:58
    Mittwoch, 2. April 2014 13:10
  • @orangutanklaus: aomei ist auf windows server leider nicht lizenzfrei

    auf meiner NAS läuft samba in der version 3.6

    ich habe es bei einem anderen kunden ausprobiert, ebenfalls auf eine QNap, hier hat es einwandfrei funktioniert, man musste lediglich drauf achten, dass der benutzer für die Windows-Freigabe der QNap auch lokal am Server als User angelegt ist..

    der einzige unterschied der beiden kunden ist, dass der eine backupserver ein eigenständiger physischer server ist und der bei dem es nicht funktioniert ein virtualisierter (VMware)..

    Donnerstag, 15. Mai 2014 15:29
  • Die Frage ist zwar schon etwas länger her aber hier eine andere Möglichkeit zur Lösung des Problems.

    Je nach dem welches NAS von QNAO du besitzt, unterstützt es iSCSI. Ein iSCSI-LUN wird im Speichermanager des QNAP angelegt.

    Ein s. g. iSCSI-LUN kann in Windows 7,8, 10 und auch in den Serverversionen mit Hilfe des iSCSI-Initiators (Bestandteil von Windows) verbunden werden und stellt sich in der Datenträgerverwaltung als vollwertige Fesplatte,  kann partitioniert und mit Laufwerksbuchstaben versehen wie eine im Server eingebaute Platte verwendet werden. Z. B. darauf die Serverordner ablegen und freigeben, in Speicherpools einbinden, und ein toller Vorteil von iSCSI gegenüber einer Freigabe ist, dass die Daten darauf auch vom Server indiziert werden, was bei einer Netzwerfreigabe eines Linux-NAS ja nicht der fall ist.

    Nachteile:

    Das LUN kann i. d. R. nur in einen PC oder einen Server eingebunden werden. Ein gleichzeitiger Zugriff von zwei PCs ist nicht möglich. Das stört aber i. d. R. nicht, weil der Windowsserver der einige ist, der darauf zugreift und die Clients sich die Daten über die Freigaben des Servers holen.

    Wird das LUN für die Serversicherung verwendet und der Server muss im Ernstfall mit diesem Backup komplett wieder hergestellt werden, dürfte dies kompliziert werden, da der Server dann mit einem Rettungsbootmedium gestartet wird, der ohne weiteres keine Verbindung zum LUN aufbauen kann.

    Donnerstag, 2. April 2015 11:28
  • iSCSI war für uns keine Lösung, da wie schon erwähnt das erst mal über einen Server bereit gestellt werden muss. Im Notfall kann dies evtl. mal nicht gewährleistet sein (da dieser Server vielleicht nicht funktioniert). Außerdem ist es von der Performance her besser, wenn nicht alles noch über ein zusätzliches Glied laufen muss (es werden 5 Server gesichert).

    Ich habe gerade gestern die Antwort auf das Problem gefunden.

    Also wir verwenden eine QNAP (aktuellste FW) und dort hat folgendes zum Erfolg geführt:

    In der smb.conf auf der Freigabe "strict allocate = yes" hinzufügen UND zusätzlich die SMB Version auf Version 1.0 zurück schalten (über das Webinterface).

    Evtl. muss noch der Server direkt die Rechte auf die Freigabe haben, aber ob das wirklich nötig war wollte ich nicht mehr austesten.

    Damit hat es dann endlich wieder funktioniert. Verwirrend war aber: Auf einigen Servern hat das Backup ohne SMB 1.0 geklappt, auf anderen wiederum nicht (alle haben Server 2012 R2 drauf).

    Aber wie gesagt, es funktioniert jetzt endlich wieder.



    • Bearbeitet tcr82 Donnerstag, 2. April 2015 12:51
    Donnerstag, 2. April 2015 12:49
  • ?? Was ist das denn für eine Antwort... vom Profi wahrscheinlich.

    Der Fehler hat nichts mit der Qualität des NAS zu tun.

    Meistens Konfigurations-Probleme bei den NAS-Laufwerken -> 2012 braucht eine niedrigere Version von SMB (x < 2). 2012 R2 kommt mit höheren Varianten klar (x >= 2)

    Habe diese Fehler noch bei 2 Maschinen, die anderen 6 können ohne Probleme mit den selben Login-Daten sichern.

    Betriebssystem und Systemkonfiguration ähnlich.

    Mögliche Fehler können System, Festplatten bzw. Dateisystemfehler sein.

    chkdsk /R /F /X

    und

    sfc /scannow

    können helfen.

    Nach weiteren Stunden mit dem Windows-Backup habe ich die beiden weiteren Störenfriede gefunden. 

    • Exchange 2013 auf CU11 -> Backup funktioniert
    • SQL DB von 2012 auf 2014 -> Backup funktioniert


    Anmerkung zu NAS
    : Unter Umständen kann es helfen bei 2012 R2 die Unterstützung für die SMB 1.0/CIFS-Dateifreigabe... zu installieren (Features)

    Anmerkung zum SQL Server: Bei MSSQL 2012 wird es wahrscheinlich auch ein SP3 tun.

    Anmerkung zum Exchange Update: Bei der Ausführung des Befehls 

    vssadmin list writers

    sind mir Fehler im Exchange Writer aufgefallen (Stabil -> Wiederholbarer Fehler) 



    Donnerstag, 24. Dezember 2015 20:46