none
Fehler bei CimMethode RRS feed

  • Frage

  • Hallo Zusammen,

    ich bin Powershell Anfänger und suche Hilfe, denn ich finde den Fehler nicht:

    Invoke-Command -ComputerName 192.168.56.2 {$allowts=Get-CimClass -Namespace root\cimv2\TerminalServices -ClassName Win32_TerminalServiceSetting;Invoke-CimMethod -ClassName $allowts -MethodName SetAllowTSConnections -Arguments @{AllowTSConnections=1;ModifyFirewallException=1}}-Credential WIN08_TEsTPC03\user03

    Das ROOT/cimv2/TerminalServices:Win32_TerminalServiceSetting-Argument enthält Zeichen, die im ClassName-Parameter nicht zulässig sind. Geben Sie ein gültiges Argument an, und führen Sie den Befehl dann erneut aus.
        + CategoryInfo          : NotSpecified: (:) [Invoke-CimMethod], ArgumentException
        + FullyQualifiedErrorId : System.ArgumentException,Microsoft.Management.Infrastructure.CimCmdlets.InvokeCimMethodCommand
        + PSComputerName        : 192.168.56.2

    Laut Microsoft gibt es die Methode "SetAllowTSConnections"... Wo ist mein Denkfehler bzw. was wäre am Argument falsch?

    Vielen Dank im Voraus!

    Mittwoch, 3. Januar 2018 23:39

Antworten

  • Hallo BOfH_666,
    vielen Dank für deine konstruktive Kritik und den Tipp auch bezüglich Script... Ja ich möchte auf einem entfernten Computer RDP aktivieren und hatte es im Rahmen bezüglich Umgang mit WMI und CIM als Übungsaufgabe gesetzt :). Ich habe mir nochmal meine Befehlszeile angeschaut und korrigiert.

    Ich lag doch nicht so falsch und nun funktioniert es auch…

    Invoke-Command -ComputerName 192.168.56.2 -ScriptBlock
    {
    Get-CimInstance -ClassName Win32_TerminalServiceSetting
    -Namespace root\cimv2\TerminalServices |
    Invoke-CimMethod -MethodName SetAllowTSConnections
    -Arguments @{AllowTSConnections=1;ModifyFirewallException=1}
    } -Credential WIN08_TEsTPC03\user03


    Donnerstag, 4. Januar 2018 10:28

Alle Antworten

  • Hmmm .... Du hast ein paar Fehler in Deinem Code ... aber vorher erstmal - wenn Du hier Code postest, solltest Du den mit der entsprechenden Option im Editor unbedingt als Code formatieren. So vermeidest Du ungewollte Zeilenumbrüche und der Code ist besser zu lesen und zu kopieren usw. Unabhängig davon solltest Du den Code entsprechend formatieren/einrücken. So wäre Dir vielleicht auch aufgefallen, dass Du einen Klammerfehler in Deinem Code hast.  ;-)
    Wenn ich mich nicht irre, möchtest Du remote den Remotezugriff aktivieren, richtig? Eine empfehlenswerte Methode wäre, das über Gruppenrichtlinien zu konfigurieren. Wenn es unbedingt ein Script sein soll, könntest Du das hier mal probieren: Enable-RDPAccess.ps1.

    Wenn Du öfter mit Powershell arbeiten möchtest, empfehle ich Dir, erstmal mit Grundlagen von Powershell anzufangen: Learn PowerShell: Microsoft Virtual Academy - Getting Started with Microsoft PowerShell.


    Best regards,

    (79,108,97,102|%{[char]$_})-join''


    • Bearbeitet BOfH-666 Donnerstag, 4. Januar 2018 00:13
    Donnerstag, 4. Januar 2018 00:11
  • Hallo BOfH_666,
    vielen Dank für deine konstruktive Kritik und den Tipp auch bezüglich Script... Ja ich möchte auf einem entfernten Computer RDP aktivieren und hatte es im Rahmen bezüglich Umgang mit WMI und CIM als Übungsaufgabe gesetzt :). Ich habe mir nochmal meine Befehlszeile angeschaut und korrigiert.

    Ich lag doch nicht so falsch und nun funktioniert es auch…

    Invoke-Command -ComputerName 192.168.56.2 -ScriptBlock
    {
    Get-CimInstance -ClassName Win32_TerminalServiceSetting
    -Namespace root\cimv2\TerminalServices |
    Invoke-CimMethod -MethodName SetAllowTSConnections
    -Arguments @{AllowTSConnections=1;ModifyFirewallException=1}
    } -Credential WIN08_TEsTPC03\user03


    Donnerstag, 4. Januar 2018 10:28
  • Hallo D.,

    Großartig!  ;-) Wenn Du jetzt noch die beiden "unerlaubten" Zeilenumbrüche korrigierst, kannst Du ausnahmsweise mal Deinen eigenen Post als Antwort markieren. Dann finden Andere, die das gleiche oder ein ähnliches Problem haben die Lösung schneller.


    Best regards,

    (79,108,97,102|%{[char]$_})-join''

    Donnerstag, 4. Januar 2018 15:27