none
Excel 2010 öffnet Dateien nur auf den 2ten Öffnungsversuch RRS feed

  • Allgemeine Diskussion

  • Hallo,

    ich habe beim Kunden das Problem das er, wenn er eine Excel Datei öffnet, er die Meldung bekommt, das die Datei durch den Benutzer "er selber/ Sein Name" bereits geöffnet ist.

     

    Excel bietet das übliche öffnen , schreibgeschützt, Benachrichten , Abbrechen an.

    Wenn ich hier abbreche und sofort die Datei nochmals öffne klappt es ohne Probleme.

     

    Die Dateien können nicht in verwendung sein, es sind seine eigenen Dokumenten ohne Freigabe.Problem besteht bei allen Exceltabellen.

     

    Da ich schonn übliche gestestet habe, stehe ich nun vor einer vollständigen und komplexen Neuinstallation des Systems.

     

    Ich hoffe es kann mir jemand einen Tipp.

     

    Meine Versuche seither:

    ·         Antivirus runter,

    ·         Dateien umbenannt,

    ·         Makros alle erlaubt,

    ·         alle Sicherheitsfeature in office deaktiviert,

    ·         Reparatur von Office 2010,

    ·         Fixit vom MS

    ·         Null Änderung am System.

     

    Viele Grüße

    Andreas

    • Bearbeitet Alex Pitulice Donnerstag, 10. November 2011 08:41 Paragraph Bearbeitung
    • Typ geändert Alex Pitulice Mittwoch, 7. Dezember 2011 09:33 Warten auf Feedback
    Freitag, 4. November 2011 08:16

Alle Antworten

  • Hallo,

    da die Datei lokal auf dem Rechner liegt kann ich mir nur zwei Möglichkeiten vorstellen.

    Die Datei wurde einmal unsachgemäß geschlossen und dadurch konnte das owner-file nicht gelöscht werden. (Das owner-file ist gekennzeichnet mit einer Tilde ~ und einem Dollarzeichen $ und wird temporär (sobald die Datei geöffnet wurde) im selben Ordner angezeigt in der auch die eigentliche Datei liegt.)

    Die andere Möglichkeit ist, dass eine zweite Instanz von Excel im Hintergrund läuft und das Dokument immer noch geöffnet ist.

    Zunächst würde ich einmal die Datei schreibgeschützt öffnen und nachdem sie geöffnet wurde wieder zu schließen. (In manchen Fällen wird dadurch das owner-file gelöscht). Anschließend nochmal öffnen. Kommt dann noch die gleiche Meldung?

    Ansonsten in das Verzeichnis wechseln wo die zu öffnende Datei liegt. Wird hier das owner-file angezeigt (~$'derselbe Dateiname')?

    Wenn ja, dann bitte mal Excel schließen und das owner-file (~$) manuell löschen.

    Wenn sich die Datei nicht löschen lässt, dann mal über den Task-Manager -> Prozesse schauen ob die excel.exe noch angezeigt wird -> wenn ja Prozess beenden.

    Zum Schluss das gewünschte Dokument öffnen.

    Ich hoffe damit konnte ich helfen.

    VG

    Martin

     

    Freitag, 4. November 2011 14:55
  • Hallo Martin,

    vielen Dank für diese Info´s.

    Das betrifft alle Exceldateien auf den Notebook.

    Nehme ich diese Dateien auf ein anderes Office 2010, klappt alles prima. Daher schliesse ich eine Filedefekt aus.

    Die Files mit dem $ Zeichen verschwinden nach dem schliessen der Dateien wieder, so wie es sein soll.

    Auch ist im Hintergrund ist der excel.exe Prozess geschlossen.

    Trotzdem immer das gleich Problem.

    Danke u VG

    Andreas

     


    Freitag, 4. November 2011 15:50
  • Hallo Andreas,

    Prüfe mal diesen Registry-Eintrag:

    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]

    Normalerweise soll er so aussehen: "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /dde

    Teste auch die Einstellung mit %1 statt /dde: "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" %1

    Exportiere erst mal vorsichtigerweise die originale Einstellung (mit /dde) damit Du ein Backup hast, dann mach die Änderung.

    Viele Grüße,

    Bogdan


    Ich bin gerne bei den Foren. Es kommt von Herzen. Es wird aber keine implizite oder sonstige Garantie für die geposteten Antworte / Informationen gewährt. Hier auch die Forenregeln.
    Montag, 7. November 2011 15:25
  • Hallo Bodgan,

    die Änderung des Regeintrages hat leider nicht gebracht.

    Ber mir ist aufgefallen, wenn ich nicht ganz so schnell mich durch die Dateistrukturen klicke, dann geht es auf Anhieb.

    Irgendwie werden die Dateien zu langsam geladen ?!? Das deutet evtl. auf einen HArdware defekt hin. Evtl ist die SSD im Eimer.

    Niochmals danke für die INfo.

    Neue Erkentnisse werde icvh natürlich posten.

    VG Andreas

     

    Dienstag, 8. November 2011 15:44
  • Hallo Andreas,

    könntest Du probieren Excel im Safe Mode (/s Switch) zu starten, und danach die Dateien mit Open File zu öffnen?  Vielleicht klappt es so :)

    Manuell starten

    1.Klicken Sie auf Start und anschließend auf Ausführen.

    2.Klicken Sie auf Durchsuchen, und suchen Sie den Ordner, in dem Microsoft Excel installiert ist (s. o.).

    3.Wenn Sie die Datei "Excel.exe" gefunden haben, markieren Sie sie, und klicken Sie auf Öffnen.

    4.Geben Sie am Ende des Pfads im Feld Öffnen ein Leerzeichen und dann /s ein. Die Zeile sollte in etwa so aussehen:"C:\Programme\Microsoft Office\Office\Excel.exe" /s

     

    Mehr hier: Beschreibung der Startoptionen für Excel

    Gruss,

    Alex

    Donnerstag, 10. November 2011 09:03