none
OWA und Exchange Zugriff von extern auf SBS 2008 funktioniert nicht RRS feed

  • Frage

  • <object height="1" id="plugin0" style=";z-index:1000;" type="application/x-dgnria" width="1"><param name="tabId" value="{E7D0E2EA-2A45-439E-9710-E321C508841B}" /></object>

    Hallo,

    nun bin ich enlich einigermaßen fit in SBS 2011 - Habe aber einen Kunden, bei dem SBS 2008 installiert ist und den ich von einem "Frickler" übernommen habe... Irgendwie geht da nichts! Ich habe bei 1&1 entsprechende remote.domain.com und autodiscover.domain.com mit jeweiligem CNAME auf die feste IP Adresse angelegt und auch im Vigor Router die Portweiterleitungen für 443,80, 987, 143 und 25 eingerichtet. wenn ich die remote.domain.com von mir aus dem Büro aufrufe kommt nur "Serverfehler - 404 - Datei oder Verzeichnis nicht gefunden". Auch intern am Server selbst und an den Clients das gleiche. Die Companyweb - Seite funktioniert jedoch! Irgedwie ist im IIS Manager auch alles komplett anders als beim 2011, sodass ich auch keine Einstellungen mit anderen vergleichen kann... Die SBS-Consolen Funktion "Beheben von Netzwerkproblemen habe ich auch schon ausprobiert. Damit habe ich auch neues Zertifikat hinzugefügt. Da auch schon das nächste Problem: Unter Public - öffentliche Downloads sind die installcertificate.exe und das Zertifikat als "einzelne Datei" nicht vorhanden! Wie kann ich das neu erstellen? Alle Assistenten der SBS-Consolen Startseite habe ich erneut durchlaufen und Fehler im SMTP Connector die dort angezeigt wurden durch manuelles Anpassen im Exchange Manager (Zugriffsberechtigungen waren völlig verstellt) beheben können. Also alle Assistenten laufen un fehlerfrei durch, aber ich finde das Zertifikat nicht um es auf iPhones zu installieren... die certsrv Seite läuft ebenfalls nicht (diese allerdings mit Fehler 500 - interner Serverfehler)...

    Was kann ich tun? Jemand einen Tip ausser "alles neuinstallieren"?

    Eine "alles auf Werkseinstellung" Funktion gibt es da wohl nicht....?

    Montag, 11. März 2013 22:46

Antworten

Alle Antworten

  • Wir haben bei uns im DNS-Server eine neue Forward-Lookupzone erstellt (remote.domain.tld) und darin einen Host A Eintrag mit der IP des SBS. So wie ich das nämlich sehe habt Ihr bis jetzt nur eine Weiterleitung, aber keine Namensauflösung.

    Zertifikate kann man übrigens auch manuell exportieren: start => Ausführen => mmc => Snap-in hinzufügen => Zertifikate

    Volker


    Und Abends ein Glas Wein von AMAVINO

    Dienstag, 12. März 2013 08:15
  • <object height="1" id="plugin0" style=";z-index:1000;" type="application/x-dgnria" width="1"><param name="tabId" value="{992971D3-882B-475E-AD3E-56268CD9F3DC}" /></object>

    Hallo,

    im DNS ist die Forward-Lookup Zone remote.domain.com schon vorhanden (incl. dem Host A Eintrag).

    Das Zertifikat habe ich genau so auch schon in allen Varianten exportiert und mir auf das iPhone geschickt. Mit dem Ergebnis, dass das iPhone sagt es sei "nicht vertrauenswürdig" und der Zugriff klappt auch nicht.

    Die Ports der Firewall sind weitergeleitet an den SBS und die Windows eigene Firewall ist aus, trotzdem kann ich den Exchange nicht erreichen. iPhone Meldung: "Die Verbindung mit dem Server ist fehlgeschlagen"

    Ich habe in letzter Zeit sehr häufig iPhones angebunden, aber dann habe ich immer das "fertige" Zertifikat aus öffentliche Downloads genommen. Wann legt der SBS denn dort das Zertifikat ab? Wie und vor allem welche Zertifikate kann ich denn über das Zertifikate Snap-in löschen und neue anlegen, damit er dieses dann auch dort wieder ablegt?

    Außerdem klappen die ganzen Websites nicht (owa, remote, autodiscover und certsrv). Darum war eine Frage, ob man IIS komplett de- und neuinstallieren kann ohne Exchange zu schrotten...

    Viele Grüße

     David


    • Bearbeitet Drahn80 Dienstag, 12. März 2013 11:49
    Dienstag, 12. März 2013 11:46
  • Ich würde Dir empfehlen, den Internetverbindungsassistent noch einmal auszuführen. Der wird Dir einiges wieder gerade biegen, was verstellt wurde. Ob das reicht, wird sich dann zeigen ;)

    Übrigens gibt es einen KB-Artikel, der erklärt, wie Du den IIS neu installieren kannst:

    http://support.microsoft.com/kb/320202/de

    Gruß

    -Axel-


    Niveau sieht nur von unten aus wie Arroganz

    Dienstag, 12. März 2013 23:48
  • Ein erster Ansatz wäre:

    Reinstall the Client Access Role in Windows Small Business Server 2008
    http://technet.microsoft.com/en-us/library/dd767439(v=ws.10).aspx

    Danach müsste man sehen, welche weiteren Probleme hinsichtlich des SBS bestehen.

    --

    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net

    • Als Antwort markiert Drahn80 Freitag, 15. März 2013 13:01
    Freitag, 15. März 2013 10:19
    Moderator
  • <object height="1" id="plugin0" style=";z-index:1000;" type="application/x-dgnria" width="1"><param name="tabId" value="{67B9CF4D-03B5-4D4D-84E0-447597B276AF}" /></object>

    Wunderbar, nachdem ich über den PS Befehl

    "Set-ExecutionPolicy Unrestricted"

    das ausführen des unter Punkt 3 beschriebenen PS1 Scriptes erlaubt (vorher kam immer ein Signierungs-Fehlermeldung) habe konnte ich dieses erfolgreich ausführen. Danach funktionierte auch sofort der Zugriff via iPhone (mit Zertifikatswarung allerdings)! Haben den Assistenten für die Internetadresse und das Zertifikat dann noch einmal erfolgreich ausgeführt.

    Es läuft, allerdings erscheint in öffentliche Downloads nach wie vor das Zertifikat nicht welches ich bei anderen Kunden dann per Mail auf das iPhone geschickt habe und es so installieren konnte. Im Moment kann ich am iPhone nur die Warnung ignorieren und trotzdem auf die Mails zugreifen...

    Wenn jetzt noch jemand eine Lösung dafür findet wäre EXTRAKLASSE aber funktionieren tut es jedenfalls auch so schonmal!

    ALSO: DANKE HERR REDELBERGER!

    Freitag, 15. März 2013 13:08
  • Nach dem "Windows Small Business Server 2008 Repair Guide" sollte es wie folgt gehen:

    [..]
    Run the Fix My Network Wizard to create a new certificate installation package and server certificate.
    [..]

    Wenn der "Fix My Network Wizard" einen Fehler dabei wirft ist die zugehörige Log-Datei zu analysieren:

    Logs events of the "Fix My Network" wizard
    C:\Program Files\Windows Small Business Server\Logs\fncw.log

    Source: http://blogs.technet.com/b/sbs/archive/2008/10/01/key-small-business-server-2008-log-files.aspx

    Ansonsten hilft evtl. nur die harte Variante:

    ACHTUNG: Sämtlich mit dieser CA ausgestellten Zertifikate werden ungültig!

    How to reinstall the Certification Authority role
    http://technet.microsoft.com/en-us/library/dd421659.aspx

    --

    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net

    Montag, 18. März 2013 18:46
    Moderator